cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Announcement“Cisco Design Thinking Workshop”. Cisco Small Business is excited to invite its Silicon Valley customers to an exclusive interactive one-day session between customers and product Managers.  If you are interested in this exclusive workshop, please fill out the Registration Form. For more information, please check out our FAQ


Get the latest new and information the November issue of the Cisco Small Business Monthly Newsletter

1762
Views
0
Helpful
10
Replies
Beginner

spa921 rebooting continually.

Hello

I've been using a linksys spa921 for about 6 months now.  I love it.

Unfortunatly, I've been having issues with it recently.

In the last few days, it starts rebooting spontaneously.  The red light at the top goes on, as well as the mute light and the speaker light.  Then, the phone shuts down and starts up again, usually unsuccessfully - I need to unplug it and plug it in again.

I've done a factory reset a number of times.  It works for a day or so, but then the problem starts again.

I've tried to update the firmware, but I am unable to do this.  I keep getting "upgrade failed: no response from the SPA"

I've seen online that this has been an issue with some people, and the advice is always to upgrade the firmware.

What should I do.  help!

Everyone's tags (1)
10 REPLIES 10
Frequent Contributor

Re: spa921 rebooting continually.

Danilo,


Do you have an option of plugging directly into the phone and upgrading the firmware being directly connected to the phone.


This way we can eliminate the possiblity of a ip conflict and you shouldn't have any issues upgrading it.

Beginner

Re: spa921 rebooting continually.

ok.  but now we get to see how much of a newbie I am....

I plug the phone directly into my laptop (this is what you mean, right?), and it just hangs on "checking DNS" after having hung on "initializing network" for a few mins

Beginner

Re: spa921 rebooting continually.

ok.  I connect my laptop to the phone.  Even though it still hangs on "checking DNS", I was able to go into the settings and

check its IP.  I was able to log into the phone using the web interface.

When I try to update the firmware, I get the same thing - no response from the SPA

Highlighted
Beginner

Re: spa921 rebooting continually.

Danilo,

Check your current firmware on your 921 and check the version you are trying to upgrade to. I'm assuming everyone's on the same IP subnet?

Hope to hear from you soon.

Lindsey

Beginner

Re: spa921 rebooting continually.

I'm assuming that this is under "software version" in the web interface.  It's telling me 4.1.10 (b)

I'm trying to upgrade to 5.1.8

I'm on the same subnet

Beginner

Re: spa921 rebooting continually.

Thank you David and Lindsey for trying to help me! 

Beginner

Re: spa921 rebooting continually.

Danilo,

No problem, it's our pleasure.

I don't recall any upgrade issues from a 4.x release to the 5, but since that last firmware revision by Linksys released in 2006, my first "guess" would be to ask you what OS you are upgrading with. I'd try my best for an XP machine if you got it.

If you need a sanity check or to make sure the device just hasn't died, call in to 1 866 606 1866 and select the VoIP option for your Small Business device, provided you are in warranty (you stated you owned the device for less than a year. Since the phone is end of life, if you have your proof of purchase, keep it handy) we can possibly remote into your pc and help try the upgrade.

My experience with the older upgrade utilities for the spa9xx series is use XP. Sounds like everything else is in order. Don't do your upgrade remotely, and when in doubt, download the entire thing again. Just to be sure.

Ping me back if you need anything else!

Thanks!

Lindsey

Beginner

Re: spa921 rebooting continually.

uh-oh.  I don't have windows xp.  I have windows 7.

I had originally downloaded the upgrade on my mac and passed it to the pc over the network.  Per your suggestion, I downloaded the updater onto the pc directly.  It was a different interface than the one I was using before - it gave me the option to recover firmware, whereas the other hadn't.

I just moved and my house is a mess.  Hopefully, I can find the receipt somewhere 

I tried with the laptop and the modem plugged into the same network and the laptop plugged directly into the phone, but I'm not sure I have my tcp/ip settings correct when I do that.  I'm kind of a newbie to using windows.

Beginner

Re: spa921 rebooting continually.

Quick shot in the dark suggestion:

If in win7, right click the .exe for the FW upgrade utilitiy, go to properties and compatibility and run in compatibility mode for xp. I'm not right in front of a win7 machine to give you the exact direction, but I have had success doing this with some other linksys based utilities to ease the transition to vista/7. Not sure if 32/64 bit OS has an effect, but it wouldn't suprise me.

Good luck!

Lindsey

Beginner

Re: spa921 rebooting continually.

I wasn't able to do that with the version I re-downloaded recently.  It didn't give me that option.

I did it with the other updater (upg-spa941) and it didn't make a difference.