cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1377
Views
0
Helpful
6
Replies
Highlighted
Beginner

UC320 and SIP trunk issues

Hello All,

Just need a pointer here if anyone can assist.  Basically I have a SIP trunk setup on a UC320. It is setup as under outbound trunks so all good from what I can gather.  When I look at the Status Overview of the trunks it says registration failed.  I enabled syslog and ticked the relevant boxes to restrict the visible logs to SIP for the trunk but I cannot see the trunk try to register.  I've rebooted and still nothing in the UC320 syslog of thetrunk attempting to register.   All I get is below which looks like just voicemail.  There is the statment which I cannot find any information on.  127.0.0.1 is local interface on the UC320 so I can't understand what this relates to.
Jan  5 16:54:44 UC320W user.debug voice: SIP message from source IP 127.0.0.1 is blocked.

Anyone got any ideas?

Thanks in advance

David

Syslog excerpt

Jan  5 16:54:45 UC320W user.debug voice: SUBSCRIBE sip:ivms@127.0.0.1:7060 SIP/2.0

Via: SIP/2.0/UDP 192.168.254.241:5064;branch=z9hG4bK-d8b8d354

From: Voice Mail <sip:ivms@127.0.0.1>;tag=643030a37fd485bf

To: Voice Mail <sip:ivms@127.0.0.1>

Call-ID: dd63e573-427fd72f@192.168.254.241

CSeq: 26052 SUBSCRIBE

Max-Forwards: 70

Contact: Voice Mail <sip:ivms@192.168.254.241:5064;ref=ivms>

Expires: 2147483647

Event: message-summary

User-Agent: Cisco/UC320W-2.3.2(6)

Allow-Events: talk, hold, conference, x-spa-cti

Content-Length: 0

Jan  5 16:54:45 UC320W user.debug voice: SIP/2.0 200 OK

Via: SIP/2.0/UDP 192.168.254.241:5064;branch=z9hG4bK-d8b8d354

From: Voice Mail <sip:ivms@127.0.0.1>;tag=643030a37fd485bf

To: Voice Mail <sip:ivms@127.0.0.1>;tag=as290d3607

Call-ID: dd63e573-427fd72f@192.168.254.241

CSeq: 26052 SUBSCRIBE

User-Agent: Asterisk PBX

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER

Expires: 3600

Contact: <sip:ivms@127.0.0.1:7060>;expires=3600

Content-Length: 0

Jan  5 16:54:45 UC320W user.debug voice: SIP message from source IP 127.0.0.1 is blocked.
Jan  5 16:54:46 UC320W user.debug voice: SIP message from source IP 127.0.0.1 is blocked.
Jan  5 16:54:47 UC320W user.debug voice: SIP message from source IP 127.0.0.1 is blocked.
Jan  5 16:54:48 UC320W user.debug voice: SIP message from source IP 127.0.0.1 is blocked.
Jan  5 16:54:49 UC320W user.debug voice: SIP message from source IP 127.0.0.1 is blocked.

6 REPLIES 6
Highlighted
Enthusiast

Hi David,

Did you check the box "Require Registration" at SIP/BRI Trunks page? If yes, please send your configuration through Configuration Utility -> Services -> Feedback, input "Attention wenyang@cisco.com" at Issues or suggestions section. I will take a look and get back to you.

Best regards,

Wendy

Highlighted

Hi Wendy,


Thanks for your offer to assist which is greatly appreciated.

Since receiveing your response the SIP provider found an issue in their configuration and now registration is ok but I have another issue. I had another issue which was related to outbound calling and no audio but again this was a SIP provider setup issue.

When calls come inbound they are set to Simultaneous ring a huntgroup of all extensions.  However when you pick up the call on a handset the others keep ringing.  Any ideas?

Kindest Regards

David

Highlighted

Hi David,

If you dial from an internal extension to this simutaneous huntgroup, do you have the same issue? If there is any 2-way audio between the answering user and the PSTN user? How many members are in this huntgroup?

Best regards,

Wendy

Highlighted

Hello Wendy,

Thanks for helping.

If you dial internally the hunt group 200 (6 members) all phones ring.  When one answers the other stop ringing.  This appears to be ok and the problem is from inbound calls from outside.

When a SIP call comes in from outside and rings the hunt group 200 if 1 handset picks up the others continue to ring.  Even the handset you pick the call up on keeps ringing.  You also cannot transfer the call or have any of the options appear on the screen of the phone that you would normally expect to see.  The systems is running 2.3.2 (6)

There is no pstn connected.

Kindest Regards

David

Highlighted

Ok Found this to be a combination of an issue with the setup at the SIP provider side and port forwarding.  Resolved by natting one of our public IPs to the UC320 and all ok.

Thanks for the help everyone (especially Wendy)

Highlighted

Hi David,

Your feedback is greatly appreciated. It's my pleasure working with you!

Best regards,

Wendy