cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Please be advised, the GuideMe Wizard is no longer available on the Small Business Support Community. For search capability please use the community search field to find content related to Cisco Small Business documents, videos, and discussions.
887
Views
0
Helpful
5
Replies
Highlighted

UC500 Missing first zero in incoming calls

Hi all

I have the problem that the first zero in a number is missing in incoming calls. So the number is always shown as 12345 instead of 012345. Does anyone know how to solve this problem?

I appreciate your help.

Regards

Alex

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: UC500 Missing first zero in incoming calls

Hi Alex,
I hope you are familiar with the CLI and can add to the configuration:

voice translation-rule 30000
rule 1 /\(^.+\)/ /00\1/ type national national
rule 2 /\(^.+\)/ /000\1/ type international international
rule 3 /\(^.+\)/ /0\1/ type any subscriber

voice translation-profile NULL_DAZU

translate calling 30000

and for each trunk voice-port:

voice-port 0/1/0

translation-profile incoming NULL_DAZU


Alternatively, you can add the translation profile to the incoming dial-peers or trunkgroups.

I hope my English was adequate. If you still need help, contact me.

Best Regards
Maurycy

P:S. Ja, ich bin aus Deutschland und kann verschiedene Probleme mit der UC500-Familie oder allgemein CME lösen.

5 REPLIES 5
Beginner

Re: UC500 Missing first zero in incoming calls

Are you from Germany? I would love to use the German language.

Re: UC500 Missing first zero in incoming calls

Yes, I'm from Germany. From my side it's fine to go ahead with german but others would have problems to follow our conversaton  .. however, lets switch and translate it back to english ..

Bist du ebenfalls aus Deutschland? Und vor allem, hast du eine Idee wie ich mein Problem fixen kann?

Beste Grüße / Cheers

Alex

Beginner

Re: UC500 Missing first zero in incoming calls

Hi Alex,
I hope you are familiar with the CLI and can add to the configuration:

voice translation-rule 30000
rule 1 /\(^.+\)/ /00\1/ type national national
rule 2 /\(^.+\)/ /000\1/ type international international
rule 3 /\(^.+\)/ /0\1/ type any subscriber

voice translation-profile NULL_DAZU

translate calling 30000

and for each trunk voice-port:

voice-port 0/1/0

translation-profile incoming NULL_DAZU


Alternatively, you can add the translation profile to the incoming dial-peers or trunkgroups.

I hope my English was adequate. If you still need help, contact me.

Best Regards
Maurycy

P:S. Ja, ich bin aus Deutschland und kann verschiedene Probleme mit der UC500-Familie oder allgemein CME lösen.

Re: UC500 Missing first zero in incoming calls

Hi Maurycy

Thanks for your quick response. Will test it tonight. To be honest I'm not familar with CLI, anyway that's the chance to learn it ..

If I want to have a second 0, to have the comfort to place a call directly from to call log I have to update the rules as following:

voice translation-rule 30000
rule 1 /\(^.+\)/ /000\1/ type national national
rule 2 /\(^.+\)/ /0000\1/ type international international
rule 3 /\(^.+\)/ /00\1/ type any subscriber

Is my thought correct?

I've got a second question. Hope thats ok for you. I us from time t time the call forward feature to my mobile. Unfortunately my mobile shows the number from my phone and not from the caller.

I guess here I've to add also a translation rule?

Dein Englisch ist perfekt, keine Sore .. noch eine dritte Frage. Ist die Anbindung eines Blackberrys an die UC520 möglich?

Beste Grüße

Alex

Re: UC500 Missing first zero in incoming calls

Hi Maurycy

I've updated my config and it works great. You made my day dude! Many many thanks for your help. I really appreciate it!

Please ignore my question about the further 0. This was also solved with the commands.

Hope you can help me with my two further questions

If you'll come to FFM let me know, a beer is waiting for you

Cheers

Alex