cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4773
Views
0
Helpful
14
Replies

UC520 Incoming call issue

vincentdenison
Beginner
Beginner

Hi,

I change my SIP provider for Selfone (French Provider).

They use for registration an ID with a "star" in the middle. Example: 0027*001

I can register correctly and can pass ouside call.

I have an issue with incoming calls.

When I debug ccsip messages, I see the incoming call but it is rejected with a 500 Internal Server Error (see debug below).

Could someone can help ?

Thx.

Vincent.

Sent:
OPTIONS sip:109.237.253.26:5060 SIP/2.0
Via: SIP/2.0/UDP 213.219.187.2:5060;branch=z9hG4bK2AA1249E
From: <sip:213.219.187.2>;tag=383AF3A8-16D0
To: <sip:109.237.253.26>
Date: Mon, 01 Oct 2012 13:48:11 GMT
Call-ID: 794DBE99-B0511E2-9B71DD43-41074A7C@213.219.187.2
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
CSeq: 101 OPTIONS
Contact: <sip:213.219.187.2:5060>
Content-Length: 0


005893: Oct  1 15:48:11.289: //23049/000000000000/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 213.219.187.2:5060;branch=z9hG4bK2AA1249E
From: <sip:213.219.187.2>;tag=383AF3A8-16D0
To: <sip:109.237.253.26>;tag=43d2f2651b38c5c10e7b50ad918afba5.2628
Call-ID: 794DBE99-B0511E2-9B71DD43-41074A7C@213.219.187.2
CSeq: 101 OPTIONS
Server: VoipNow
Content-Length: 0


005894: Oct  1 15:48:14.485: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:0027*002@213.219.187.2:5060 SIP/2.0
Record-Route: <sip:109.237.253.26;lr=on;ftag=as29b5fdbb;did=f8b.fb03b571>
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bK5941.5d48b1d6.0
Max-Forwards: 69
From: "32475XXXXXX"<sip:32475XXXXXX@109.237.253.26>;tag=as29b5fdbb
To: <sip:0027*002@109.237.253.26>
Call-ID: 0dca7a7813b8de8560ab2c3633a579f3@109.237.253.26
Contact: <sip:32475975423@109.237.253.26:5060>
CSeq: 102 INVITE
User-Agent: SELFONE
Date: Mon, 01 Oct 2012 13:49:40 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces, timer
X-voipnow-did: 3261480153
X-voipnow-extension: 0027*002
X-voipnow-infrastructureid: e009f0a022fc
X-voipnow-did: 3261480153
Content-Type: application/sdp
Content-Length: 768

v=0
o=root 1698622377 1698622377 IN IP4 109.237.253.26
s=Asterisk PBX 1.6.1.4
c=IN IP4 109.237.253.26
b=CT:384
t=0 0
m=audio 18788 RTP/AVP 0 8 3 112 5 10 7 110 97 111 9 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:3 GSM/8000
a=rtpmap:112 AAL2-G726-32/8000
a=rtpmap:5 DVI4/8000
a=rtpmap:10 L16/8000
a=rtpmap:7 LPC/8000
a=rtpmap:110 speex/8000
a=rtpmap:97 iLBC/8000
a=fmtp:97 mode=30
a=rtpmap:111 G726-32/8000
a=rtpmap:9 G722/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -
a=ptime:20
a=sendrecv
m=video 14190 RTP/AVP 26 31 34 98 99 104
a=rtpmap:26 JPEG/90000
a=rtpmap:31 H261/90000
a=rtpmap:34 H263/90000
a=rtpmap:98 h263-1998/90000
a=rtpmap:99 H264/90000
a=rtpmap:104 MP4V-ES/90000
a=sendrecv

005895: Oct  1 15:48:14.497: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bK5941.5d48b1d6.0
From: "32475XXXXXX"<sip:32475XXXXXX@109.237.253.26>;tag=as29b5fdbb
To: <sip:0027*002@109.237.253.26>;tag=383B005C-B83
Date: Mon, 01 Oct 2012 13:48:14 GMT
Call-ID: 0dca7a7813b8de8560ab2c3633a579f3@109.237.253.26
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


005896: Oct  1 15:48:14.545: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:0027*002@213.219.187.2:5060 SIP/2.0
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bK5941.5d48b1d6.0
From: "32475XXXXXX"<sip:32475XXXXXX@109.237.253.26>;tag=as29b5fdbb
Call-ID: 0dca7a7813b8de8560ab2c3633a579f3@109.237.253.26
To: <sip:0027*002@109.237.253.26>;tag=383B005C-B83
CSeq: 102 ACK
Max-Forwards: 70
User-Agent: VoipNow PBX
Content-Length: 0

1 Accepted Solution

Accepted Solutions

Hi,

Looking at the debug the translation rule 4000 is not working but the call is now allowed to enter the UC...So we are half way there.

Try replacing rule 4000 with this instead:

voice translation-rule 4000

rule 1 /^.*/ /10/

If this does not work also this may be an option:

voice translation-rule 4000

rule 1 /.*/ /10/

I’m sorry for the trial and error approach on this but it is very uncommon to have a “*” in the incoming caller ID.  If this works let me know.  Otherwise please post both of the debugs for the call and I will continue to work on this.

Thanks,

Jason Nickle

View solution in original post

14 Replies 14

Darren DeCroock
Enthusiast
Enthusiast

Hello Vicent,

It sounds like an Access List problem.

voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL

access-list 2

access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL

access-list 2 remark SDM_ACL Category=1

access-list 2 permit 12.194.20.31

access-list 2 permit 12.194.18.31

access-list 2 deny   any

Make sure that your SIP providers address is included, so the incoming call is allowed.

Something like this:  (The Access List number (2) may be different in your config.)

voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL

access-list 2

access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL

access-list 2 permit 109.237.253.26

access-list 2 deny   any

Thank you,

Darren

An easy test to see if the Access List is causing the problem:

Config T

voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL

no access-list 2

Then make a test call.

I would not leave the access list disabled, as this could open you up for toll-fraud.