cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2431
Views
9
Helpful
11
Replies
Highlighted
Beginner

UC520 problems after IOS/CME upgrade

I wanted to try out Jabber so I decided to upgrade the IOS/CME only from

uc500-advipservicesk9-mz.151-2.T4 (UC520 8.2)

to

uc500-advipservicesk9-mz.151-4.M4b (UC520 8.6)

Ever since the upgrade, I'm having the following problems -

1. MWI not working

2. Cannot add new ephones or dial-peers without rebooting the system.  I'm getting this "ERROR: could not add peer" error message.  When I reload the UC520, I'm able to add again.  Could this be caused by some type of memory/resource leak?

Anyone else having similar issues?  I'm tempted to downgrade to 151-2.T4 to see if the problem happens with that version as well.

Also, is there an updated ROM monitor file for the UC520? 

My UC520 is still on

ROM: System Bootstrap, Version 12.4(11r)XW, RELEASE SOFTWARE (fc1)

Thank you

11 REPLIES 11
Highlighted
Beginner

For "1.MWI not working" , have you tried refleshing Messgage Waiting Indicator setting  in CUE interface ?

Highlighted
Enthusiast

Hello jyoopro4ia,

A few things to check here:

1. First find what your MWI on and off DNs are.

2. Then do a show voice port summary and see if the MWI ephone dns are idle or in use.

3. If the dns are idle, do a csim start A800... where ... is the extension. This should turn on MWI on the phone

4. If the MWI dns are idle and you can force the MWI on/off, check if you have this in the configuration:

     voice service voip

     sip

       bind control source-interface Vlan100

       bind media source-interface Vlan100

If so, remove those bind statements.

4b. If the MWI dns are in use, kill the call to the dns, delete the dns, and recreate them.

5. Test the dns again using the csim start A800...

6. If that still fails we need to configure the UC to use unsolicted MWI notification

     In CME:

     sip-ua

     mwi-server ipv4:10.1.10.1 expires 3600 port 5060 transport udp unsolicited

     In CUE:

     ccn subsystem sip

     mwi sip unsolicited

     end

     mwi refresh all

As far as the dial peer issue you can check the memory and processor using these commands:

show memory debug leak

show processes cpu history

Do you get a crash log or error code from the UC after the dial peers are added and the UC reloads?

Thanks,

-john

Highlighted

I have been fighting this MWI issue as well for a week, your post just sorted me out in about 5 minutes!

Items 1-4 worked like a charm, as soon as I removed those binds and refreshed things and poof, lights all over the place.

Thanks.

That should have been a 5 star rating, anyway I can change that?

Highlighted

John,

I'm looking fwd to trying to this when I return to office.  From Brian's comments, it looks promising!

i'll let you know about #2 as well.

Highlighted

Looks like removing those binds fixed the issues.  Thanks John.

Time to look at the dial peer issue......

Highlighted

John,

Without reloading, I cannot add dial peers (or ephone-dns).  Only immediately after a reload, I am able to do so.  It looks like reloading clears up resources to allow me to add.

As I just mentioned, I am not able to add ephone-dn's as well.  I get the same error message.

ERROR: could not add peer

I ran both show commands you recommended and I don't see anything too crazy... Any other thoughts?

Highlighted

Hello jyoopro4ia,

Under telephony-service you should see the max ephones and ephone-dns listed. Can you verify that the additional ephones and ephone-dns are not exceeding the limit?

Thanks,

-john

Highlighted

correct.  I can verify that.

I am not going over the limit listed under telephony-service.

Highlighted

John,

The two lines you had me remove -

     voice service voip

     sip

       bind control source-interface Vlan100

       bind media source-interface Vlan100

I read that when using Cisco Jabber above two lines are required.  Can you confirm that?

Highlighted

Hello jyoopro4ia,

Not that I'm aware of. Can you provide me the documentation where you saw that?

Here is the guide for Jabber on UC500: https://supportforums.cisco.com/docs/DOC-24508

If you have issues with Jabber after removing those bind statements, you can use the unsolicitied MWI notification method.

Thanks,

-john

Highlighted
Hall of Fame Master

2. Cannot add new ephones or dial-peers without rebooting the system.  I'm getting this "ERROR: could not add peer" error message.  When I reload the UC520, I'm able to add again.  Could this be caused by some type of memory/resource leak?

Seems to me you're running in a know issue of memory leak, that cisco has never really dealt with. See

https://supportforums.cisco.com/message/1121799

and more cases too.

Personally, I would try cleaning and reducing configuration via CLI