cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

699
Views
15
Helpful
12
Replies
Highlighted
Beginner

UC520W Restore Issues

Hi,

I just purchased a used UC520W for home office. I reset to factory defaults by copying the factory config (UC520W-16U-4FXO-K9-factory.cfg) to the startup.

I plug a PC into 0/1/0 (1st of the 8 POE Ports), and the machine is not reciving a IP from DHCP. I tried to set a static IP, etc however no matter what I do I cannot connect to the UC520 from CCA.

This UC520 will be used only for Call Manager. Wish to just plug into network along with the phones. Routing & switching is done with other cisco gear. Also, I wish to use the WLAN in the UC520 for a single ssid for my 7925's to connect to.

Phones & PC's are all on one VLAN now.

Any help would be appeticated.

Thank You!

12 REPLIES 12
Highlighted
Hall of Fame Master

UC520W Restore Issues

Wrong forum, post in "small business voice - UC500". You can move your post using the actions panel on the right.

Highlighted
Beginner

UC520W Restore Issues

Hi bndbrennan,

Can you get the following outputs:

show run interface fa 0/1/0

show run | se dhcp

You need to ensure that the interface you are plugged into is configured as untagged in your data vlan.  Also, you need to ensure you have DHCP configured correctly for that VLAN. 

Let me know,

-Trent Good

-Trent Good ** Please rate useful posts! **
Highlighted
Beginner

UC520W Restore Issues

Hi Trent,

Thank You. Below is the "show run interface fa 0/1/0" and the "show run" as "show run | see dhcp" did not return anything.

Router>en

Router#show run interface fa 0/1/0

Building configuration...

Current configuration : 35 bytes

!

interface FastEthernet0/1/0

end

Router#

Router#show run              

Building configuration...                        

Current configuration : 1636 bytes                                 

!

version 15.1           

no service pad             

service timestamps debug datetime msec                                     

service timestamps log datetime msec                                   

no service password-encryption                             

!

hostname Router              

!

boot-start-marker                

boot-end-marker              

!

!

!

no aaa new-model               

!

crypto pki token default removal timeout 0                                         

!

!

dot11 syslog           

ip source-route              

ip cef     

!

!

!

!

!

no ipv6 cef          

!

multilink bundle-name authenticated                                  

!

!

!

!

!

!

!

!

!

!

voice-card 0           

!

!

!

license udi pid UC520W-16U-4FXO-K9 sn FHK114312W2                                                

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0                        

no ip address             

shutdown        

duplex auto           

speed auto          

!

interface Integrated-Service-Engine0/0                                     

no ip address             

shutdown        

!

interface FastEthernet0/1/0                          

!

interface FastEthernet0/1/1                          

!

interface FastEthernet0/1/2                          

!

interface FastEthernet0/1/3                          

!

interface FastEthernet0/1/4                          

!

interface FastEthernet0/1/5                          

!

interface FastEthernet0/1/6                          

!

interface FastEthernet0/1/7                          

!

interface FastEthernet0/1/8                          

!

interface Dot11Radio0/5/0                        

no ip address             

shutdown        

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0                                                                               

54.0    

station-role root                 

!

interface Vlan1              

no ip address             

!

ip forward-protocol nd                     

!

no ip http server                

no ip http secure-server                       

!

logging esm config                 

!

!

!

!

!

control-plane            

!

!

voice-port 0/0/0               

!

voice-port 0/0/1               

!

voice-port 0/0/2               

!

voice-port 0/0/3               

!

voice-port 0/1/0               

!

voice-port 0/1/1               

!

voice-port 0/1/2               

!

voice-port 0/1/3               

!

voice-port 0/4/0               

auto-cut-through                

signal immediate                

input gain auto-control                       

description Music On Hold Port                              

!

!

!

!

!

line con 0         

no modem enable               

line aux 0         

line 2     

no activation-character                       

no exec       

transport preferred none                        

transport input all                   

line vty 0 4           

login     

transport input all                   

!

end

Highlighted
Beginner

Re: UC520W Restore Issues

Hi bndbrennan,

You don't have any IP address information on the device.  Also, this doesn't look like the factory default config.  It looks like the result of a write erase.

You may trying to set the config register to 0x2102 as it looks like it is booting to the initial config:


conf t
config-register 0x2102

Typically on a UC640/560 the factory default file is about 23kb,
yours is about 1.6kb.  Not sure if there is a difference between
the 520 factory default and 540/560 factory default though.

Otherwise to get access via CCA try the following:

conf t

int vlan 1

ip address 192.168.10.1 255.255.255.0

no shut

exit

ip dhcp pool data

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

You may double check your factory default file as there are some voice specific information that is included in it which your configuration doesn't appear to have.

-Trent Good

** Please rate useful posts! **

-Trent Good ** Please rate useful posts! **
Highlighted
Beginner

UC520W Restore Issues

I ran those commands, and also set an ip address for the Integated-Service-Engine0/0

PC gets address from DHCP when plugged into POE switch port 1. Address is 192.168.10.2

I open CCA, I try to add 192.168.10.1 or 192.168.9.1 (Integated-Service-Engine0/0).

I am prompted with a login window stating ...realm "level_15_access" on "ipaddress"'

Is this what I want to happen? What would the default login be? Do I connect to the Integated-Service-Engine0/0 or the 192.168.10.1 address?

Highlighted
Beginner

UC520W Restore Issues

Hi bndbrennan,

Try the following:

username cisco privilege 15 secret 4  tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY

enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY

-Trent Good

** Please rate useful posts! **

-Trent Good ** Please rate useful posts! **
Highlighted
Beginner

UC520W Restore Issues

Thank You.

I was able to get access to the UC520 via CCA via the 192.168.10.1 address. However, when loading any of the telephony items, it says "loading voice related data"..The progress bar fills up and it keeps going, right now this one has been up for 54 mins.

Highlighted
Enthusiast

UC520W Restore Issues

Hello,

Based upon the previous configuration you posted, it doesn't appear that the factory default was completed, as there a lots of default configurations missing.

How did you restore the factory configuration?

Thanks,

-john

Highlighted
Beginner

UC520W Restore Issues

Trent- Thank you very much for your help!

Hi John,

I copied the file (UC520W-16U-4FXO-K9-factory.cfg) that was in flash, to startup...

Highlighted
Enthusiast

UC520W Restore Issues

Hello,

Im wondering if that file has the actually factory config. You might want to download Software Pack 8.6.2 and grab the latest factory config file from there.

You can check the factory config file in CLI by doing the following:

more flash:/UC520W-16U-4FXO-K9-factory.cfg

The factory config files should have a default cisco admin user, 192.168.10.1 programmed on vlan1, the voicemail module Integrated-Service-Engine0/0 IP configuration, etc. That information doesn't appear present in your factory config file.

Thanks,

-john

Highlighted
Beginner

UC520W Restore Issues

Thank You. I have downloaded the pack, and go to install/upgrade before doing a restore in CCA, and the wizard hangs up at the "Ping Test from CUE to CCA". Im going to reboot everything and give it another try now.

Highlighted
Enthusiast

UC520W Restore Issues

Hello,

According to the config above, the voicemail system, CUE, can't communicate with your PC. This is because the voicemail system, doesn't actually have an IP address in your configuration.

From command line, you need to copy the factory config file into flash, save that config to the startup config, reload the UC, and then do the upgrade in CCA. After that point, you can do a restore or start the initial config.

Thanks,

-john