cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1472
Views
0
Helpful
17
Replies
Mike Gann
Beginner

UC540 Auto attendant fails with inncoming international calls

We're a small business located in California and we self installed a UC540 system a couple of months ago. We followed the wizards to setup the system, so we are by no means experts. During this time we have had multiple reports of the auto attendant not responding to keypresses with inbound international callers. We had had these reports from callers in Switzerland and Great Britain.

Are there any known issues regarding this or perhaps a setting I should change?

As far as we know the system is working great with domestic calls.

Thanks,

Mike

17 REPLIES 17
johschaf
Enthusiast

Hello,

Generally speaking the keypresses, aka DTMF, should work in all instances if it works with domestic calls.

If you search the running config what do you see for how your DTMF is configured?

dtmf-relay XXX

Can you test and make sure the AA is accepting DTMF from domestic calls?

What version are you running?

Thanks,

-john

Hi John -

Thanks for the reply. The AA has been working great with domestic calls.

As far as checking the DTMF configuration I'm not sure how to do this. Is this through the console port? And if it is, do you know what the serial port settings should be on the laptop?

Thanks,

Mike

Hello,

No you can do this from the Cisco Configuration Assistant

Troubleshooting -> IOS Exec Commands -> Show running-config

Then search for dtmf-relay

To check your version

Monitoring -> Telephony -> Software Pack

In order to get to the bottom of this we might have to recreate the issue while running some debugs. If the UC is under warranty or contract, we can more than likely assist you with this.

Thanks,

-john

Hi John -

The requested information is below. The unit is under warranty.Please let me know if the information below shows anything.

Software Pack: 8.6.2

IOS: 15.1(4)M6

CME: 8.6

CUE: 8.6.5

Here is the DTMF info from the running-config:

voice register pool  1

dtmf-relay rtp-nte

voice register pool  2

dtmf-relay rtp-nte

dial-peer voice 2000 voip

dtmf-relay rtp-nte

dial-peer voice 2001 voip

dtmf-relay sip-notify

dial-peer voice 2012 voip

dtmf-relay sip-notify

Hello,

Thanks, that was exactly what I was looking for. These 2 dial-peers don't like right in regards to the DTMF settings. Can you post the full dial-peers?

dial-peer voice 2001 voip

dtmf-relay sip-notify

dial-peer voice 2012 voip

dtmf-relay sip-notify

The dtmf-relay sip-notify was replaced with the dtmf-relay rtp-nte in later software versions, so I'm think we need to change that.

Thanks,

-john

Hi John -

Here are the full details:

dial-peer voice 2001 voip

description ** cue auto attendant number **

translation-profile outgoing PSTN_CallForwarding

destination-pattern 398

b2bua

session protocol sipv2

session target ipv4:10.1.10.1

voice-class sip outbound-proxy ipv4:10.1.10.1 

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 2012 voip

description ** cue prompt manager number **

translation-profile outgoing PSTN_CallForwarding

destination-pattern 397

b2bua

session protocol sipv2

session target ipv4:10.1.10.1

voice-class sip outbound-proxy ipv4:10.1.10.1 

dtmf-relay sip-notify

codec g711ulaw

no vad

Hello Mike,

I'd like you to make some adjustments to the DTMF settings on those dial-peers. You will need to do this in the CLI.

conf t

dial-peer voice 2001 voip

dtmf-relay rtp-nte

dial-peer voice 2012 voip

dtmf-relay rtp-nte

end

wr mem

Then test the AA if possible.

Thanks,

-john

Hi John -

I need a little help with the CLI.

I have my laptop connected to the console port. I enter my user name and password and get to a "UC_540>" prompt. Is this where I need to enter the configuration commands? I tried and get an error when I try to enter the first line, so I suspect I am not at the right place yet to enter them.

Thanks,

Mike

Hello Mike,

Before you put in those commands you have to be in enable mode.

At the > prompt enter: enable

It should then prompt you for your password again, or put you straight into enable mode. Enable mode will show a # prompt

Then copy and paste those commands in.

Thanks,

-john

Thanks John,

I'll try this now. After I make the changes do I need to reboot the system or is it good to go as is.

Thanks,

Mike

Hello,

You do not need to do a reboot. Just make you enter the last command, wr mem, as that will save the configuration.

Thanks,

-john

Hi John -

I'm obviously missing something. I was able to enter enable mode and it did ask for my password again. I entered it and got to the "UC_540#" prrompt.

The system then said to enter the commands one line at a time and end each line with cntrl-Z. I do this but I get a

"% invalid input detected at ^ marker" after each line. So I am assuming I am not doing it correctly.

I know this is basic stuff, but I appreciate the help,

Mike

Hello,

After getting the # prompt, did you start with this command: conf t

Where are you getting the ^ prompt?

Thanks,

-john

Here is a screen capture from my terminal: