cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest Cisco news in this December issue of the Cisco Small Business Monthly Newsletter

620
Views
5
Helpful
3
Replies
Beginner

UC540 incomming calls not matching dial-peers

Outgoing calls are fine.

When a call comes in fro PTT on my BRI lines I can see it has the correct digits, but a dial-peer is not matched.

000441: Apr 20 09:12:33.395: //-1/290A9D338008/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=7500026140
   cisco-anitype=2
   cisco-aniplan=1
   cisco-anipi=0
   cisco-anisi=3
   dest=224232
   cisco-desttype=0
   cisco-destplan=1
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-lastrdn=
   cisco-rdntype=-1
   cisco-rdnplan=-1
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

000442: Apr 20 09:12:33.395: //-1/290A9D338008/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x87894520, Call Info(
   Calling Number=7500026140,(Calling Name=)(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),
   Called Number=224232(TON=Unknown, NPI=ISDN),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
   Incoming Dial-peer=1000, Progress Indication=NOT END TO END ISDN(1), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
000443: Apr 20 09:12:33.395: //-1/290A9D338008/CCAPI/ccCheckClipClir:
   In: Calling Number=7500026140(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)
000444: Apr 20 09:12:33.395: //-1/290A9D338008/CCAPI/ccCheckClipClir:
   Out: Calling Number=7500026140(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)
000445: Apr 20 09:12:33.395: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
000446: Apr 20 09:12:33.395: :cc_get_feature_vsa malloc success
000447: Apr 20 09:12:33.395: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
000448: Apr 20 09:12:33.395:  cc_get_feature_vsa count is 1
000449: Apr 20 09:12:33.395: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
000450: Apr 20 09:12:33.395: :FEATURE_VSA attributes are: feature_name:0,feature_time:2312240040,feature_id:115
000451: Apr 20 09:12:33.395: //115/290A9D338008/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=7500026140(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),
   Called Number=224232(TON=Unknown, NPI=ISDN))
000452: Apr 20 09:12:33.399: //115/290A9D338008/CCAPI/cc_process_call_setup_ind:
   Event=0x87820F30
000453: Apr 20 09:12:33.399: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Try with the demoted called number 224232
000454: Apr 20 09:12:33.399: //115/290A9D338008/CCAPI/ccCallSetContext:
   Context=0x89A14A5C
000455: Apr 20 09:12:33.399: //115/290A9D338008/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 115 with tag 1000 to app "_ManagedAppProcess_Default"
000456: Apr 20 09:12:33.399: //115/290A9D338008/CCAPI/ccCallSetupAck:
   Call Id=115
000457: Apr 20 09:12:33.399: //115/290A9D338008/CCAPI/cc_api_set_transfer_info:
   Transfer Number=, Transfer Reason=0x0
000458: Apr 20 09:12:33.399: //115/290A9D338008/CCAPI/ccGenerateToneInfo:
   Stop Tone On Digit=TRUE, Tone=Dial Tone,
   Tone Direction=Network, Params=0x0, Call Id=115
000459: Apr 20 09:12:33.403: //115/290A9D338008/CCAPI/ccSetDigitTimeouts:
   Initial Digit Timeout=-1000(ms), Inter Digit Timeout=-1000(ms)
000460: Apr 20 09:12:33.403: //115/290A9D338008/CCAPI/ccSetDigitTimeouts:
   Call Entry(Inter Digit Timeout=10000(ms), Initial Digit Timeout=10000(ms))
000461: Apr 20 09:12:33.403: //115/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
   (callID=0x73, digit_event=0x1, enable=TRUE, consume=FALSE)
000462: Apr 20 09:12:33.403: //115/290A9D338008/CCAPI/ccCallReportDigits:
   Enabled=TRUE, Call Id=115
000463: Apr 20 09:12:33.403: //115/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
   (vdbPtr=0x87894520, callID=0x73, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
000464: Apr 20 09:12:33.403: //115/290A9D338008/CCAPI/cc_api_call_report_digits_done:
   Enabled=TRUE, Disposition=0x0, Interface=0x87894520, Call Id=115
000465: Apr 20 09:12:33.403: //115/290A9D338008/CCAPI/cc_api_call_report_digits_done:
   Call Entry(Initial Digit Timeout=15000(ms), Inter Digit Timeout=10000(ms))
000466: Apr 20 09:12:33.487: %ISDN-6-CONNECT: Interface BRI0/2/1:2 is now connected to 7500026140 N/A
000467: Apr 20 09:12:35.231: %ISDN-6-CONNECT: Interface BRI0/2/1:1 is now connected to N/A N/A
000468: Apr 20 09:12:35.231: %ISDN-6-DISCONNECT: Interface BRI0/2/1:2  disconnected from 7500026140 , call lasted 1 seconds
000469: Apr 20 09:12:35.231: //115/290A9D338008/CCAPI/cc_api_call_disconnected:
   Cause Value=16, Interface=0x87894520, Call Id=115

ephone-4[3] Mac:1CDF.0F4A.985E TCP socket:[2] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 8/8 max_streams=1 SPCP ver 1/1
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:12
IP:192.168.3.13 1024 SPA502G  keepalive 10 max_line 1 available_line 1
button 1: dn 232 number 224232 CH1   IDLE         CH2   IDLE        
Preferred Codec: g711ulaw

calls from ip phone to ip phone work fine using the same digits.

There are no translations patterns in place

Does anyone have an idea why this would not be matching

3 REPLIES 3
Highlighted
Hall of Fame Master

Re: UC540 incomming calls not matching dial-peers

ashleyisa wrote:

Does anyone have an idea why this would not be matching

Because something is wrongly configured.

Beginner

Re: UC540 incomming calls not matching dial-peers

Looks like dial-peer 1000 is being matched.

Calling Number=7500026140,(Calling Name=)(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),
   Called Number=224232(TON=Unknown, NPI=ISDN),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
   Incoming Dial-peer=1000, Progress Indication=NOT END TO END ISDN(1), Calling IE Present=TRUE

You might want to post your config.

Don C.

Beginner

Re: UC540 incomming calls not matching dial-peers

Basically, the issue was IOS.

I was running uc500-advipservicesk9-mz.124-24.SB on a UC540 stratight out of the box.

I upgraded to uc500-advipservicesk9-mz.151-2.T2 and this resolved the issue.


They are not found on the cisco download software site, but rather, here in supportforums under UC500 software packs:

https://supportforums.cisco.com/docs/DOC-9827