cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
597
Views
0
Helpful
4
Replies
Highlighted
Beginner

UC540 Integrated-Service-Engine corrupt database(sysdb?) Voicemail unavailable; CCA freezes and I am a CLI novice.

Greetings!

We have a Cisco UC540 with 

Software Release IOS CME CUE CCA
8.0.2 2010-Mar 15.0(1)XA2 8.0 7.1.3 2.2.2

According to the table at another post:

I verified that the CUE is 7.1.3 and from the CLI# show config indicates it is running 15.0(1)XA2.

The CCA we have been using now hangs on loading the information from the Voicemail.  It will not backup its configuration, and it does the general wacky things that CCA has always done though with even less success since this has happened.  

I have tried to do my homework and read up on the possible causes of this.  I am leaning toward the "powered down without shutting down or reloading the system from CCA or CLI" cause and resultant corrupted database? 

The UC540 has warned me at some point of a database corruption and I suspect this has now afflicted the Integrated-Service-Engine.  

I am an IT novice when it comes to Cisco equipment other than knowing that they are an embedded computer with an operating system that runs as a state machine.  To that end, I am unfamiliar with the CLI.  I know enough to break things and not enough to fix what I have damaged.  I have heard this referred to as a CLI Cowboy.

 We have happily used the UC540 system for seven years with little need to interface with it.  We would like to continue using our Cisco equipment however the phone system voicemail has been inoperable for several months, and now calls are not being routed correctly along with the ghost pickup of a ring group that then drops the call.  Needless to say this has impacted our business and I know I am over my technical expertise.

The partner we purchased the equipment from we do not do business with anymore and is not an option.  I tried contacting a highly decorated Cisco partner from the website today... (Update: They returned my call and are asking around for someone with UC experience).

I explained that I knew our equipment was End-Of-Life (EOL) and out of support however I needed someone familiar with the UC5XX equipment since they are a unique piece of technology our small business invested in. I have done some e-mailing and calling of other support partners in my area.  However, nobody has anyone that is an expert on the UC5XX or they have not supported them for X years and I basically would be paying for them to come up to speed in order to get the system back into working condition.    

I am afraid to reset the UC540 system since we do not have the original software load on hand and it will not backup its current configuration.  I know I can copy the terminal screen from #show config out of PuTTY.  Putting it back into the system correctly is another story.  I have customized a few things from CLI years ago since CCA does not give you all the functionality to configure the system (I think this was having to reorganize the softkey buttons on the phones).  The other issue is I remember when the system was installed the ROM files for a few of the 79XX phones we have was not included and had to be manually added in the release of software that our UC540 is loaded with.  

I have read up on how to reset the Integrated-Service-Engine 0/0 and earlier today from this link and it gave me the option to try and repair the corrupt database it discovered.  

I answered yes to attempt repair, and now the Integrated-Service-Engine is stuck in an endless loop of loading the bootloader, panic, crashing, and rebooting.  I have attached the snippet I collected from the session showing what it is doing at the end of this message.  

    1. Again, I don't have the software to perform a clean factory reset if it requires reloading the factory image.
    2. Do not know how to make a backup other than from CLI.
    3. Am uncomfortable reloading said CLI backup since I watched a few videos of people locking themselves out of the equipment.
    4. If I factory reset the system, how do I get the license files reloaded since we do not have copies of it and can't access them from CCA (Plus its EoL so are they even available anymore?)
    5. I am trying to avoid investing $X,000's on a new phone system (or a "Pay $XX per handset/mo." that everyone wants to keep pushing on us)
    6. My boss is getting upset at losing phone calls from clients and vendors.
    7. The office manager is tired of being the "new voicemail" aka a Post-It note pad.
    8. To top it all off I have to reconfigure the network and put the UC540 behind another router since the 100MB interface can not handle the new 150MB fiber internet service we updated to.  When the ISP helped me reconfigure the running configuration to change IP address & gateway for the UC540 he accidentally cutoff LAN access and had to get a console cable out to reverse the mistake.  (Plus I do not have a console cable)

I feel that if I can get the Voicemail working (Integrated-Service-Engine?) and CCA to properly load we will be back to smooth sailing.  

I am confused by some of the acronyms, CUE, CUCM, CUCME, ISE, CME, etc. other than I realize they are like individual modules in automobiles which control a specific system: climate controller, engine control module, transmission control module, door control module, infotainment controller (Nav, Sat, CD, iPod, Bluetooth, RSE), etc.

With this being said, I am trying to reach out for help/guidance getting from (A) 1/3-functional UC540 to (B) Fully operational UC540.  I am not trying to get assistance for free; just the most cost effective for my company.

Thank you for any insight you may have,

Rick.

4 REPLIES 4
Highlighted
Beginner

Hello,

I hope you are doing well, my name is Jonathan and I am one of the Engineers from theSmall business department.

- I apologize for the inconvenience this may be causing you, just to let you know the UC products are already end of life, i will try to check for information related to this problem, honestly the site that was handling the UC products is no longer available so i am not very familiar with the unit, but i suggest to keep looking on the forum to see if there are any cases related that might help you as well.

http://www.cisco.com/c/en/us/products/unified-communications/unified-communications-540-small-business-uc540/index.html

Thanks.

Regards.

Highlighted

Hello JonRodr,

Thank you for looking into this.  I know the UC products are EoL and what little information about them is being archived.  Fortunately, the issue I am having with the Integrated-Service-Engine on the UC is universal among other products that are hopefully still supported.  

It is harder and harder to find someone familiar with these units as most companies have replaced them due to EoL and End of Support (EoS).  They are still very viable units in my opinion as they still offer a lot of technology for a small business setup on the voice side of things.  

I would much rather invest time and money in this long established and reliable technology for a basic PBX setup than the newer open source setups that the individual phones are considerably more expensive.  

Thanks,

Rick.

Highlighted
Beginner

Hi Rick,

I have gone through your post and the issue looks critical.

I am looking into the information you have shared.

In addition, could you please share ::

- show run

- topology

- Error observed while backup from CCA. Share screenshot along with log file generated during that time period.

- Any troubleshooting or steps performed which result into this situation.

- Do you have any image of UC available incase of factory reset is the option left.

Regards,

Sudhanshu

Highlighted
Beginner

Hello Rick,
Hope you are doing good.
I read the entire forum and understood your concern. Now, just to address your problem, lets try few steps. Let me know if that's feasible for you.
Action Plan:
1. Take backup of UC540 device using CCA. Now backup with CCA will take care of licenses as well.
You can follow this link:
http://sbkb.cisco.com/CiscoSB/GetArticle.aspx?docid=df0242cc2c8946d485c9b70a6259fee4_Backup_Restore_Configuration_on_UC500_series_.xml&pid=2&converted=0
Few points to remember here:
========================
a. Make sure that PC or laptop is directly connected to UC box.
b. Windows Firewall and Antivirus should be turned off.
c. No other external TFTP or FTP servers are running on that PC or laptop if that is running then it will fail during backup. Try to turn off from services in Windows. It's because CCA runs its own TFTP and FTP services while doing backup of router and CUE (voicemail) respectively.
d. And only one network port should work if connected via LAN, then disable wireless.
2. After backup, we will try to do the upgrade it to latest version of UC software bundle.
Latest Version of CCA is: https://software.cisco.com/download/release.html?mdfid=281010085&softwareid=281161599&release=3.2(3)&relind=AVAILABLE&rellifecycle=&reltype=latest&i=rm
Download UC540 Software from here:
https://software.cisco.com/download/release.html?mdfid=282819521&softwareid=282762907&os=&release=8.6(2)&relind=AVAILABLE&rellifecycle=&reltype=latest&i=!pp
UC 540 Software Pack 8.6.2 
UC540-8.6.2.zip
3. For upgrade follow this method:
You need to do from CCA. Maintainence >> Software Upgrade >> Point it to the zip folder which you will be downloading from above mentioned link.
Steps 2 and 3 will be performed when you complete the first step without fail. Also, for steps 2 and 3 you need to either plan for downtime or maintenance window to complete same.
Now, thats the only way to check whether its a hardware issue or software, but looks like upgrade will fix the issue you are having.
You can check this link for restoration using CCA. Do let me know if you find any difficulties:
https://www.youtube.com/watch?v=v3weDV_DAZM
Unfortunately, the support for UC 3xx and 5xx devices ended this 31st Jan 2017. But you can surely go with these links for depth knowledge.
 
https://supportforums.cisco.com/document/36791/sbcs-including-uc500-technical-enablement-labs
https://supportforums.cisco.com/document/64466/cisco-steps-success-voip-uc500-smb-version
https://supportforums.cisco.com/document/63086/cisco-tee-team-how-videos
http://sbkb.cisco.com/CiscoSB/ukp.aspx?pid=3
 
Few links for documents are removed but most of them are active. At least video links are present which can be helpful and beneficial.
 
Let me know if you have any further queries or concerns. I would say support ended but we are always ready for help and get your concern addressed as soon as possible.

Sincerely,

Shubhamoy