Showing results for 
Search instead for 
Did you mean: 

UC540 problem with Vonage incoming call


I have a wierd issue, where only Vonage calls are having issue

When someone call from Vonage, it goes to auto attendant, but it doesnt recognize the input. I tried more than 10 times and all call failed giving input.

I am sure this is a dtmf issue, but want to make sure with the configuration

Here is the dial-peer for incoming call

dial-peer voice 2001 voip

description ** cue auto attendant number **

translation-profile outgoing PSTN_CallForwarding

destination-pattern 889


session protocol sipv2

session target ipv4:

voice-class sip outbound-proxy ipv4:

dtmf-relay sip-notify rtp-nte

codec g711ulaw

no vad

Please let me know if you need more information.

Thanks in advance


Alexander Maroukian
Rising star
Rising star

Hello Uday,

Please try only "dtmf-relay rtp-nte" without sip-notify in the dial-peer?



*Please rate helpful posts

Hi Alex,

      Thanks for the reply. I tried that option but this time it didn't took the input from any phone.



Hi Uday,

Please check the running config of the CUE.

what is the dtmf-relay method and chenge it accordingly so on both side it should be rtp-nte. So if it is rtp-nte only under the dial-peer is should be the same under "ccn subsystem sip" in the CUE:

ccn subsystem sip

gateway address ""

dtmf-relay rtp-nte

end subsystem

Please make this and test again.



*Please rate helpful posts


        I made these changes and tested again.

Now I can give input from any phone but not from Vonage phone

I tried different Vonage phones.. Same issue



Thomas Gruendler

From my past experiences, it was always a Vonage issue and not the the phone system issue.  Vonage has had a history of DTMF issues in the past.  Call Vonage first or use the Vonage phone to call something else that requires DTMF codes and see if they go through.

Thanks for the information Thomas.

But when I try Bank of america or any number, calls are successfull. Issue is only when I call my UC540

Can explain the call flow detailing each and any device.

Thanks Paolo

Here is the call flow

1. Call coming to UC540

2. Gives a welcome greeting with options

3. User tries to give input , but UC540 doesnt accept the input

This is happening only with Vonage calls

Now I have another issue(with all calls)

Some times when customer gives the input, it accept it and immediately hungs up.

Any idea why it is happening like this?



Make so a call from Vonage customer can be answered on a Cisco phone.

Have caller press few keys. If no tone is heard, then it is Vonage fault, as suggested above.

Regarding the second problem, update to latest SW 8.6.0, and check again.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: