cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1378
Views
4
Helpful
10
Replies
m.stefani
Beginner

UC540 SIP-TRUNK with T-Com Provider ???

Hi All,

I am looking for an answer to the followwing question:

Is it possible to connect a UC 540 via SIP-Trunking to the T-Com provider?

Many Thnaks in advance

Michael

10 REPLIES 10
danplacek
Enthusiast

Yes, we do many deployments with SIP delivered over a T1 by the ISP.

We have worked with Earthlink, TDS, and CBeyond successfully.

SIP to ITSPs works as well -- but SIP over the public internet is an invitation for problems.

Hi,

I'm usind sip trunk with sipgate over thr public internet without any problems.

The uc need some special configuration for the authentication, but that is all.

Best regards
Christian

- Please rate helpful posts -

Hi Christian,

I am also working on getting a SIP Trunk to SIPGate working in my Lab.

Would you mind to share your settings?

What special configuration is needed for authentication?

I am struggling at the moment with Natting. My router has no direct connection to the internet. Its behind a NAT Router and my SIP register requests to sipgate has only my internal ip address in the via or contact header.

Is there a way to replace my internal ip with my external ip or should this happen automaticly when my request reaches sipconnect.sipgate.de ?

regards,

Bernhard

Hi Bernahrd,

you need the CUBE functionality to modify the SIP header of your packets. There you can replace the ip. Can you please post a sample header of your outgoing sip packet.

regards

Christian

- Please rate helpful posts -

Hi Christian,

Thanks for your reply.

Indeed my outgoing SIP Packet has internal IP addresses.

I will check for the CUBE functionality to modify the SIP Header. thank you!

What special authentication is needed?

I've got following sip-ua config:

sip-ua

credentials username XXXXXXt0 password 7 xxxxxxxx realm sipconnect.sipgate.de

authentication username XXXXXXt0 password 7 xxxxxxxxx realm sipconnect.sipgate.de

no remote-party-id

retry invite 5

retry register 10

timers connect 100

registrar dns:sipconnect.sipgate.de:5060 expires 3600

sip-server dns:sipconnect.sipgate.de:5060

best regards,

Bernhard

Hi Bernhard,

is it now possible to add characters in the username? The last time I configured SIP it wasn't possible.

I will check later my documents.

regards

Christian

- Please rate helpful posts -

- Please rate helpful posts -

Hi Christian,

I am using a 2921 router with 15.2(4)M3 IOS and it is possible to add characters. Unfortunately registering is still not working.

I got now CUBE Header replace in place and i see in my sip messages the following:

Sent:

REGISTER sip:sipconnect.sipgate.de:5060 SIP/2.0

Via: SIP/2.0/UDP :5060;branch=z9hG4bK18ED

From: <>xxxxxxxxt0@sipconnect.sipgate.de>;tag=ADED78-1E6

To: <>xxxxxxxxt0@sipconnect.sipgate.de>

Date: Wed, 10 Apr 2013 13:47:56 GMT

Call-ID: 84DDCD30-A11B11E2-800296FE-57E3AE87

User-Agent: Cisco-SIPGateway/IOS-15.2.4.M3

Max-Forwards: 70

Timestamp: 1365601676

CSeq: 3 REGISTER

Contact: :5060>

Expires:  3600

Supported: path

Content-Length: 0

on my NAT Router i got a port forwarding to my internal address for udp 5060.

I used following config for replacement:

voice class sip-profiles 1

request REGISTER sip-header Contact modify "internal ip" "external ip"

request REGISTER sip-header Via modify "internal ip" "external ip"

and have the sip profile applied to voice service voip.

Of course you have to replace "internal ip" and "external ip" with the correct ip addresses.

but i see only outbound SIP requests nothing comes inbound...

anything else i need to modify?

regards,

Bernhard

Hi Bernhard,

can you check if your WAN router is receiving the SIP answer?

I found some infos that you need to configure:

no ip nat service sip udp port 5060

But I've never tried this.

- Please rate helpful posts -

- Please rate helpful posts -

Hi Bernhard,

I tested this in my lab on the weekend. I used a CME behind a ASA to connect to sipgate and there was no configuration needed in the CME to modify the SIP headers for this scenario.

So I think your problem is somewhere in the WAN router.

best regards

Christian

- Please rate helpful posts -

- Please rate helpful posts -

Hello,

I know this post is quite old but I was wondering if you would be able to provide a basic config for this? I am having trouble registering my UC540 with sipgate.


Richard