cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

UC540 Wrong Codec on SIP Trunk

hamiltonandrew
Beginner
Beginner

Hi there,

I have a UC540 (using the software it came out of the box with, configured with CCA 3.2) that I'm trying to use with SIP trunking.  The carrier only supports ulaw, so that's how I've set it up.

Yesterday morning, after factory-resetting it and doing a brand-new configuration, it was working correctly and placing calls through the trunk using ulaw.  But, after futzing around with the trunk trying to get authentication right, something happened and now it's attempting to place outgoing calls using g729. There is no mention of g729 anywhere in the config.  I tried rebooting the UC540, I tried deleting and recreating the trunk in CCA.  Still g729.

I just don't know what went wrong.  Any suggestions?  Have there been any changes made in more recent versions of the software that might address this?

Thanks,

- Drew

Message was edited by: Andrew Hamilton    Reason:  Added config file

2 ACCEPTED SOLUTIONS

Accepted Solutions

In your configuration dial-peers from 1020 to 1044 don't have a codec.

Can you try to set g711u?

What dial-peer is matched during your calls?

Cisco has an hidden dial-peer 0 used in the case of no match. This dial-peer use g729 codec.

Regards.

View solution in original post

We have an open bug in CCA 3.2 (CSCty78255) whereby if you make changes to the SIP trunk config, the preferred codec configuration gets stripped off the dial-peers.  This should be fixed in 3.2.1 when it releases in the next couple of weeks, but in the interim, I suggest you contact support who will walk you through fixing the config manually.

And just for the benefit of the other posters here, the default codec used by a dial-peer when there is nothing explicitly configured is g729, so even outbound calls that match on configured dial-peer will behave the same.

Cheers,

Dave.

View solution in original post

11 REPLIES 11

hamiltonandrew
Beginner
Beginner

Whoops, thanks!  New to any Cisco stuff.

Can you add the config of your UC (without password)?

Regards.

Thanks!  I added it to the original question.  I changed the client names and phone numbers as well as editing out the passwords.

David Trad
Rising star
Rising star

Hi Andrew,

Your config yields no suspicious co figuration to cause your problem.

How do you know that G.729 is being negotiated? can you show the debug messages for this??

More info is needed to help with the diagnosis.

(PS) You should upgrade the system to software pack 8.2 factory IOS/CME is not a good option as they can be quite old.

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

The SIP Trunk is actually an Asterisk box on the local subnet, so the SIP trace from the Asterisk box is where I saw that the Cisco was offering (only) the G.729 stream.

I can send the debug messages next time that I'm in at the client in a couple days.

I'll also try upgrading the software and see if that helps -- it's possible that there's a bug in the factory software, I suppose.

If all else fails, I can transcode from g.729 to ulaw inside the Asterisk box, so I have a fallback plan, but that's suboptimal.

Hi Andrew,

OK here is what I think is happening, but cannot be 100% certain without

seeing the Asterisk Config.

Please check your Peer configuration on the Asterisk system and ensure that

the peer connecting to the UC is set to dis-allow all, and under allow make

sure that only uLaw & aLaw are chosen.

I haven't played with an asterisk system in over a year, but that sip debug

suggests that the * box is asking for G.729, but the UC responds with only

"US" uLaw, the debug is actually backwards.... This makes sense because

there is no configuration anywhere on the config that suggests G.729, not

even on the ephone/ephone-dn so the UC would not issue its advertisement

suggesting it can take G.729...

Please check your peer configuration, and if you are using AsteriskNow or

FreePBX based GUI interfaces, be carefully because they can overwrite

configurations without letting you know, unless it is running Asterisk

Real-Time engine which is DB driven not static config driven.

Well that's all I can think of now

Cheers,

David.

On Apr 4, 2012 7:44 AM, "hamiltonandrew" <

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

I ended up still having a SIP trace from the trunk side in my scrollback buffer.  I attached it here just in case it might be useful for anything.

In your configuration dial-peers from 1020 to 1044 don't have a codec.

Can you try to set g711u?

What dial-peer is matched during your calls?

Cisco has an hidden dial-peer 0 used in the case of no match. This dial-peer use g729 codec.

Regards.

We have an open bug in CCA 3.2 (CSCty78255) whereby if you make changes to the SIP trunk config, the preferred codec configuration gets stripped off the dial-peers.  This should be fixed in 3.2.1 when it releases in the next couple of weeks, but in the interim, I suggest you contact support who will walk you through fixing the config manually.

And just for the benefit of the other posters here, the default codec used by a dial-peer when there is nothing explicitly configured is g729, so even outbound calls that match on configured dial-peer will behave the same.

Cheers,

Dave.

Awesome...

Thanks Dave

Cheers,

David.

On Apr 4, 2012 6:25 PM, "dharper" <

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

That did the trick, thanks!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: