Showing results for 
Search instead for 
Did you mean: 

Upgrade Firmware for 7925G failed



i have a Problem with the Firmware-Upgrade from my Cisco 7925G Wireless-Phone from 1.3.3-3 to 1.3.4

When i start the Upgrade, the Upgrade fails when the Phone will Download the Picture-File.

Is this a known Problem?

With kind regards



Marcos Hernandez

Are you using the Phone Load Manager in CCA? What do you get when you do a "debug tftp events"?


Join the club!  cant update 7925's either with CCA either.   Would love to know if there is a solution.

I tried this, it failed for me too...

I imagine this is FW version 1.3.4 and so you cant use the PLM of CCA since its not yet in a bundle.

I downloaded it from CCO.

I manually tftped the files to the flash (proper directory)

I adjusted the tftp-server statements, and then in telephony-service modified the load statement, which I checked did adjust system:its file for the 7925.

I powered off the phone and powered it on and the phone tries to get the right FW, but says "image authentication failed' on the phone itselfr.

TFTP looks like this....

002671: Mar 15 02:27:35.527: %DOT11-6-DISASSOC: Interface Dot11Radio0/5/0, Deauthenticating Station 0023.3341.6141 Reason: Sending station has left the BSS SSID[cisco-voice]
002672: Mar 15 02:28:41.990: %DOT11-6-ASSOC: Interface Dot11Radio0/5/0, Station SEP002333416141 0023.3341.6141 Associated SSID[cisco-voice] AUTH_TYPE[OPEN] KEY_MGMT[NONE]
002673: Mar 15 02:28:42.830: %IPPHONE-6-UNREGISTER_ABNORMAL: ephone-3:SEP002333416141 IP: Socket:4 DeviceType:Phone has unregistered abnormally.
002674: Mar 15 02:28:43.642: TFTP: Looking for CTLSEP002333416141.tlv
002675: Mar 15 02:28:43.834: TFTP: Looking for WLAN002333416141.xml
002676: Mar 15 02:28:43.974: TFTP: Looking for WLANDefault.xml
002677: Mar 15 02:28:44.110: TFTP: Looking for SEP002333416141.cnf.xml
002678: Mar 15 02:28:44.110: TFTP: Opened system:/its/XMLDefault7925.cnf.xml, fd 14, size 1381 for process 326
002679: Mar 15 02:28:44.130: TFTP: Finished system:/its/XMLDefault7925.cnf.xml, time 00:00:00 for process 326
002680: Mar 15 02:28:45.650: TFTP: Looking for Ringlist.xml
002681: Mar 15 02:28:46.102: TFTP: Looking for DistinctiveRingList.xml
002682: Mar 15 02:28:47.286: TFTP: Looking for English_United_States/7921-dictionary.xml
002683: Mar 15 02:28:48.074: TFTP: Looking for English_United_States/7921-kate.utf-8.xml
002684: Mar 15 02:28:48.214: TFTP: Looking for English_United_States/7921-font.dat
002685: Mar 15 02:28:59.714: TFTP: Looking for CP7925G-1.3.4/CP7925G-1.3.4.LOADS
002686: Mar 15 02:28:59.862: TFTP: Looking for CP7925G-1.3.4.LOADS
002687: Mar 15 02:28:59.866: TFTP: Opened flash:/phones/7925/CP7925G-1.3.3.LOADS, fd 14, size 900 for process 326
002688: Mar 15 02:28:59.882: TFTP: Finished flash:/phones/7925/CP7925G-1.3.3.LOADS, time 00:00:00 for process 326
002689: Mar 15 02:29:05.950: %IPPHONE-6-REG_ALARM: Name=SEP002333416141 Load=CP7925G-1.3.3 Last=Initialized
002690: Mar 15 02:29:06.154: %IPPHONE-6-REGISTER: ephone-3:SEP002333416141 IP: Socket:2 DeviceType:Phone has registered.


I get the auth fail on 7925 and 7975 phones both.  The issue as I am told from TAC is that there is a proper upgrade sequence as far as Phone loads.   For instance on the 7975G   you have to go from 8-3-2  to 8-5-2 to 8-5-2S to 8-5-3or S   If you skip over anyone you get the Auth Fail message.   I would guess the 7975 has the same issue.  Sounds like you know how to do it outside CCA so you are in better shape than me as long as you can get the upgrade sequence. 

Yes, I just tried again, and looked at the phone carefillu.  It says "upgrading FW" and then "image authentication failed'.

I will ask internally and find out what this means and what we can do for you here.  The release notes for 1.3.4 are here:

and I was running 1.3.3, so there is no step in between, I dont think, which I am missing.

I will ask now and look for an answer and post it ASA dev. replied....


Steve, did you do a "create cnf"?



i am using the CLI to download the Image to the 7925G. The Debug i will get on Monday; i am allways on a Cisco VoIP Curs :).




Yes, I did.  This is how the system:its xml file knows to call for the 1.3.4 load as shown in the debug tftp-events.

I think I have found the error of my ways.   I cant verify till tonight, when I get to the system I was testing Sunday, but I did speak to the phone test and dev team, and they assured me the tar bundle is good and they verifed phone upgrades will work 1.3.3 to 1.3.4, so it must be an error in configuration.

In my case, I am almost sure I missed a step....  Let me share what you should do and then you can see before I try tonight, if it works.  It should work....

1)  TFTP the files from your PC to the UC 500 flash directory for the 7925 phone.

UC520#copy tftp flash:
Address or name of remote host []?
Source filename []? APPSH-1.3.4.SBN
Destination filename [/phones/7925/APPSH-1.3.4.SBN]?
Accessing tftp://
Loading APPSH-1.3.4.SBN from (via BVI1): !!!!!!!!!!!
[OK - 2603162 bytes]

2603162 bytes copied in 22.656 secs (114899 bytes/sec)

UC520#copy tftp flash:
Address or name of remote host []?
Source filename [APPSH-1.3.4.SBN]? CP7925G-1.3.4.LOADS
Destination filename [/phones/7925/CP7925G-1.3.4.LOADS]?
Accessing tftp://
Loading CP7925G-1.3.4.LOADS from (via BVI1): !
[OK - 918 bytes]

918 bytes copied in 0.728 secs (1261 bytes/sec)

UC520#copy tftp flash:  
Address or name of remote host []?
Source filename [CP7925G-1.3.4.LOADS]? GUIH-1.3.4.SBN
Destination filename [/phones/7925/GUIH-1.3.4.SBN]?
Accessing tftp://
Loading GUIH-1.3.4.SBN from (via BVI1): !!!!!!!!
[OK - 1894787 bytes]

1894787 bytes copied in 15.600 secs (121461 bytes/sec)

UC520#copy tftp flash:
Address or name of remote host []?
Source filename [GUIH-1.3.4.SBN]? MISCH-1.3.4.SBN
Destination filename [/phones/7925/MISCH-1.3.4.SBN]?
Accessing tftp://
Loading MISCH-1.3.4.SBN from (via BVI1): !
[OK - 1916 bytes]

1916 bytes copied in 0.744 secs (2575 bytes/sec)

UC520#copy tftp flash:
Address or name of remote host []?
Source filename [MISCH-1.3.4.SBN]? SYSH-1.3.4.SBN
Destination filename [/phones/7925/SYSH-1.3.4.SBN]?
Accessing tftp://
Loading SYSH-1.3.4.SBN from (via BVI1): !!!!!!!!!
[OK - 2118620 bytes]

2118620 bytes copied in 17.896 secs (118385 bytes/sec)

UC520#copy tftp flash:
Address or name of remote host []?
Source filename [SYSH-1.3.4.SBN]? TNUXH-1.3.4.SBN
Destination filename [/phones/7925/TNUXH-1.3.4.SBN]?
Accessing tftp://
Loading TNUXH-1.3.4.SBN from (via BVI1): !!!!
[OK - 939425 bytes]

939425 bytes copied in 8.916 secs (105364 bytes/sec)

UC520#copy tftp flash:
Address or name of remote host []?
Source filename [TNUXH-1.3.4.SBN]? WLANH-1.3.4.SBN
Destination filename [/phones/7925/WLANH-1.3.4.SBN]?
Accessing tftp://
Loading WLANH-1.3.4.SBN from (via BVI1): !!!!!!!!
[OK - 1946034 bytes]

2) Adjust the TFTP-SERVER statements in your running config and save it.

(this is where I made my error I think, I adjusted the alias in putting them back, but not the front of the line ;-((((( )

CONF T mode

no tftp-server flash:/phones/7925/CP7925G-1.3.3.LOADS alias CP7925G-1.3.3.LOADS
no tftp-server flash:/phones/7925/GUIH-1.3.3.SBN alias GUIH-1.3.3.SBN
no tftp-server flash:/phones/7925/MISCH-1.3.3.SBN alias MISCH-1.3.3.SBN
no tftp-server flash:/phones/7925/SYSH-1.3.3.SBN alias SYSH-1.3.3.SBN
no tftp-server flash:/phones/7925/TNUXH-1.3.3.SBN alias TNUXH-1.3.3.SBN
no tftp-server flash:/phones/7925/WLANH-1.3.3.SBN alias WLANH-1.3.3.SBN

tftp-server flash:/phones/7925/CP7925G-1.3.4.LOADS alias CP7925G-1.3.4.LOADS
tftp-server flash:/phones/7925/GUIH-1.3.4.SBN alias GUIH-1.3.4.SBN
tftp-server flash:/phones/7925/MISCH-1.3.4.SBN alias MISCH-1.3.4.SBN
tftp-server flash:/phones/7925/SYSH-1.3.4.SBN alias SYSH-1.3.4.SBN
tftp-server flash:/phones/7925/TNUXH-1.3.4.SBN alias TNUXH-1.3.4.SBN
tftp-server flash:/phones/7925/WLANH-1.3.4.SBN alias WLANH-1.3.4.SBN

3) Modify the telephone Service Load statement:

UC520#conf t
UC520(config-telephony)#no load 7925 CP7925G-1.3.3
Updating CNF files
CNF files update complete for phonetype(7925)

UC520(config-telephony)#load 7925 CP7925G-1.3.4  
Updating CNF files
CNF files update complete for phonetype(7925)

Building configuration...

4) Create CNF

cont f


no create cnf

create cnf

5)  You can check to see that the xml file is adjusted to call for the new load for the 7925:

You dont do this manually yourself.  This happens when the cnf files are created above.....

UC520#cd system:its
UC520#more XMLDefault7925.cnf.xml

{7925 Mar 14 2010 22:19:23}

Eastern Standard/Daylight Time








Power off and then power on the 7925 and see if that works....


yep, just tried the corrected tftp-server statements, and it worked!!!

Anyone know the proper firmware load order?

Why does this have to be so hard?

Perhaps if the the Dev/Test engineers cant simplify the process to point and click, they can consult with one of thier Linksys colleagues?

Linksys routers and SPA phones are an example of how easy firmware upgrades can be.

If nothing else, put a browse for firmware button in the devices' web configuration page.

Thank you.

Good news. Drag and Drop exists in CCA 3.0 for traditional cisco ip phones now too. So what we used to have to do with CLI is no longer needed.

I hope that's what your asking? I think it is. Cca first handled SPA 500 phones and this past release does them all. I confirmed it worked as well.

Next is backgrounds and ringtones. I saw it on the feature list. Speak up for what you need. We listen.


IE 8 x86 then x64

CCA 3.0 (.0.72)

UCC-540 15.1(2)T2

I just tried to drag and drop the following files onto both the UCC-540 and the phones themselves. I got the circle withe the line through it for each attempted action.


Off to the third party PITA TFTP server I went.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: