cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
996
Views
0
Helpful
10
Replies

Voice translation rules

muratg7777
Beginner
Beginner

Hi;

We have UC520 which is connected to analog central.

I have connected 4 extensions on FXO ports. When extension 111 calls ip phone 1 rings. 112 calls ip phone 2 rings and goes like that.

The problem is when I use ip phone 1, outgoing call is using another extension's port

I want to configure:

phone 1 use fxo 0/1/0

phone 2 use fxo 0/1/1

phone 3 use fxo 0/1/2

phone 4 use fxo 0/1/3

on outgoing calls. I think I can do it with voice translation-rule but couldn't find it how?

2 Accepted Solutions

Accepted Solutions

Then the easiest way would be to use CCA.

Go to:  Configure>Telephony>Dial-Plan>Incoming

Set the FXO lines to "CO_Lines"

Then configure the button(s) on the phones to use the correct "CO_Line".

Thank you,

Darren

View solution in original post

10 Replies 10

Darren DeCroock
Enthusiast
Enthusiast

Not sure that I fully understand, so let me restate what I believe your issue is:

You have 4 lines connected to the FXO ports on your UC520.  Incoming calls are being directed correctly.  Outgoing calls are not using the line you want to assoicate to that phone, but instead using a random FXO line.

If that is correct, a translation rule is not what you need to modify.  That would only change the calling or called number.  You need to specify the FXO port that you want the phone to use.   There are a few ways to do this, but I would suggest that you setup "CO_Lines" for those phones, but that may not work, depending on your setup. 

Are you using CCA or CLI to manage this UC520?  How many IP phones do you have, and are they all sharing the FXO lines?

If you could provide more information, I am sure that we could help you out.

Thank you,

Darren

Yes that's exactly what I want to do.

I can use both of them (CCA and CLI).

I use 4 Ip Phones. One FXO (extension comes from analog central) to one ip phone. I want to strict it because when they use random fxo lines, the analog central recieves wrong id. I mean x is calling but on the telephone they see y is calling.

Then the easiest way would be to use CCA.

Go to:  Configure>Telephony>Dial-Plan>Incoming

Set the FXO lines to "CO_Lines"

Then configure the button(s) on the phones to use the correct "CO_Line".

Thank you,

Darren

Thanks for the answer.

How can I sign CO_Line to telephone?

Here is my config:

voice-port 0/1/0
trunk-group ALL_FXO 64
cptone TR
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 231
description Configured by CCA 4 FXO-0/1/0-Custom-CO0
caller-id enable

ephone-dn  16  dual-line
number 231 no-reg primary
label 231
description Murat GUCLU
name Murat GUCLU
call-forward busy 399

ephone  6
device-security-mode none
mac-address 0024.97F0.8712
max-calls-per-button 2
  type 525G
button  1:16

On voice-port 0/1/0 - Extension is 131 (Analog Central)

Thanks Steven. It Worked

This worked with phone 1

When I configure phone2. The phone on outgoing call works but when I call phone 1, I see phone 2 co_line is active too (button red)

and I can't call phone 2 on analog central but phone 1 works. Outgoing call works on both phones.

I cannot reach phone2 (131 analog number which is connected to port 0/1/3) it rings 2-3 times normally and then drops to beep tone

On second call I hear busy tone.

Config:

Voice-port 0/1/0
trunk-group ALL_FXO 64
no battery-reversal
cptone TR
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 3A10
description Configured by CCA 4FXO-0/1/0-Custom-CO0
caller-id enable


voice-port 0/1/3
trunk-group ALL_FXO 64
no battery-reversal
cptone TR
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 3A13
description Configured by CCA 4FXO-0/1/3-Custom-CO3
caller-id enable

ephone-dn  45  dual-line
number 231 no-reg primary
label 231
description Murat GUCLU
name Murat GUCLU

ephone-dn  53
number 3A10 no-reg primary
label CO Line 1
trunk A0 monitor-port 0/1/0

ephone  6
device-security-mode none
mac-address 0024.97F0.5922
ephone-template 16 
max-calls-per-button 2
  paging-dn 4
type 525G
button  1:45 2:53

ephone  5
  device-security-mode none
  mac-address 0023.EBED.1122
  ephone-template 16
  max-calls-per-button 2

paging-dn 4

  type 525G

button  1:14 2:48

ephone-dn  48
number 3A16 no-reg primary
label 112
trunk A3 monitor-port 0/1/3

ephone-dn  14  dual-line
number 212 no-reg primary
label 212
description Test
name Test
call-forward busy 399
call-forward noan 399 timeout 20

I have configured my UC from the beginning. It works perfectly

My Co Line is on button 1 now. I want to change the name of the telephone (not the Co_Line label). It shows 3A10.

How can I label it?

Using CCA?

What release?

I prefer CLI.

I have CCA 3.0 but when I configure Co_Lines from CCA it assigns same id to both phones.

I see 3A10 on both 2 phones so CLI is better

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: