cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1462
Views
10
Helpful
14
Replies
mdube
Beginner

Voicemail instructions in different language for callers

Hello all,

Here I am with another "fun" question about the UC

Ok so for the last few days, I have been working on a client's UC560 so that we have different queues for french and english callers.

For most of the setup, I have been able to provide the caller with instructions or welcome messages only in french or in english depending on the origin of the caller. Here is the setup :

PRI provider actually redirects incoming calls depending on the area code to specific numbers. Here in Quebec, Canada, we have a bunch of area codes that we consider will be people speaking in french, every other area code gets redirected to the other number. It's then simple to DID to specific AA.

So say French caller calls the 1-800-555-5555

DID to AA 296 with welcoming message in french, then 3 levels of hunt groups, then B-ACD with transfert prompt in french (I have overwritten the en_allagentsbusy.au message to something we recorded in french, then shared extension and then voicemail of that shared extension. The system being in french, the instructions given by the Cisco system are in french, and our message is also in french (something along the lines, We are sorry but all of our agents are handling other calls, please leave a message, ...in french)

My problem is, I have exactly the same pattern for english calls, only, it is a DID to AA 295 (message in english) then hunt-groups, then B-ACD with custom prerecored message (i have overwritten en_welcome.au), then shared line, then GDM

with another prerecorded message in english. BUT! The instructions are in french...

I do have both languages loaded, but of course, it's the french that is set as active... The only thing I would need, is to have english instructions for the caller on that very specific GDM mailbox...

Anyway to do this? Or maybe, anyway to disable the Cisco instructions for that mailbox so that we record instructions ourselves?

I know it is probably a long run, but if anyone's got an idea, let me know!

14 REPLIES 14
paolo bevilacqua
Hall of Fame Master

You cannot re-record anything in CUE VM system except the personal greetings. And, there is no option for switching language once conencted to a mailbox.

So I believe, the only option is that somehow, you will configure two GDM MBs, one for each language, and someohow redirect calls correctly to the right one.

Since individiduals can be members of more of one GDM, they should not have a problem retriving messages from both )assuming they are bilingual )

Oh I already have two distinct GDM MBs with personnal greetings recorded in corresponding language. It's the instructions I would need in english, for one of these MB.

Here's the call pattern

French Caller :

1-800-555-5555 -> PRI provider redirects to 555-1111 -> DID to AA 296 -> Hunt1 123 -> Hunt2 124 -> Hunt3 125 -> B-ACD 870 -> Shared line 820 -> GDM

English Caller :

1-800-555-5555 -> PRI provider redirects to 555-2222 (because of calling area code) -> DID to AA 296 -> Hunt1 223 -> Hunt2 224 -> Hunt3 225 -> B-ACD 871 -> Shared line 821 -> GDM

It's the latest GDM I would like the caller to hear the instructions in english. He does hear the personnal greeting of that VM in english, but still hears the Cisco Lady saying in french "Please record the message blablabl, and when you are done hang up or hold for more options"...

Make sure you have both English and French languages installed.

Then for the user owning the desired GDM, set language to English..

Paolo,

I have tried directly on their system, and it is not changing anything... I am guessing you meant changing the language by accessing the 10.1.10.1 website, then Configure, Users, then the owner user?

That GDM has 17 members, and they can't be changed to English, as everyone who will contact them will get the instructions in english, but here in Quebec, most of the people are speaking french.

You mentionned owner, so I tried on our own system to add a owner to that GDM (not only a member) and eventhough the language is set in english for that owner, the GDM is still in french...

In fact, after all the tests, I realized that setting the language to English US does nothing, I have checked the personnal MBs of the owners, and on the GDM MBs... weird???

I think you have ran into a limitation of CUE here, that I have just realized myself too.

That is, because a GDM is to be owned by a group as opposed by an user, and because there is no way to set language for a group, the consequence is that any GDM will be always in the system default language, not a nice thing.

As a workaround you will have to create a new user with the desired language, move the number from group to it, create new mailbox too, then access using a separate login into CUE every time.

If that doesn't work, try updating software and/or contact Cisco TAC, because it is supposed that the language setting of an user will determine the language used by the mailbox.

mdube
Beginner

Hello Paolo,

Here I am again

Ok so I configured a new user and set it up in english. Unfortunately, it is still not working.

If I want to hear the messages on my VM, the instructions will actually be in english. But if I am calling that extension and then gets redirected to the VM like an external caller would be, I hear the personnal greetings but then, the instructions to leave a message to that user are in french... So I guess I am stuck on this one?

You think that programmatically this could be done? If so, you might have a contract

No it can't be done programmatically, and the correct behavior is that a mailbox uses the language set for the owner, not the system default language.

Just today another person reported the same issue with a 8.6.4 CUE, so likely it's a bug and you will have to contact Cisco TAC for support

mdube
Beginner

Cisco TAC has been opened, will let you guys know how it turns out.

Thanks for the help!

Today I've tested this again with CUE 8.6.5.

Once logged in VM, prompts are in the language configured for the user.

However, caller instructions are always in the system language.

I think that is a bug, but I would not be surprised if this has always been the CUE behavoir since introduction of multiple languages support.

Yes, right now my case is in "Cisco pending" state, as they are having a hard time figuring out what's the problem...

Haven't had a contact with them for a few days now, I might ping them back and see what's the current status...

When Cisco takes things like that, better ask for escalation, otherwise chances are you get old waiting.

And cross fingers, to not get the dreaded answer "working as designed".

Thanks for the tip. The case has been escalated.

Will update whenever I have new info because this might be useful someday to others

Have a good day, thanks for your tests Paolo!

Hello all,

Got an update from Cisco friday.

They told me a CDET had been created CSCue24142 (UC560 CUE en-US user's mailbox gives sub instructions in default fr-CA)

I cannot see it in the Bug Toolkit, I guess I don't have required access but anyway, at least it's filed as a bug now which should be addressed.

The bug should be visible, ask the engineer to make it so, or explain why it is not.