Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Why Can't I Get IMAP to Work? Anywhere?

We have 3 sites set up with voicemail to email using IMAP.  All 3 sites have a problem with negative message counters that require a reboot of CUE.  I have 3 separate cases open with Cisco for months with no progress.  All I get is 'works fine in our lab.'  This really doesn't make the customer happy.  One particular customer bought the UC500 for the IMAP feature alone.  I am surprised they have not returned it yet since we have been working on it for two and a half months.  The SR is escalated.  We have swapped boxes.  We are not even close to a resolution.  This is killing us.

At two of the sites, the problem happens once every couple of weeks.  At the other site, it messes up their voicemail the moment we set up the imap account on their computer.

How do we get this problem solved?




Case number please?  We can check to see whats the progress...

616940299 is the one I am focusing on.  I can get the case numbers for the other ones.  The other ones happen once every couple of weeks.

This site uses MACs but I setup an account on my Windows laptop with the same result.


Investigation by SBSC indicates there is a defect filed that is scheduled to be available in CUE 8.0.5 is CSCtj25054  (CUE 8.0.2 locks when IMAP clients use "UID COPY" command).

I read the bug in bug tool kit and this is from iPhones though, while yours is MAC books.   What do you think?


I had high hopes when you said it was possibly a bug.  At least that would be something we could explain to the customer.

I don't think the Macs are an issue here.  We have the same exact problem at two other sites that are using Windows computers with Microsoft Outlook.

How does the UID COPY command work?  Is that something that happens with all email clients or just the iPhone?

I am attaching an audio recording of the error.  There is another post on the forum where someone else is having the same issue.  They made a video of the problem.   It does not appear they made any progress on their case either.  I pm'd the person to find out their case number to see if the SBSC tech could reference it for possible clues but did not get a response.

Thanks for this video.  I am sharing with the Engineers.

I think its the operation of copying the email message from the CUE to the local folder, perhaps using port 143, but I am asking to see exactly so we can use it to rule things out.

In the mean time, check this out...Google search 'UID copy'. Not being sarcastic, but I was surprised at what I found...

Here is a link to the other thread that has the video.  It is about halfway down.

Initially when I googled uid copy, I also added cisco cue to the search.  It does appear apple has some issues with the uid copy.  The problem we are having though is not the same as the bug.  The mailbox is there and the system knows it is there.  There seems to be a synchronization error.  As the audio file indicates, the Cisco says there are 6 new messages.  These messages were deleted from the email client so they do not exist anymore.  That is why that cannot be played.

I put this in the case notes but maybe someone might find this important to this thread.

Here is pretty much what happened.

1.       User had 6 new voicemails in their imap inbox on the computer.

2.       User listened to messages in imap inbox

3.       User deleted messages in imap inbox

4.       Mwi on phone stayed lit so they were confused since they had listened to all new messages

5.       The dialed the voicemail on their phone.  It said they had 6 new messages (the messages that were deleted) but they could not listen to them.

6.       Voicemail on phone was caught in an endless loop.

7.       Rebooted CUE and everything was fine

8.       Removed imap email account from computer for time being.

OK, so we confirmed we have not seen this issue before.  Need to know which IMAP client is the customer using? 

Does this happen consistently or is it reproducible.
We need “trace voicemail all”, “trace imap command request”, “trace imap command response” to debug this issue.

If you provide it here or to the case is fine (I will look here if you do)

"OK, so we confirmed we have not seen this issue before" I don't want to call you on this but...

David Trad
Rising star

Hi Jason & Steven,

I might be missing something here, but does using IMAP now also delete the VM from the UC? In the past this was not possible, if you deleted it it just removed it of the local system but it still remained on the UC until user interaction and removal???

Is this a new feature of the UC? I was a little confused when I read Jason's posts and I have had to re-read them more than once just to make sure I was correctly reading them



Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

IMAP accounts on an email client like outlook have always synced with the CUE (at least the last 3-4 years).  After the last new message is opened, the MWI light goes off.  If deleted in the inbox, it is deleted on the CUE.  You can even mark a message as un-read and it will turn your MWI light back on.

SMTP (Message Notification) is the one you can send to the users root email Inbox and MWI/Messages dont sync.

My last 20 jobs have used SMTP, good luck on finding the IMAP Bug.  

Yes not that it's any help, but you could move them over to SMTP for the time being until it get's

fixed. The con is you have to delete from two places, but as a plus you can get the voicemail on your iphone/ipad.

Good luck and post here what happens

Bob James


I posted that video and we are still experinecing the issue.

One thing that has changed is the computer that is in the video was replaced about a month ago and when it was upgraded we upgraded his microsoft office to 2010. since that time he as not had the problem,  however we still have other people with the problem.  we are in the process of collecting trace logs on the CUE,  we will be moving to office 2010 starting next week so we will see what happens then.

Update on this is there is a defect filed, which will be fixed in CUE 8.0.5, which is for summer release (new Software Pack).

Multiple clients attempting to access and delete messages in CUE can cause the message count to go negative, causing a few different problems. In a few cases it seems like iPhone access can make this more apparent.

If anyone has this issue they ate asked to open a case and consider the option of taking a early version of CUE 8.0.5, but this has NOT been tested as a bundle with UC500 so has obvious risks. The Support team may also have additional information of what causes this, which may not be only a CUE issue.

Sent from Cisco Technical Support iPhone App