Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


WIP310 Fails To Re-Register.

Customer has several WIP310 connected wirelessly to an accesspoint and then to a internal PBX Tribox V2.6.22. Using Teliax ITSP.

The phones work great for a while but randomly fail to re-register. The only way for it to work again is to power cycle the device.   Customer has tried three diferent access point in order to elimate the possibility of bad wireless connectivity. Has latest firmware 5.0.11
Please advice in any way possible thanks in advance.
233 REPLIES 233

Here it is.. I just left the phone idle till it lost the registration, and after like 1 or 2 minutes, I accessed via GUI and did the /admin/reboot (which make it re-registered the phone)

Thanks Alex.




Hi Alex,

Do you have any other SPA phones or ATAs on your network, registered to the same SIP proxy? If so, do they work without problem?

Would you be able to provide me a test account on you server please? This will allow Engineering to test in your environment?

Looking at your trace, I see the following:

Packet:                 Dest: WIP310 >                                 Info:                      Nonce:                 Time since capture started

784                         >                                             REGISTER request            7a7dd407            1560

786                         <                                             100 Trying                                                     1560

787                         <                                             401 Unauthorized            0e54395c             1560

788                         >                                             REGISTER request            7a7dd407            1564

791                         <                                             100 Trying                                                     1564

792                         <                                             401 Unauthorized            6776a3ed             1564

811                         >                                             REGISTER request            0e54395c             1569

813                         <                                             100 Trying                                                     1569

814                         <                                             401 Unauthorized            1a6071d9             1569

832                         >                                             REGISTER request            0e54395c             1573

833                         <                                             100 Trying                                                     1573

834                         <                                             401 Unauthorized            039c8df6              1573

853                         >                                             REGISTER request            1a6071d9             1577

871                         <                                             100 Trying                                                     1577

872                         <                                             401 Unauthorized            7b1c190b             1577

1296                       >                                             /admin/reboot command issued             1677

1328                       >                                             REGISTER request            n/a                       1685

1338                       <                                             100 Trying                                                     1685

1339                       <                                             401 Unauthorized            139c9511              1685

1358                       >                                             REGISTER request            139c9511              1685

1360                       <                                             100 Trying                                                      1685

1365                       <                                             200 OK                                                            1685

1366                       <                                             NOTIFY                                                            1685

1388                       >                                             200 OK                                                            1685





I am very interested to see a resolution to this problem.  Quickly - as this was not cheap!  And I don't want to have to upgrade my access point...  Though on the cards.

I first noted this in May when I received my 310 (though I did'nt log it here on the Cisco forum) did flag to supplier and voxilla.

From my perspective there is an underlying wireless connectivity issue.  Reflecting, the fact that the unit was less than 8ft from the access point, with limited interference.  And on failure (and loss of registration) the unit needs to be re-assocaited with its wireless access point, only then can it be pinged and access to the wep-ui be attempted. Of note, I find the web-ui slow compared to a SPA941 on a the end of Linksys wirelss adapter device.

Finally, I use the 310 with the SPA9000 and 6 SPA phones (a mix of 941 and 942).



Some breif updates:

- I've updated the wireless access point to the Cisco/Linksys WAP2000.  Some initial problems trying to associate - but that could have been more humam error around WEP.  Originally it was associated to a Netgear unit.

- Immediately notice that the battery ppower settled.  In retrospect I had noticed before that the unit kep having to recharge. Now it got to full charge and stayed there.

- There were initial re-registering problems - but again the unit settled down.  I had previously changed the SIP timing from 0.5 to 2.

- Another item: I can't ping or get to the web-ui, but the system is still registering on the SPA9000.

I will have time next week to do full diag and pull logs.

Patrick is there any timeline for a new software version?

I am also experiencing this issue.  I have my WIP310 connected to Asterisk v1.6 through a Linksys WRT54GL router.  I have up until August 21st to RMA the phone.  Hopefully we can get a solution before then.  Let me know if I can be of any assistance to the CIsco engineering team in troubleshooting this issue.  Go, Cisco, go!



Lucky you that still have a chance to RMA the phone.. right now I have my 200 bux desktop adornment that just blinks red and sometimes green :(

Any update on the matter Patrick ??

1. Use WAP4410N

Trixbox (Asterisk Appliance)  ----- Cisco 2960 (POE) ------- Linksys WAP4410N  <----wifi-----> wip-310

After the firmware update with Flashman. I registered to the operator success. But making calls is very difficult, almost not. WAP4410N I use, then I replaced the D-Link 2640T calls very stable.

2. Use D-Link Wireless

then I replaced the D-Link 2640T calls very stable (OK).

How ?


Hi voipmartvn,

Can you please restate your question? I am not sure what you are asking.




I have spent some time rereading the entire thread and want to clarify my problem

I'm Using a WIP310 sw 5.0.11(10301355) in Trixbox

Phone will frequently lose registration - I have tried it on several wireless networks -- one in my home with optimal connectivity.

I have Changed my T1 timer to 2 and my Register Expires to 60.

Most frequently I notice it having a hard time reconnecting after I have made a call.

I am non-technical in this area and unable to follow your instructions earlier for the firmware upgrade. If this is needed, please provide complete instructions. I purchased this phone because I am traveling overseas and need to be able to connect remotely. Quick help would be appreciated.

The other issues I mentioned earlier are copied here:

Moreover, the documentation and several cisco/linksys reference software and help available at, which does not exist.

Also, I am unable ro register my wip310 as it is not in the dropdown lists of products (wip300 & wip320 is)

Final Issue, on a public WiFi, I open have to click "Accept" on a browser in order to connect. Is there any way to do this on the WIP310?

Hi Patrick,

after having gone through the whole thread I would like to bring this up again. I'm responsible for our companies' IT including telephony. We are currently migrating from traditional phone network to SIP based PBX (asterisk based). After having used a Cisco WIP310 for some time at home without much trouble we got 2 pcs. WIP310 for our company recently. For SIP migration they are used together with one Siemens SL75 WLAN (one of the very first WLAN SIP phones around).

Infrastructure looks like that:

Asterisk-Box --> ETH-Switch --> Cisco AP541N-E-K9 --> WiFi Phones

While the Siemens SL75 WLAN works without any issues we are getting very poor reliability from those two WIP310 HW R03 (ACC135107BL, ACC1404086H). Most dominant problem is the "Not Registered" issue arising randomly, even when WLAN signal is strong (like reported by others in this thread). After having adjusted T2 Timing parameter and switched backlight to never turn off we have no more "Not registered" but standby battery lifetime is not acceptable with this setting.

Another issue that is still arising are lost phone calls. Calls just abort randomly duruing conversation.

Currently these phones are simply not working for production use. Has there been any progress with these issues, is there another firmware I might try?

What about the others having had these problems, did you succeed or simply gave up?

Thanks a lot in advance,



A significant amount of time has passed since this thread was started and Cisco elevated the problem internally.  Can someone from Cisco please give us an update as to when these phones will work and or we can get a refund?

Hi reputablesquid,

It was me who elevated the issue to Escalation Engineering.

In addition, I tested my WIP310 unit against a SPA9000 and then against an Asterisk server. Each test was over several days, in and out of cradle, charging and off of battery.

I was not able to replicate registration issues. [running Asterisk > SLM224P > WRV200 > WIP310]

Escalation Engineering also tried in their labs, and were unable to replicate the problem. I requested a test account earlier in this thread but have not yet received an account. [I've been out, and may have missed an email]

Are you able to provide a test account on your server so that we can attempt to replicate and better understand the issue?

I'm not in support, or in sales, so I can't speak to the refund question.




Glad your back on the thread Patrick..

I sent you the ip, username and password for my asterisk via PM on the forum.. check if u still have it or I can send it again so you can test.. Or give me a number where I could call in in case you need some live debugging..

Hi Alex,

Thanks, I'd missed the PM. I've registered a WIP310 to your trixbox server and so far, the WIP310 has not lost registration. It's been solidly registered for about 90 minutes so far.

My test environment is:

WIP310 > WRV200 > Cable Modem > Internet

The WIP310:

- has 3 of 4 bars of wireless reception

- is running on battery

- lying on its back, face up

I'm running debug level 3 on the phone so hopefully I'll capture something of interest should a problem occur




This widget could not be displayed.