cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
1718
Visitas
15
ÚTIL
22
Respuestas
leoelectrodata
Beginner

No funciona IVR o incoming Call

Hola.

 

Estoy trabajando en un GW de voz 2921 que va integrado al CUCM 9x.. Los anexos se registran en el CUCM y el GW esta en modo SRST.  Las llamadas salientes funcionan sin ningún problema desde el CUCM hacia el gateway conectado a una E1.  El problema esta en el IVR que se configuró o las llamadas entrantes. Al llamar al cualquiera de los n° asignados por el proveedor de la E1, dice que el número no existe, y viendo parte del debug voice ccapi inout me he dado cuenta en vez de decir dest=2600 dice dest=600 y no sale por el dial-peer 2600 si no por el dial-peer 1 que es donde salen las llamadas.

 

Dejo copia del debug y parte del show run;

 

 

voice#

Dec  4 02:51:14.218: //-1/xxxxxxxxxxxx/CCAPI/ccAppShutdownMode:

   remove it from the queue

Dec  4 02:51:45.118: //-1/D88EFCDA8002/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=0

   cisco-anitype=2

   cisco-aniplan=1

   cisco-anipi=0

   cisco-anisi=3

   dest=600  ----> debería ser 2600

   cisco-desttype=4

   cisco-destplan=1

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

 

 

Dec  4 02:51:45.118: //-1/D88EFCDA8002/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x22E7CFF8, Call Info(

   Calling Number=0,(Calling Name=)(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),

   Called Number=600 ----> debería ser 2600  (TON=Subscriber, NPI=ISDN),

   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=1,----> debería ser dial-peer=2600 Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=0, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1

Dec  4 02:51:45.118: //-1/D88EFCDA8002/CCAPI/ccCheckClipClir:

   In: Calling Number=(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)

Dec  4 02:51:45.118: //-1/D88EFCDA8002/CCAPI/ccCheckClipClir:

   Out: Calling Number=(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)

Dec  4 02:51:45.118: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

 

 

Dec  4 02:51:45.118: :cc_get_feature_vsa malloc success

Dec  4 02:51:45.118: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

 

 

Dec  4 02:51:45.118:  cc_get_feature_vsa count is 1

Dec  4 02:51:45.118: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

 

 

Dec  4 02:51:45.118: :FEATURE_VSA attributes are: feature_name:0,feature_time:599716064,feature_id:3

Dec  4 02:51:45.118: //3/D88EFCDA8002/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),

   Called Number=600(TON=Subscriber, NPI=ISDN))

Dec  4 02:51:45.118: //3/D88EFCDA8002/CCAPI/cc_process_call_setup_ind:

   Event=0x3D3225D8

Dec  4 02:51:45.118: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 600

Dec  4 02:51:45.118: //3/D88EFCDA8002/CCAPI/ccCallSetContext:

   Context=0x23BF1BEC

Dec  4 02:51:45.118: //3/D88EFCDA8002/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 3 with tag 1 to app "_ManagedAppProcess_Default"

Dec  4 02:51:45.122: //3/D88EFCDA8002/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

Dec  4 02:51:45.122: //3/D88EFCDA8002/CCAPI/ccCallDisconnect:

   Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Dec  4 02:51:45.122: //3/D88EFCDA8002/CCAPI/ccCallDisconnect:

   Cause Value=1, Call Entry(Responsed=TRUE, Cause Value=1)

Dec  4 02:51:45.122: //3/D88EFCDA8002/CCAPI/cc_api_get_transfer_info:

   Transfer Number=NULL

Dec  4 02:51:45.326: //3/D88EFCDA8002/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x22E7CFF8, Tag=0x0, Call Id=3,

   Call Entry(Disconnect Cause=1, Voice Class Cause Code=0, Retry Count=0)

Dec  4 02:51:45.326: //3/D88EFCDA8002/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

Dec  4 02:51:45.326: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

 

 

Dec  4 02:51:45.326: :cc_free_feature_vsa freeing 23BEF0D8

Dec  4 02:51:45.326: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

 

 

Dec  4 02:51:45.326:  vsacount in free is 0

2921-voice#

 

 

 

 

-------------------------- show run------------------------

 

voice translation-rule 1

rule 1 /.*/ /2542600/  -----> inicio n° asignao por el proveedor E1

!

voice translation-rule 2

rule 1 /^254/ //

!

!

voice translation-profile Anexos

translate called 2

!

voice translation-profile Cabecera

translate calling 1

!

!

!

!

application

service script2 flash:script2.tcl

!

service script3 flash:script3.tcl

!

service aa flash:its-CISCO.2.0.1.0.tcl

  param operator 2601

  paramspace english language en

  paramspace english index 0

  paramspace english location flash://

  param menu-timeout 1

  paramspace english prefix en

  param max-extension-length 4

  param aa-pilot 2600

!

service AA-Duke flash:script3.tcl

!

!

 

voice-port 0/0/0:15

translation-profile incoming Anexos

translation-profile outgoing Cabecera

!

!

!

!

!

!

mgcp profile default

!

!

dial-peer voice 1 pots

destination-pattern 9T

port 0/0/0:15

!

dial-peer voice 2 voip

destination-pattern 2...

session target ipv4:10.203.120.xxx

dtmf-relay rtp-nte h245-alphanumeric

!

dial-peer voice 2600 pots

description AutoAttendant

service aa

incoming called-number 2600

direct-inward-dial

port 0/0/0:15

---------------

 

Muchas gracias.

22 RESPUESTAS 22

Hola Leonardo,

Es correcto. Me parece que tienes que agregar las mismas configuraciones de aa en AA-Duke. ¿Ya lo intentaste?

Saludos,

Felipe Segnini

Ver la solución en mensaje original publicado

Estoy realizando las conf.

Que significa que salga este mensaje?

2921-Vo(config-app-param)# param operator 2601

Warning: parameter operator has not been registered under AA-Duke namespace

Saludos.

Es un mensaje genérico. Nada de que preocuparse. Siempre te va a salir.

Saludos,

Felipe Segnini

Ver la solución en mensaje original publicado

Hola.

Realizé las mismas configuraciones del service aa al service AA-Duke , pero no dió resultado .

cual debería ser la configuración ideal para que una llamada que es contestada por el IVR  y pasado unos segundo se redirige automaticamente a un anexo?.

saludos

A mi parecer creo que hay un problema de la señalización de los últimos 4 digitos que deberías de estar recibiendo sobre la E1.

controller E1 0/0/0

framing NO-CRC4

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

  country telmex

  category 2

  answer-signal group-b 1

  caller-digits 4

  trunk-group PSTN

description ENLACE HACIA PSTN

controller E1 0/0/0

framing NO-CRC4

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

  country telmex

  category 2

  answer-signal group-b 1

  caller-digits 4   ---> ESTE PARAMETRO A MI GUSTO ES EL QUE TE HACE FALTA.

    trunk-group PSTN

description ENLACE HACIA PSTN

Ver la solución en mensaje original publicado

leoelectrodata
Beginner

Hola

  Se solucionó el problema.  Era simple.   El problema que no se escuchaba el audio era que el archivo tcl tenía que agregar el "flash:".

Muchas gracias por las soluciones antes mencionada,

Saludos.

Hola Leonardo;

Lei el post y tengo el mismo problema que tu repersentas, entiendo que lo solucionaste agregando "flash" al archivo tcl? esta parte no la comprendo para poder aplicarlo a mi central, es decir tuviste que modificar el script del archivo .tcl o por el contrario agregaste una linea de comando en el servicio de application? te agradesco si me das una mano con este tema.

Gracias y saludos.

hola.

Cuando me refiero al flash, es porque el archivo tlc se agrega en la memoria del gateway, entonces la ruta que tenía en el tcl no tenía agregado el flash, lo agrege editando la linea que corresponde en el archivo TLC y se solucionó el problema. 

Saludos.

Crear
Reconozca a un colega
Content for Community-Ad