cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
552
Visitas
0
ÚTIL
1
Respuestas
tresdeasada
Beginner

No funcionan las llamadas entrantes SIP Trunk -> CUBE -> CUCM

Hola a todos. 

Estoy tratando de configurar telefonía IP por medio de SIP Trunk, el problema es que no puedo recibir llamadas entrantes, hago un debug ccsi all en mi GW y algunas veces aparece un debug o algunas otras no (por lo general este es el caso). Es como si la llamada ni siquiera entrara al GW.

La verdad soy bastante nuevo en esto de SIP Trunk y no sé si estoy omitiendo algo.

Pongo aquí la configuración con algunos valores ficticios.

 

 

Current configuration : 11885 bytes
!
! Last configuration change at 17:12:32 UTC Mon Jan 28 2019
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CUBE
!
boot-start-marker
boot-end-marker
!
!
logging buffered 1000000
!
aaa new-model
!
!
aaa authentication login VPNREMOTE-U local
aaa authorization network VPNREMOTE-G local
!
!
!
!
!
aaa session-id common
!
ip cef
!
!
!
!
ip dhcp pool ll
!
!
!
ip domain name empresa.com

ip name-server x.x.x.x
ip name-server x.x.x.x
ip name-server x.x.x.x

no ipv6 cef
!
multilink bundle-name authenticated
!
!
flow record FNFnbarREC
match ipv4 tos
match ipv4 dscp
match ipv4 protocol
match ipv4 source address
match ipv4 destination address
match transport source-port
match transport destination-port
match interface input
match application name
collect routing source as
collect routing destination as
collect routing next-hop address ipv4
collect ipv4 id
collect ipv4 source mask
collect ipv4 destination mask
collect transport tcp flags
collect interface output
collect flow direction
collect counter bytes
collect counter packets
collect timestamp sys-uptime first
collect timestamp sys-uptime last
!
!
flow exporter FNFnbarEXP
destination 192.168.1.48
source GigabitEthernet0/1
transport udp 9912
!
!
flow monitor FNFnbarMON
exporter FNFnbarEXP
cache timeout active 1
record FNFnbarREC
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-33
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-33
revocation-check none
rsakeypair TP-self-signed-33
!
!
crypto pki certificate chain TP-self-signed-33
voice-card 0
!
!
!
voice service voip
ip address trusted list
ipv4 192.168.120.5
ipv4 206.20.196.19
ipv4 169.132.196.33
address-hiding
allow-connections sip to sip
no supplementary-service sip refer
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
asserted-id pai
early-offer forced
!
voice class codec 10
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
!
!
voice translation-rule 1
rule 1 /.*/ /3886076389/ !Usuario de SIP trunk
!
voice translation-rule 2
rule 1 /5513211111/ /3001/ !Número telefónico 10 digitos a extensión de CUCM
!
!
voice translation-profile incsip
translate called 2
!
voice translation-profile out
translate calling 1
!
!
!
license udi pid CISCO2911/K9 sn 1
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
redundancy
!
!
!
!
!
ip ssh logging events
ip ssh version 2
!
track 100 ip sla 1
delay down 10 up 5
!
!
crypto isakmp policy 2
encr 3des
hash md5
authentication pre-share
group 2
lifetime 60800
crypto isakmp key empresa address 0.0.0.0
!
crypto isakmp client configuration group remote
key empresa
dns 192.168.130.2
wins 192.168.130.2
domain wr
pool VPNREMOTE-P
acl RECURSOS-V
crypto isakmp profile VPNclient
match identity group remote
client authentication list VPNREMOTE-U
isakmp authorization list VPNREMOTE-G
client configuration address respond
!
!
crypto ipsec transform-set TUNEL esp-3des esp-md5-hmac
mode tunnel
!
!
!
crypto dynamic-map VPNREMOTE-DYNAMIC 10
set transform-set TUNEL
set isakmp-profile VPNclient
reverse-route
!
!crypto map vpn
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description <<<< INTERNET >>>>
ip address 192.168.168.2 255.255.255.0
ip flow monitor FNFnbarMON input
ip flow monitor FNFnbarMON output
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description <<<< ENLACE A SW_CORE >>>>
ip address 192.168.100.2 255.255.255.240
ip flow ingress
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface GigabitEthernet0/2
description <<<PPPOE, no está en uso>>>
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Virtual-Template1
no ip address
!
interface Dialer0
no ip address
!
interface Dialer1
ip address negotiated
ip access-group EVITA-ICMP in
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname empresa.com
ppp chap password 0 empresa
ppp pap sent-username empresa.com password 0 empresa
crypto map Vpn
!
!
router eigrp 1
network 192.168.0.0 0.0.255.255
!
ip local pool VPNREMOTE-POOL 192.168.160.2 192.168.160.30
ip forward-protocol nd
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip dns server
ip nat inside source list 16 pool no-overloaded
ip nat inside source list NAT_Outside interface GigabitEthernet0/0 overload
ip nat inside source route-map nat-por-dialer1 interface Dialer1 overload
ip nat inside source static tcp 192.168.130.7 3000 ippublica 3000 extendable
ip nat inside source static tcp 192.168.130.7 3389 ippublica 3389 extendable
ip nat inside source static tcp 192.168.130.7 8091 ippublica 8091 extendable
ip route 0.0.0.0 0.0.0.0 192.168.168.1
ip route 0.0.0.0 0.0.0.0 206.20.196.19
ip route 0.0.0.0 0.0.0.0 169.132.196.33
ip route 169.132.0.0 255.255.255.255 192.168.168.1
ip route 206.20.0.0 255.255.255.255 192.168.168.1
!
ip access-list extended EVITA-ICMP
permit ip any any
deny icmp any host ip echo-reply log
deny icmp any host ip echo log
deny icmp any host ip echo-reply log
deny icmp any host ip echo log
ip access-list extended NAT_Outside
deny ip 192.168.0.0 0.0.255.255 10.10.1.0 0.0.0.255
remark Evita el NAT a los clientes VPN
deny ip 192.168.0.0 0.0.255.255 192.168.0.0 0.0.255.255
remark
remark NAT Internet
permit ip 192.168.0.0 0.0.255.255 any
ip access-list extended rv
permit ip 192.168.0.0 0.0.255.255 any
ip access-list extended tc
permit ip 192.168.1.0 0.0.0.255 10.10.0.0 0.0.255.255
permit ip 192.168.110.0 0.0.0.255 10.10.0.0 0.0.255.255
permit ip 192.168.130.0 0.0.0.255 10.10.0.0 0.0.255.255
deny ip any any
!
ip sla auto discovery
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 10 permit 192.168.110.0 0.0.0.255
access-list 10 permit 192.168.160.0 0.0.0.255
access-list 10 deny any
access-list 15 permit 192.168.100.0 0.0.0.15
access-list 15 permit 192.168.0.0 0.0.255.255
access-list 15 permit 192.168.1.0 0.0.0.255
!
!
snmp-server enable traps ospf state-change
snmp-server enable traps ospf cisco-specific state-change shamlink interface
snmp-server enable traps entity-sensor threshold
!
!
!
control-plane
!
!
voice-port 0/0/0
cptone
timing hookflash-out 50
timing guard-out 1000
caller-id enable
!
voice-port 0/0/1
cptone
timing hookflash-out 50
timing guard-out 1000
caller-id enable
!
voice-port 0/0/2
cptone
timing hookflash-out 50
timing guard-out 1000
caller-id enable
!
voice-port 0/0/3
cptone
timing hookflash-out 50
caller-id enable
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 192.168.120.5
ccm-manager config
!
mgcp
mgcp call-agent 192.168.120.5 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
!
mgcp profile default
!
!
dial-peer voice 99900992 pots
service mgcpapp
port 0/0/2
!
dial-peer voice 99900993 pots
service mgcpapp
port 0/0/3
!
dial-peer voice 99900990 pots
service mgcpapp
port 0/0/0
!
dial-peer voice 99900991 pots
service mgcpapp
port 0/0/1
!
dial-peer voice 99900099 pots
service mgcpapp
port 0/0/0
!
dial-peer voice 99900199 pots
service mgcpapp
port 0/0/1
!
dial-peer voice 99900299 pots
service mgcpapp
port 0/0/2
!
dial-peer voice 99900399 pots
service mgcpapp
port 0/0/3
!
dial-peer voice 1 voip !!!Llamadas salientes funcionando!!!
translation-profile outgoing out
destination-pattern T
session protocol sipv2
session target sip-server
voice-class codec 10
voice-class sip early-offer forced
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte h245-alphanumeric
no vad
!
dial-peer voice 3 voip
session protocol sipv2
session target sip-server
incoming called-number .%
voice-class codec 10
voice-class sip early-offer forced
voice-class sip bind media source-interface GigabitEthernet0/1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 5 voip !!!Falla en llamadas entrantes!!
translation-profile incoming incsip
session protocol sipv2
incoming called-number 5513211111
voice-class codec 10
voice-class sip early-offer forced
dtmf-relay rtp-nte
no vad
!
dial-peer voice 6 voip
destination-pattern ....
session protocol sipv2
session target ipv4:192.168.120.5
voice-class codec 10
voice-class sip early-offer forced
dtmf-relay rtp-nte
no vad
!
!
sip-ua
credentials username 3886076389 password contraseña realm net2phone
authentication username 3886076389 password contraseña
retry invite 2
timers connect 100
registrar dns:siptrunk.net2phone.com expires 3600
sip-server dns:siptrunk.net2phone.com
host-registrar
!
!
!
gatekeeper
shutdown

 

 

Les recuerdo que no hace ni siquiera debug de las entrantes, espero me puedan orientar.

 

Gracias por leer!

1 RESPUESTA 1

Las salientes funcionan? Con el "show sip connection UDP/TCP detail" te aparece el trunk establecido? Tienes la IP del otro extremo entre las "ip address trusted list"?