cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
429
Visitas
0
ÚTIL
2
Respuestas

Problemas para sacar llamadas en GW de voz

Hola que tal espero que me puedan apoyar con esto.

No se mucho de telefonia pero en estos momentos estoy levantando un call manager 9.1, el problema que tengo es que al momento de yo marcar un numero por ejemplo un celular veo que la llamada se incia pero nunca enlaza con el numero marcado, en el gw de voz con el comando sh voice call status, si observo que le llega la marcacion pero al parecer ya no sale por la pstn.

Actualmente tenemos un call manager 4.1 utilizando ese mismo GW de voz, entonces no se si mi problema sea desde la configuracion del Call manager 9.1 o  el problema esta en el GW de voz.

Mando la configuracion.

Marcando un numero local se observa que la marcacion si llega al GW pero ya no sale de ahi, no se si falte algo en el router como dial-peer

2821-AYTOAGS#sh voice call status

CallID     CID  ccVdb      Port        Slot/DSP:Ch  Called #   Codec    MLPP Dial-peers

0xFCA      929  0x47BEF0E0 0/0/0:1.1        0/1:1  *999101010  g711ulaw       0/9000

1 active call found

controller E1 0/0/0

framing NO-CRC4

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-21 type r2-digital r2-compelled ani

cas-custom 1

  country telmex

  category 2

  answer-signal group-b 1

  caller-digits 4

  groupa-callerid-end

!       

controller E1 0/1/0

framing NO-CRC4

clock source free-running

ds0-group 1 timeslots 1-15,17-31 type r2-analog r2-compelled ani

!       

controller E1 0/1/1

framing NO-CRC4

clock source free-running

ds0-group 1 timeslots 1-15,17-31 type r2-analog r2-compelled ani

!       

!       

interface Loopback1

ip address 10.1.0.1 255.255.255.0

!       

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 131.107.207.253 255.255.240.0

duplex auto

speed auto

h323-gateway voip bind srcaddr 131.107.207.253

!       

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!       

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 131.107.207.254

!       

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!       

!     

control-plane

!

!

!

voice-port 0/0/0:1

echo-cancel coverage 32

no vad

no comfort-noise

cptone MX

timeouts interdigit 2

timing inter-digit 50

connection plar 3950

!

voice-port 0/1/0:1

echo-cancel coverage 32

no vad

no comfort-noise

cptone MX

timing inter-digit 50

timing dialout-delay 50

!       

voice-port 0/1/1:1

echo-cancel coverage 32

no vad 

no comfort-noise

cptone MX

timing inter-digit 50

timing dialout-delay 50

!       

!       

!       

!       

!       

dial-peer voice 3000 voip

destination-pattern 3...

voice-class h323 1

session target ipv4:131.107.192.1

dtmf-relay h245-alphanumeric

codec g711ulaw

fax rate 9600

ip qos dscp cs5 media

no vad 

!       

dial-peer voice 1000 pots

destination-pattern 1...

direct-inward-dial

port 0/1/0:1

prefix 1

!

dial-peer voice 9000 pots

destination-pattern 9[^0].....

no digit-strip

direct-inward-dial

port 0/0/0:1

no register e164

!

dial-peer voice 900 pots

destination-pattern 01..........

no digit-strip

direct-inward-dial

port 0/0/0:1

forward-digits all

prefix 9

no register e164

!

dial-peer voice 9 pots

destination-pattern 900T

direct-inward-dial

port 0/0/0:1

prefix 00

no register e164

!

dial-peer voice 3208 voip

destination-pattern 3208

voice-class h323 1

session target ipv4:131.107.192.1

dtmf-relay h245-alphanumeric

codec g711ulaw

fax rate 9600

ip qos dscp cs5 media

no vad

!

dial-peer voice 1001 pots

destination-pattern 1...

direct-inward-dial

port 0/1/1:1

prefix 1

!       

dial-peer voice 91 pots

destination-pattern 044..........

no digit-strip

direct-inward-dial

port 0/0/0:1

forward-digits all

prefix 9

no register e164

!

dial-peer voice 95 pots

destination-pattern 045..........

no digit-strip

direct-inward-dial

port 0/0/0:1

forward-digits all

prefix 9

no register e164

!

!

!

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

login local

line vty 5 15

privilege level 15

login local

!

scheduler allocate 20000 1000

ntp source GigabitEthernet0/0

ntp master

end

1 SOLUCIÓN ACEPTADA

Soluciones aceptadas

Hola Chrystian,

Te recomendaría checar la versión de IOS ya que con CM 4 si funciona y CM 9 no:

Cisco Unified Communications System Release Summary Matrix for IP Telephony

http://www.cisco.com/en/US/docs/voice_ip_comm/uc_system/unified/communications/system/versions/IPTMtrix.html#wp1016708

Ya que este en una versión compatible veo que tu dail-peer envía solamente los últimos 7 dígitos:

9101010

destination-pattern 9[^0].....

no digit-strip

Te recomiendo obtener los debugs:

debug voice ccapi inout

debug vpm signal

debug voip vtsp all

Envíalos al buffer para no impactar el funcionamiento del router:

conf t

service timestamps debug datetime local msec

service timestamps log datetime local msec

service sequence

no logging console

no logging monitor

no logging rate-limit

no logging queue-limit

logging buffer 3000000 debug

end

De esta manera podrás verificar que sucede con el leg de la llamada hacia el proveedor.

Espero que esto ayude.

Saludos,

- Pablo

Ver la solución en mensaje original publicado

2 RESPUESTAS 2

Hola Chrystian,

Te recomendaría checar la versión de IOS ya que con CM 4 si funciona y CM 9 no:

Cisco Unified Communications System Release Summary Matrix for IP Telephony

http://www.cisco.com/en/US/docs/voice_ip_comm/uc_system/unified/communications/system/versions/IPTMtrix.html#wp1016708

Ya que este en una versión compatible veo que tu dail-peer envía solamente los últimos 7 dígitos:

9101010

destination-pattern 9[^0].....

no digit-strip

Te recomiendo obtener los debugs:

debug voice ccapi inout

debug vpm signal

debug voip vtsp all

Envíalos al buffer para no impactar el funcionamiento del router:

conf t

service timestamps debug datetime local msec

service timestamps log datetime local msec

service sequence

no logging console

no logging monitor

no logging rate-limit

no logging queue-limit

logging buffer 3000000 debug

end

De esta manera podrás verificar que sucede con el leg de la llamada hacia el proveedor.

Espero que esto ayude.

Saludos,

- Pablo

Gracias, cambie los dial peer y ya funciona de manera correcta.

Saludos

Vamos a comenzar

¡Conecte con otros expertos de Cisco y del mundo! Encuentre soluciones a sus problemas técnicos o comerciales, y aprenda compartiendo experiencias.

Queremos que su experiencia sea grata, le compartimos algunos links que le ayudarán a familiarizarse con la Comunidad de Cisco:

Reconozca a un colega