cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

153
Views
0
Helpful
2
Replies
Beginner

3745 with E1 connection problem

We have 3745 Router with E1 interface, configured for dial-in service with Toll free Number . What happens, user gets connected when dials through Tollfree Number and works fine. As per Telco ,the connection gets locked even after user disconnects the dial-in connection. In this case, after 30th connection, all the channels in E1 line gets locked and 31st user can't dial-in and he/she gets busy tone when dials .In this case , either I have to restart the E1 controller or call the Telco to unlock all the channels in E1 . Telco claims that this is something to do with Router configuration only as it does not release the connection after user disconnects the connection. I'm posting the configuration of RAS server which shows E1 controller configuration and Async configuration.

sh run

Building configuration...

Current configuration : 2458 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname RAS-SERVER

!

boot-start-marker

boot-end-marker

!

card type e1 1

enable secret xxxx

modem country mica e1-default

aaa new-model

!

!

aaa authentication login default group tacacs+ local enable

aaa authentication login notac enable

aaa authentication ppp default group tacacs+

aaa authorization exec default none

aaa authorization network default group tacacs+

aaa accounting network default start-stop group tacacs+

aaa session-id common

ip subnet-zero

!

!

!

ip domain name xxxxxx

no ftp-server write-enable

isdn voice-call-failure 0

chat-script offhook "" "ATH1" OK

!

!

!

controller E1 1/0

framing NO-CRC4

ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 0

unused-abcd 0 0 0 1

country saudiarabia

debounce-time 20

release-guard-time 250

dnis-complete

answer-guard-time 300

ani-define 8003031111

!

!

interface FastEthernet0/0

ip address x.x.x.x

speed 100

full-duplex

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Group-Async0

ip unnumbered FastEthernet0/0

encapsulation ppp

ip tcp header-compression

no ip mroute-cache

async mode interactive

peer default ip address pool dial-in

ppp authentication pap

group-range 129 158

line 129 158

session-timeout 500

absolute-timeout 500

modem Dialin

transport input all

autoselect ppp

line aux 0

line vty 0 4

exec-timeout 200 0

password xxxx

!

!

end

2 REPLIES 2
Highlighted
Cisco Employee

Re: 3745 with E1 connection problem

We need to see the following debugs for a incoming call starting from receipt of the call at 3745 till user disconnect the call.

debug modem csm

debug modem

debug cas

Make sure to disconnect the call after 1 mins of normal operation after connection.

Beginner

Re: 3745 with E1 connection problem

Thanks patel. I tried these debug commands and when user disconnects the RAS connection, modem gets disconnected at Router side and goes "idle " status. As per Telco engineer , he does not get RLG signal from my Router to release the trunk .Instead , he claims, he gets BLK signal and it blocks the trunk at Telco side. Telco has a similar setup (E1 link, connected with same Switch at Telco side) with some other customer and he gets line signals as follows and that customer's RAS server works fine without trunk blocking.

RCV : SZK AN RLG

SND : SZ CF

Whereas from my RAS server, he gets the signal as follows and he claims BLK signal blocks the trunking at Telco Switch:

RCV : SZK AN BLK

SND : SZ CF

Appreciated for your reply.

Regards,

Raju