cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
320
Views
0
Helpful
3
Replies
Beginner

AnyConnect - DHCP


Hi all,

When my client use AnyConnect Version 3.1.05187 and connect in some case they get the right subnet mask 255.255.255.0 and other times they get a 255.0.0.0 mask even though the DHCP server is configured to send /24 (this issue has been seen on an external windows server as well as on the firewall). however when it gives the /8 mask it also gives a incorrect default gateway

What is really weird is sometimes it works perfectly and sometimes not at to pinpoint the issue customer removed the possibility of it being two different servers by allowing the firewall to provide the DHCP address itself with the same results.

When client connect to other firewalls on different versions they do not experience this issue ( the correct mask is given and received each time).
they are running on 9.2(1) and and AC is
3.1.05187
I was not able to find any reported bug on the Cisco bug tool, anyone has any idea why this is happing only on this version?

 

thanks a lot

regards,

Lancellot

3 REPLIES 3
Beginner

Is it possible for you to

Is it possible for you to paste the configuration related to the VPN?

 

How are you assigning the IP address to the user? Through a DHCP server or through a VPN pool configured on the ASA? If it is through a local pool configured on the ASA then please send me the output of "wh run ip local pool"

 

I will get back to you once i have the above information.

 

 

Thanks

Jeet Kumar

Highlighted
Beginner

Hi Jeet, this was done on the

Hi Jeet,

 

this was done on the external server as well as on the ASA (behaviour are the same), please bear with me, I will get the information.

regards,

Lance

Beginner

Sure i will wait for the

Sure i will wait for the configuration and try my best to help you out.

 

Thanks

Jeet Kumar