cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

634
Views
5
Helpful
2
Replies
Participant

AnyConnect VPN Profile not getting installed with msi

I am trying to install AC core-vpn form the msi using this cli command taken from the admin guide:

msiexec /package anyconnect-win-4.6.02074-core-vpn-predeploy-k9.msi /norestart /passive

I have also prepped a vpn profile xml file with the local editor and saved it into the Profile\vpn folder of the installation folder hierarchy.

So when I run the above msiexec command, the AC client gets installed fine, but when I launch it, I do not see the server listed in the dropdown (that should be read from the xml file).  In fact, looking at the installed folder(s), I don't see the xml file there at all.

 

What have I done wrong here?

 

Even when I try manually copying the xml file to the installed folder:

C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\

or to a new folder:

C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\Profiles\

the AC client does not seem to find the xml file.

 

Please help.

 

Thanks.

 

John

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor RJI VIP Advisor
VIP Advisor

Re: AnyConnect VPN Profile not getting installed with msi

Hi John,
The XML file should be located in the ProgramData folder:- "C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\Profile". Restart the AnyConnect services and it should then detect the profile.

I'd have to double check my lab/notes regarding your issue with installation

View solution in original post

2 REPLIES 2
VIP Advisor RJI VIP Advisor
VIP Advisor

Re: AnyConnect VPN Profile not getting installed with msi

Hi John,
The XML file should be located in the ProgramData folder:- "C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\Profile". Restart the AnyConnect services and it should then detect the profile.

I'd have to double check my lab/notes regarding your issue with installation

View solution in original post

Participant

Re: AnyConnect VPN Profile not getting installed with msi

Thanks Rahul.

 

I figured it out... the problem was I was installing the AC client from a mapped network drive instead of from the local HD.  Once I copied the entire installation folder (with profile) to the local computer and then ran the installation, the profile got copied properly to the Program Data folder as you provided.