cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

402
Views
0
Helpful
3
Replies
Highlighted
Beginner

ASA5505 Site-toSite 3825

I have over 60 hours invested in trying to figure this out.

I have an ASA5505 that will not connect back to my 3825.

Its "sister" running the same config (except for inside subnets, and outside ip addresses that is) connects just fine.

Here is the config on the ASA:

ZAKASA# sh run
: Saved
:
ASA Version 8.0(4)
!
hostname ZAKASA
domain-name ********
enable password ******** encrypted
passwd ******** encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 172.16.64.254 255.255.240.0
!
interface Vlan2
nameif outside
security-level 0
ip address ********.9 255.255.255.0
!
interface Vlan5
nameif VLAN5
security-level 100
ip address 192.168.12.254 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
switchport trunk allowed vlan 1-2,5,1002-1005
switchport trunk native vlan 1
!
interface Ethernet0/3
!
interface Ethernet0/4
shutdown
!
interface Ethernet0/5
shutdown
!
interface Ethernet0/6
shutdown
!
interface Ethernet0/7
switchport trunk allowed vlan 1-2,5,1002-1005
switchport trunk native vlan 1
switchport mode trunk
!
ftp mode passive
clock timezone EST -5
dns domain-lookup inside
dns server-group DefaultDNS
name-server 172.16.18.10
name-server 172.16.18.11
name-server 4.2.2.2
domain-name ********
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 172.16.16.0 255.255.240.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 172.16.32.0 255.255.240.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 172.16.48.0 255.255.240.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 172.16.96.0 255.255.240.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 10.2.2.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 10.3.3.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 10.4.4.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 10.12.12.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 10.13.13.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 10.14.14.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 172.16.80.0 255.255.240.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 10.5.5.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.16.64.0 255.255.240.0 10.7.7.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 10.1.1.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 10.2.2.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 10.3.3.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 10.4.4.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 10.5.5.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 10.7.7.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 10.12.12.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 10.13.13.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 172.16.16.0 255.255.240.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 172.16.32.0 255.255.240.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 172.16.48.0 255.255.240.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 172.16.80.0 255.255.240.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 172.16.96.0 255.255.240.0
access-list outside_1_cryptomap extended permit ip 172.16.64.0 255.255.240.0 172.16.112.0 255.255.240.0
access-list capout extended permit ip host ********.162 host ********.9
access-list capout extended permit ip host ********.9 host ********.162
access-list capout extended permit udp host ********.9 eq 4500 host ********.162
access-list capout extended permit udp host ********.9 eq isakmp host ********.162
access-list capout extended permit udp host ********.162 host ********.9 eq isakmp
access-list capout extended permit udp host ********.162 host ********.9 eq 4500
access-list VoIp-Traffic_out extended permit ip 172.16.16.0 255.255.240.0 172.16.64.0 255.255.240.0
access-list VoIp-Traffic_out extended permit ip 172.16.64.0 255.255.240.0 172.16.16.0 255.255.240.0
access-list VoIP-Traffic_IN extended permit tcp 172.16.16.0 255.255.240.0 172.16.64.0 255.255.240.0 eq h323
access-list VoIP-Traffic_IN extended permit tcp 172.16.16.0 255.255.240.0 172.16.64.0 255.255.240.0 eq sip
access-list VoIP-Traffic_IN extended permit tcp 172.16.16.0 255.255.240.0 172.16.64.0 255.255.240.0 eq 2000
access-list vl5_nat extended permit ip 192.168.12.0 255.255.255.0 any
pager lines 24
mtu inside 1500
mtu outside 1500
mtu VLAN5 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
nat (VLAN5) 1 192.168.12.0 255.255.255.0
route outside 0.0.0.0 0.0.0.0 ********.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set myset1 esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer ********.162
crypto map outside_map 1 set transform-set myset1
crypto map outside_map 1 set security-association lifetime seconds 28800
crypto map outside_map 1 set security-association lifetime kilobytes 4608000
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 1
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
crypto isakmp policy 10
authentication pre-share
encryption aes
hash sha
group 5
lifetime 86400
telnet timeout 60
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 VLAN5
ssh timeout 60
console timeout 0
management-access inside
dhcpd lease 14400
dhcpd domain ********
!
dhcpd address 172.16.64.101-172.16.64.200 inside
dhcpd dns 172.16.18.11 4.2.2.2 interface inside
dhcpd lease 14400 interface inside
dhcpd ping_timeout 750 interface inside
dhcpd domain ******** interface inside
dhcpd enable inside
!
dhcpd address 192.168.12.101-192.168.12.200 VLAN5
dhcpd dns 172.16.18.11 4.2.2.2 interface VLAN5
dhcpd lease 14400 interface VLAN5
dhcpd ping_timeout 750 interface VLAN5
dhcpd domain ******** interface VLAN5
dhcpd enable VLAN5
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username ******** password ******** encrypted privilege 15
tunnel-group ********.162 type ipsec-l2l
tunnel-group ********.162 ipsec-attributes
pre-shared-key *
!
class-map Voice_OUT
match dscp ef
class-map Voice_IN
match dscp ef
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect xdmcp
policy-map VoicePolicy
class Voice_OUT
  priority
class Voice_IN
  priority
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:********
: end
ZAKASA#

The 3825 is configured the same for the other 5505's,891's, 3825's, and 2621's that connect to it.

Any help would be most appreciated.

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions

ASA5505 Site-toSite 3825

Hello,

Glad to hear that is up and running

Please mark the question as answered so future users can learn from your reply

Regards

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC

View solution in original post

3 REPLIES 3

ASA5505 Site-toSite 3825

Hello,

Dude we need more information:

-Configuration of the other side

-Maybe some logs

Also the following:

packet-tracer input inside icmp x.x.x.x ( Internal host IP) 8 0  y.y.y.y ( Other side of the VPN host)

Do it twice and send me the output of the second one

Regards

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
Beginner

ASA5505 Site-toSite 3825

I ended up wiping the ASA, reloading the config line by line as it is above and now it works.

ASA5505 Site-toSite 3825

Hello,

Glad to hear that is up and running

Please mark the question as answered so future users can learn from your reply

Regards

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC

View solution in original post