cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1927
Views
0
Helpful
2
Replies

IPv4 DMVPN over IPv6 WAN - Configuration

thomas.busse
Level 1
Level 1

Hello everyone,

I'm struggeling to get a DMVPN to work over an IPv6 WAN Network.

I have testet IPv6 connectivity from the Spoke (2001:2:2:2::1/64) to the Hub (2001:1:1:1::1/64) which is successful, there is also an IPv6 default route to my "ISP", I also have an crypto isakmp key for IPv6 addresses and my Tunnel Configuration looks like this:

Did anyone configure a scenario like this and could point me in the right direction ? :-)

Thanks in advance

Greetings,

Thomas

### HUB Configuration ###

interface Tunnel1

description ** DMVPN Intranet **

bandwidth 1000

ip vrf forwarding VPN

ip address 10.0.10.1 255.255.255.0

no ip redirects

ip mtu 1416

no ip next-hop-self eigrp 65351

no ip split-horizon eigrp 65351

ip pim sparse-mode

ip nhrp map multicast dynamic

ip nhrp network-id 1

ip nhrp holdtime 360

ip nhrp shortcut

ip nhrp redirect

ip tcp adjust-mss 1360

load-interval 30

ipv6 nhrp map multicast dynamic

ipv6 nhrp network-id 1

ipv6 nhrp holdtime 360

ipv6 nhrp shortcut

ipv6 nhrp redirect

keepalive 10 3

tunnel source GigabitEthernet0

tunnel mode gre multipoint

tunnel key 1

tunnel protection ipsec profile My-Profile shared

### Spoke Configuration ###

interface Tunnel1

description ** DMVPN Intranet **

ip vrf forwarding VPN

ip address 10.0.10.2 255.255.255.0

ip mtu 1416

ip pim sparse-mode

ip nhrp map 10.0.10.1 2001:1:1:1::1

ip nhrp map multicast 2001:1:1:1::1

ip nhrp network-id 1

ip nhrp holdtime 360

ip nhrp nhs 10.0.10.1

ip nhrp shortcut

ip tcp adjust-mss 1360

delay 1000

tunnel source GigabitEthernet0

tunnel mode gre multipoint

tunnel key 1

tunnel protection ipsec profile My-Profile shared

2 Replies 2

thomas.busse
Level 1
Level 1

Hi,

I got a solution for this.

My configuration is as follows, I missed the keyword "tunnel mode gre multipoint ipv6"

### Hub ###

interface Tunnel1

description ** DMVPN Intranet **

bandwidth 1000

ip vrf forwarding VPN

ip address 10.0.10.1 255.255.255.0

ip mtu 1416

no ip next-hop-self eigrp 65351

no ip split-horizon eigrp 65351

ip pim sparse-mode

ip nhrp map multicast dynamic

ip nhrp network-id 1

ip nhrp holdtime 360

ip nhrp shortcut

ip nhrp redirect

ip tcp adjust-mss 1360

load-interval 30

keepalive 10 3

tunnel source GigabitEthernet0

tunnel mode gre multipoint ipv6

tunnel key 1

tunnel protection ipsec profile My-Profile shared

### Spoke ###


interface Tunnel1

description ** DMVPN Intranet **

ip vrf forwarding VPN

ip address 10.0.10.2 255.255.255.0

ip mtu 1416

ip pim sparse-mode

ip nhrp map 10.0.10.1 2001:1:1:1::1

ip nhrp map multicast 2001:1:1:1::1

ip nhrp network-id 1

ip nhrp holdtime 360

ip nhrp nhs 10.0.10.1

ip nhrp shortcut

ip tcp adjust-mss 1360

delay 1000

tunnel source GigabitEthernet0

tunnel mode gre multipoint ipv6

tunnel key 1

tunnel protection ipsec profile My-Profile shared

end

Greetings

Thomas

Hi Thomas,

Thanks for providing your solution. I am also looking for a similar solution as it is har to get IPv4 PI prefix.

Could you describe a bit more your DMVPN design? Are you using IPV6 prefixes because it was hard to get an IPv6 PI prefix? Are you bgp multihomed?

Best Regards,

Laurent

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: