cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
860
Views
0
Helpful
0
Replies

L2TP over IPSEC vpn on ASA 5506

razzaque003
Level 1
Level 1

Hi,

 

I have been struggling with windows L2TP remote access vpn on Cisco ASA5506 with PSK for a long time now. The session simply fails immediately after completing PHASE-2. The configuration on the ASA looks like this:

ASA Version 9.6(1)
!
command-alias exec u undebug all
hostname ITBFW
domain-name ITB
enable password s.5F1xBa8K6wc1.B encrypted
passwd DeviMZQXvoEmq3qZ encrypted
names
dns-guard
ip local pool VPN_POOL 192.168.100.1-192.168.100.254 mask 255.255.255.0

!
interface GigabitEthernet1/1
nameif outside
security-level 0
ip address <public ip>
!
interface GigabitEthernet1/2
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet1/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/6
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/7
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/8
nameif Inter_1144
security-level 0
pppoe client vpdn group Inter-1144
ip address pppoe setroute
!
interface GigabitEthernet1/9
nameif ITBwifi
security-level 100
ip address 192.168.10.1 255.255.255.0
!
interface Management1/1
management-only
no nameif
no security-level
no ip address
!
ftp mode passive
clock timezone AST 3
dns domain-lookup inside
dns server-group DefaultDNS
name-server 192.168.1.240 inside
domain-name ITB
same-security-traffic permit inter-interface
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network VPN_SUBNET
subnet 192.168.100.0 255.255.255.0
access-list AnyConnect_Client_Local_Print extended deny ip any4 any4
access-list AnyConnect_Client_Local_Print extended permit tcp any4 any4 eq lpd
access-list AnyConnect_Client_Local_Print remark IPP: Internet Printing Protocol
access-list AnyConnect_Client_Local_Print extended permit tcp any4 any4 eq 631
access-list AnyConnect_Client_Local_Print remark Windows' printing port
access-list AnyConnect_Client_Local_Print extended permit tcp any4 any4 eq 9100
access-list AnyConnect_Client_Local_Print remark mDNS: multicast DNS protocol
access-list AnyConnect_Client_Local_Print extended permit udp any4 host 224.0.0.251 eq 5353
access-list AnyConnect_Client_Local_Print remark LLMNR: Link Local Multicast Name Resolution protocol
access-list AnyConnect_Client_Local_Print extended permit udp any4 host 224.0.0.252 eq 5355
access-list AnyConnect_Client_Local_Print remark TCP/NetBIOS protocol
access-list AnyConnect_Client_Local_Print extended permit tcp any4 any4 eq 137
access-list AnyConnect_Client_Local_Print extended permit udp any4 any4 eq netbios-ns
access-list SPLIT-TUNNEL standard permit 192.168.1.0 255.255.255.0
access-list inside_access_in extended permit ip any any
access-list ITBwifi_access_in extended permit ip any any
access-list 100 extended permit icmp any any
access-list DefaultRAGroup_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
pager lines 24
logging enable
logging timestamp
logging monitor emergencies
logging buffered informational
logging trap notifications
logging history emergencies
logging asdm notifications
logging queue 1024
logging device-id string ITBASA
logging host inside 192.168.1.232
logging permit-hostdown
mtu outside 1500
mtu inside 1500
mtu Inter_1144 1500
mtu ITBwifi 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any ITBwifi
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (ITBwifi,Inter_1144) source dynamic any interface
nat (inside,Inter_1144) source dynamic any interface
nat (inside,outside) source dynamic any interface
nat (ITBwifi,outside) source dynamic any interface
nat (inside,outside) source static any any destination static VPN_SUBNET VPN_SUBNET no-proxy-arp route-lookup
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 <public ip>
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authorization exec LOCAL auto-enable
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.10.0 255.255.255.0 ITBwifi
no snmp-server location
no snmp-server contact
sysopt connection preserve-vpn-flows
service sw-reset-button
crypto ipsec ikev1 transform-set L2TP-IKE1-TRANSFORM-SET esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set L2TP-IKE1-TRANSFORM-SET mode transport
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map L2TP-MAP 10 set ikev1 transform-set L2TP-IKE1-TRANSFORM-SET
crypto map Inter_1144_map interface Inter_1144
crypto map L2TPVPN 20 ipsec-isakmp dynamic L2TP-MAP
crypto map L2TPVPN interface outside
crypto ca trustpoint ASDM_TrustPoint0
enrollment self
subject-name CN=ITBFW
crl configure
crypto ca trustpool policy
crypto ca certificate chain ASDM_TrustPoint0
certificate 306a015c
308202d0 308201b8 a0030201 02020430 6a015c30 0d06092a 864886f7 0d010105
0500302a 310e300c 06035504 03130549 54424657 31183016 06092a86 4886f70d
01090216 09495442 46572e49 5442301e 170d3138 31323035 31353436 33395a17
0d323831 32303231 35343633 395a302a 310e300c 06035504 03130549 54424657
31183016 06092a86 4886f70d 01090216 09495442 46572e49 54423082 0122300d
06092a86 4886f70d 01010105 00038201 0f003082 010a0282 010100d2 c278947e
33aaf8e8 cbe1cb6a 7f10ce18 04942841 5a29f885 31add909 28a17f68 4f7fa0f0
b6680191 044cb754 e7439a06 9d4759bd 84de2ca3 2fb44a8e b5b3f140 c519d01a
3aa4cf47 9c3eadc1 cd51fa2b 4567cfb1 6f258baf 4906c05e 8a5afaa7 6a1c02d3
7aed3f39 790e8a2e 4dbafdba 8382aa09 7c10928c 1d64f8fb 411e8708 c0d45b6e
31612eaa 90910c72 8854700f c92f8260 b7f92104 644947cc 23fd6cf6 3215d28d
97074fad 1f213c93 0ec166d0 921dfd90 31bacadf a858f550 8a2bad2d 84da2595
0f890d3b 134155ff 94898877 e00fc1bb 785eaa3e f7257d30 78501ba3 8d99f985
05673af6 67d6d0e3 8059d864 382db319 12959f60 160806b1 2adab502 03010001
300d0609 2a864886 f70d0101 05050003 82010100 cbcd4cd5 39ac66cd 95c12db3
77c0afe6 30757be8 28827885 a4533737 3c49815f d20be771 f3340627 fc42bce0
0bd36664 8c058f64 54902fe4 c379052a 60c8ad4d d4288c3e e2f3b65a 0bc2074d
8f68648f ca27ed83 16308a75 5d95acd2 8ea47195 ea1b15c4 bd4fca5d db0f3468
852b1303 e2a48cc2 714f0105 63b20a77 1271f4ab 88b08630 935f54bd b90df4b4
ca931495 7b7ad7eb b6fd6731 f81daacb ef3a8201 87ec7bfa 86cf867d 80448470
414c57ef faf02820 3da2f687 906f412b 6a316383 ee41ba25 c1b69b8a 286053f8
09b53605 80cb2c9f 76882eee a107b213 acc1eba1 280ac088 161d2b42 aef14bbb
c200ac31 a4e7abc5 a001e165 00e811bf 9991fc41
quit
crypto ikev2 remote-access trustpoint ASDM_TrustPoint0
crypto ikev1 enable outside
crypto ikev1 policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh stricthostkeycheck
ssh 192.168.1.0 255.255.255.0 inside
ssh 192.168.10.0 255.255.255.0 ITBwifi
ssh timeout 10
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access inside
vpdn group Inter-1144 request dialout pppoe
vpdn group Inter-1144 localname 112151144@stc.net.sa
vpdn group Inter-1144 ppp authentication pap
vpdn username yyyyyyy@stc.net.sa password ***** store-local
vpdn username xxxxxxx@stc.net.sa password ***** store-local
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
vpn-sessiondb max-other-vpn-limit 10

dhcpd address 192.168.1.5-192.168.1.254 inside
dhcpd dns 8.8.8.8 8.8.4.4 interface inside
dhcpd domain ITB interface inside
dhcpd enable inside
!
dhcpd address 192.168.10.2-192.168.10.254 ITBwifi
dhcpd dns 8.8.8.8 8.8.4.4 interface ITBwifi
dhcpd enable ITBwifi
!
ssl trust-point ASDM_TrustPoint0 outside
webvpn
enable outside
anyconnect image disk0:/anyconnect-win-4.4.03034-webdeploy-k9.pkg 1
anyconnect profiles ITB_AnyConnect_client_profile disk0:/ITB_AnyConnect_client_profile.xml
anyconnect enable
tunnel-group-list enable
cache
disable
error-recovery disable
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
vpn-tunnel-protocol l2tp-ipsec ssl-client ssl-clientless
split-tunnel-policy tunnelspecified
split-tunnel-network-list value SPLIT-TUNNEL
webvpn
anyconnect profiles value ITB_AnyConnect_client_profile type user
group-policy DfltGrpPolicy attributes
banner value ****You have accepted following agreement****
banner value Access to this network and the information on it are lawfully available only for approved purposes by employees of ITB and other users authorized by ITB.
banner value If you are not an employee of ITB or an authorized user, do not attempt to log on. Other than where prohibited by law and subject to legal requirements,
banner value ITB reserves the right to review any information in any form on this network at any time.
dns-server value 192.168.1.240
vpn-simultaneous-logins 5
vpn-idle-timeout 15
vpn-tunnel-protocol ssl-client ssl-clientless
split-tunnel-policy tunnelspecified
split-tunnel-network-list value SPLIT-TUNNEL
default-domain value ITB
split-dns value ITB
address-pools value VPN_POOL
webvpn
url-list value Bookmarks
anyconnect profiles value ITB_AnyConnect_client_profile type user
anyconnect ask none default webvpn
keep-alive-ignore 100
group-policy L2TPGROUPPOLICY internal
group-policy L2TPGROUPPOLICY attributes
dns-server value 192.168.1.240
vpn-tunnel-protocol l2tp-ipsec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value SPLIT-TUNNEL
default-domain value ITB
intercept-dhcp enable
dynamic-access-policy-record DfltAccessPolicy
webvpn
always-on-vpn profile-setting
username admin password BOyrbVxxH1IXfdrd encrypted privilege 15
username admin attributes
vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-client ssl-clientless
password-storage disable
username ERP01 password j7QF/7AIxKe.Z.st encrypted
username ERP01 attributes
vpn-tunnel-protocol ssl-client ssl-clientless
password-storage disable
service-type remote-access
username ERP02 password O1CV8Krx940Q5pDU encrypted
username ERP02 attributes
vpn-tunnel-protocol ssl-client ssl-clientless
password-storage disable
service-type remote-access
username ahmad password OJfcJ2Hxc/KNzRchs0gtOw== nt-encrypted
username ahmad attributes
service-type remote-access
username cisco password vYuiToxJk1O.bB/3 encrypted privilege 15
username cisco attributes
vpn-group-policy DfltGrpPolicy
vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-client ssl-clientless
password-storage disable
tunnel-group DefaultRAGroup general-attributes
address-pool VPN_POOL
default-group-policy L2TPGROUPPOLICY
tunnel-group DefaultRAGroup ipsec-attributes
ikev1 pre-shared-key *****
tunnel-group DefaultRAGroup ppp-attributes
no authentication chap
no authentication ms-chap-v1
authentication ms-chap-v2
tunnel-group DefaultWEBVPNGroup general-attributes
address-pool VPN_POOL
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect icmp
class class-default
user-statistics accounting
inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:ac7db2aee883a36ff4f2e6095526bb85
: end

 

I am relatively new to ASA and any help would be appreciated. Its an urgent request.

 

Thanks.

0 Replies 0