cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

7885
Views
0
Helpful
8
Replies
Highlighted
Beginner

Site-Site VPN pings only one-way but all other traffic ok

I've setup an IPSec tunnel from our main site to a new remote site, as I have done all our other ones.  Traffic flows in both directions well and we can RDP for example in both directions to resources in either site.  I can ping from the remote site to HQ no problem, but I can't seem to do the same from HQ to the remote site.

I have the same firewall and NAT rules in place as I do all my other remote sites, but one thing that's different is that the remote ASA 5505 used to run ASA 8.4 but was downgraded to 8.2 to match all our other devices.  Before I performed the downgrade, I reset the config to the 8.4 factory default.  I then performed the downgrade and rebooted the ASA.  I did get a couple of errors relating to NAT but thought I had fixed them.  I supspect this may be the cause, but am confused as to why it's only ICMP in one direction which seems to be affected.

I've tried doing a nat-control and same-security-traffic permit intra-interface just in case but no difference so far in behaviour.

Any suggestions?

Everyone's tags (6)
8 REPLIES 8
Mentor

Site-Site VPN pings only one-way but all other traffic ok

Well,

The most common problem regarding ICMP is usually when you dont have "inspect icmp" enabled on an ASA. Its added under the "policy-map" configuration or directly with the command "fixup protocol icmp".  Without it it might allow the Echo through but not the Echo Reply. But dont know if that is the case this time.

Its hard to say when we dont have any configurations to look at.

You could always configure traffic capture on the HQ and Remote Site ASA for ICMP between the local and remote network and try to use that information to see where the traffic stops.

- Jouni

Contributor

Site-Site VPN pings only one-way but all other traffic ok

As Jouni said, icmp inspect usually solves this kind of problems, but in case of IPSec tunel it's not applicable, cause traffic in both directions are permitted through the tunnel by default (as long as vpn-filter is not confiugred).

If you say that RDP works fine, then maybe the host(s), you're trying to ping on the remote site doesn't allow/respond to the icmp echo? some kind of host-firewall enabled?

Beginner

Site-Site VPN pings only one-way but all other traffic ok

Thanks for the replies, the hosts I'm trying to ping at the remote site are just Windows PC's.  They do have the windows firewall enabled but they can ping each other on their LAN.  There's no group policy in place yet so they should respond to pings from all subnets.

I am sure this relates to the downgrade from 8.4 to 8.2 but I can't seem to find any procedures for it.  Here's the config on the remote ASA 5505.

: Saved
: Written by netadmin at 15:14:19.439 UTC Wed Apr 3 2013
!
ASA Version 8.2(5)
!
hostname
enable
passwd
names
name 10.48.0.0 airdrie-inside-network
name 172.16.1.0 dmz-network
name 10.254.1.0 vpnclients-network
name ADSL-Router860708 description Default Route Out
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 10.1.1.254 255.255.0.0
!
interface Vlan2
description Link to ADSL 860708
nameif outside
security-level 0
ip address 255.255.255.252
!
boot system disk0:/asa825-k8.bin
ftp mode passive
same-security-traffic permit intra-interface
object-group network obj_any
object-group network DM_INLINE_NETWORK_1
network-object vpnclients-network 255.255.255.0
network-object airdrie-inside-network 255.255.0.0
network-object dmz-network 255.255.255.0
object-group service DM_INLINE_SERVICE_1
service-object icmp
service-object tcp-udp eq domain
service-object tcp eq h323
service-object tcp eq www
service-object tcp eq https
service-object tcp eq kerberos
service-object tcp eq ldap
service-object tcp eq netbios-ssn
service-object tcp eq sip
service-object tcp eq ssh
service-object udp eq netbios-dgm
service-object udp eq netbios-ns
service-object udp eq ntp
service-object udp eq time
service-object tcp eq pop3
service-object tcp eq smtp
object-group service http-8080 tcp
port-object eq 8080
object-group service http-8081 tcp
port-object eq 8081
object-group service http-888 tcp
port-object eq 888
object-group service http-proxy tcp
port-object eq 3128
object-group service kerberos-tcp tcp
port-object eq 88
object-group service rdp tcp
port-object eq 3389
object-group service rpc tcp
port-object eq 135
object-group service rpc-range tcp
port-object range 1025 5000
port-object range 49152 65535
object-group service smb tcp
port-object eq 445
object-group service vmware-console tcp
port-object eq 902
object-group service teamviewer tcp
port-object eq 5938
object-group service DM_INLINE_TCP_1 tcp
group-object http-8080
group-object http-8081
group-object http-888
group-object http-proxy
group-object kerberos-tcp
group-object rdp
group-object rpc
group-object rpc-range
group-object smb
group-object vmware-console
group-object teamviewer
object-group service kerberos-udp udp
port-object eq 88
object-group service ldap-udp udp
port-object eq 389
object-group service DM_INLINE_UDP_1 udp
group-object kerberos-udp
group-object ldap-udp
access-list outside_1_cryptomap extended permit ip 10.1.0.0 255.255.0.0 object-group DM_INLINE_NETWORK_1
access-list inside_nat0_outbound extended permit ip 10.1.0.0 255.255.0.0 object-group DM_INLINE_NETWORK_1
access-list inside_access_in remark If any connectivity issues encountered just enable this rule
access-list inside_access_in extended permit ip any any inactive
access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_1 10.1.0.0 255.255.0.0 any
access-list inside_access_in extended permit tcp 10.1.0.0 255.255.0.0 any object-group DM_INLINE_TCP_1
access-list inside_access_in extended permit udp 10.1.0.0 255.255.0.0 any object-group DM_INLINE_UDP_1
pager lines 24
logging enable
logging asdm debugging
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-712.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 101 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 101 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 ADSL-Router860708 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 10.1.0.0 255.255.0.0 inside
http 10.48.30.0 255.255.255.0 outside
http 255.255.255.255 outside
http 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer
crypto map outside_map 1 set transform-set ESP-AES-256-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 10.1.0.0 255.255.0.0 inside
ssh 10.48.30.0 255.255.255.0 outside
ssh 255.255.255.255 outside
ssh 255.255.255.255 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.1.30.33-10.1.30.64 inside
dhcpd dns 212.9.0.135 8.8.8.8 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
username
username
tunnel-group type ipsec-l2l
tunnel-group ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:e29daae71580f03958cae299a0354aef

Contributor

Site-Site VPN pings only one-way but all other traffic ok

For some reason i don't see any problem on the remote site from the config provided). Maybe there's an ACL on the inside interface of the central site, wich denies echo-reply?

Beginner

Site-Site VPN pings only one-way but all other traffic ok

All other sites are ok and have the same nat rules etc.

One of the errors I got when I downgraded was with the obj_any object - do I still need that entry in 8.2?

Mentor

Site-Site VPN pings only one-way but all other traffic ok

Hi,

You seem to have the Default PAT rule for the Internet traffic and a NAT0 configuration that matches the L2L VPN ACL so those would seem to be fine.

In software 8.2 you wont even be able to configure "object network" as they dont exist. They were introduced in software 8.3(1)

I would suggest perhaps configuring a capture on the remote site ASA

access-list ICMP-CAP permit icmp host host

access-list ICMP-CAP permit icmp host host

capture ICMP-CAP type raw-data access-list ICMP-CAP buffer 1000000 interface inside circular-buffer

Then test the ICMP

After the test view the capture contents

show capture ICMP-CAP

And copy paste the output here

This should show if the ICMP echo from the HQ Site is arriving through the L2L VPN and if the Remote Site as sees a ICMP Echp Reply from the host on the Remote site.

You can remove the capture with command no capture ICMP-CAP

You can also copy the capture as a PCAP file from the ASA to a TFTP server and view the capture with Wireshark for example

copy /pcap capture:ICMP-CAP tftp://x.x.x.x/ICMP-CAP.pcap

- Jouni

Mentor

Site-Site VPN pings only one-way but all other traffic ok

Also,

You can always add the "fixup protocol icmp" since you dont have "inspect icmp" configured. Even if it didnt help with your situation.

- Jouni

Beginner

Site-Site VPN pings only one-way but all other traffic ok

This ended up being a Windows firewall issue.  The minute I put a dumb terminal over there I was able to ping it.  I joined the PC's over there to our Windows domain, and after they'd pulled the domain firewall profile from Group Policy (which responds to ICMP from subnet "*", the issue disappeared.