Showing results for 
Search instead for 
Did you mean: 

I had the same issue. Spybot

I had the same issue. Spybot Search and Destroy on my PC adds address to the c:\windows\System32\etc\HOSTS file. It seems that Cisco VPN does not look at the bottom of this big list, must only look down a finite amount of lines. I moved my Cisco VPN addresses to the top of the HOSTS file with all the other stuff after, and it works. You will need to use administrator writes to update the file and change it from read only to save.

Cisco Employee

Indeed the client only looks

Indeed the client only looks within a finite range. I am not sure if an enhancement request has been filed for this. Would you be willing to send me a DART file from a machine with this problem? Along with a copy of the hosts file?


I have attached my HOSTS file

I have attached my HOSTS file, I changed my companies IP address at the bottom. Not sure where the DART file is so I excluded that.

Cisco Employee

You'll have to generate the

You'll have to generate the DART bundle. For more information on using the DART tool have a look at Using DART . To install the DART tool on your machine directly(not through the ASA) do the following:

1. download the web deploy pkg file from for your OS

2. unzip or unarchive that file and look in the binaries folder

3. there will be an installer with DART in the name. install that file.


Now you should be able to run the diagnostic tool


I have had this problem today

I have had this problem today where my Cisco Anyconnect VPN stopped working. It was working all fine until my home broadband hung and rebooted itself. I restarted the PC but Cisco Anyconnect won't come up. I was having errors like "VPN Service is not available. Exiting", "Lost connection to Cisco VPN Service. Restart application". When I went into Services > Cisco AnyConnect Secure Mobility Agent> it was stopped. I sarted it but it went down again in few seconds. It came up and then went down again as if in a loop.I searched the whole internet where I can find a solution to this problem but none of the tips worked for me. I even restored my PC a week back but had no joy. Same VPN service issue and Anyconnect complaining that it has lost connection to VPN service. This is how I resolved the issue and I thought to put it here so someone else don't waste hours like I did to find a solution:

1) Un-install Cisco AnyConnect VPN

2) Unistall any registry cleaner softwares like CCleaner, Lenovo Rapid Boot etc.

3) Make sure the Cisco AnyConnect adapter has disapperared from Device Manager > Network Adapters

4) Delete the folder C:\Program Data\Cisco\Cisco Anyconnect Secure Mobility Client

5) Restart PC

6) Install Anyconnect Software

7) Restart PC

8) It should work as normal now

and after searching almost everywhere on internet this is how I resolved the issue.


The steps from asharsidd

The steps from asharsidd worked for me.  I believe that Lenovo Rapid Boot (preinstalled on a Lenovo Carbon X1 laptop) was probably the interfering with the ability of the Windows service to start, preventing the client from running.


This worked for me to stop

This worked for me to stop and then start the VPN Service on my Mac.

sudo launchctl stop

sudo launchctl start

After running these two commands i was able to start my cisco any connect without issue.



Re: VPN Agent Service not responding?

i found a quick fix  open a notepad type 

net start vpnagent

save it to your desktop and run it as admin.

voila issue fix

let me know if that work for you.


Re: VPN Agent Service not responding?



I had this happen to me today.  I fluked the fix by going to the Task Manager/Services and I found my Cisco Any Connect had stopped running.  I right clicked, selected Start and away it went.  Problem fixed.


Hope it is as easy for you.