12-08-2005 03:20 PM
I have a 2811 router that I would like to configure as a term server. There is a module installed that is labeled ASYNC 16A. I've tried this configuration, but I seem to be missing something. Does anyone have a sample config that will work? Thanks in advance for your help.
Solved! Go to Solution.
12-09-2005 12:48 PM
Hello,
I think you need to change the ports as following:
ip host test 2066 10.1.1.1
ip host test1 2067 10.1.1.1
ip host test2 2068 10.1.1.1
ip host test3 2069 10.1.1.1
ip host test4 2070 10.1.1.1
etc.
Can you try this and see if it makes a difference ?
Regards,
GP
12-09-2005 02:37 AM
Hello,
here is a sample configuration, as well as some additonal explanantions:
Take a Cisco 2811 router and run one of the async serial ports to each of the consoles on your switches, routers, firewalls, or whatever you want to connect to. Next, configure the new Cisco terminal server with the following ip host commands to make it easier for you to connect to each device.
ip host Router1 2016 10.253.100.19
ip host Router2 2015 10.253.100.19
ip host Router3 2013 10.253.100.19
The third section of each command contains the port number for the devices, and the last two digits of the number designate the port. For example, 2016 follows the first router ("Router1"), meaning this router is on port 16. The last part of the command contains the IP address of the Ethernet port on the console server.
By creating these names, you don't need to know which port the device is on. All you need to do is Telnet to the host (in this case, Router1) off of the console server.
You could also reach this device directly from a PC. For example, you could Telnet to 10.253.100.19 2016 from your PC. This tells the Telnet client to go to port 2016 instead of the default Telnet port 23.
Here is the sample config:
ciscotermserver#sh run
Building configuration...
Current configuration : 2656 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
boot-start-marker
boot-end-marker
!
enable secret 5 XXXXXXXXXXXXXXXXXXXXXXX
!
username root privilege 15 password 7 XXXXXXXXXXXXXXXXXXXXXX
no aaa new-model
ip subnet-zero
no ip domain lookup
ip host Router1 2016 10.253.100.19
ip host Router2 2015 10.253.100.19
ip host Router3 2014 10.253.100.19
ip host Router4 2013 10.253.100.19
ip host Router5 2012 10.253.100.19
ip host Router6 2011 10.253.100.19
ip host Router7 2010 10.253.100.19
ip host Router8 2009 10.253.100.19
ip host Router9 200810.253.100.19
ip host Router10 2007 10.253.100.19
ip host Router11 2006 10.253.100.19
ip host Router12 2005 10.253.100.19
!
interface Ethernet0
ip address 10.253.100.19 255.255.0.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
no ip http server
no ip classless
!
!
!
!
line con 0
line 1
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 2
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 3
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 4
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 5
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 6
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 7
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 8
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 9
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 10
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 11
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
speed 38400
line 12
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 13
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 14
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 15
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line 16
session-timeout 30
exec-timeout 0 0
no exec
transport input telnet
line aux 0
line vty 0 4
exec-timeout 60 0
login local
!
end
ciscotermserver#
HTH,
GP
12-09-2005 08:21 AM
Thank you very much for the response. I have a couple of follow up questions for you.
1. When I tried to input the line configuration, I received the error -
Router(config)#line 2
No physical hardware support for line 2
It seems that this router only has physical hardware support for line 1. Since this is a modular router, could the line configuration be something like 1/1 or 0/1? If so, do you know how this would be numbered in my situation?
2. The ASYNC 16A module has 2 interfaces. Each interface has 1 8-way cable connected to it. The interface on the right side is labeled ASYNC 0-7 and the one on the left is labeled ASYNC 8-15. Does this numbering fit into the configuration somehow?
Thank you again for your assistance.
12-09-2005 09:32 AM
Hello,
it depends on the slot in which the module is inserted, Slot 0 has line numbers 0 thru 32, Slot 1 line numbers 33 thru 65, etc...
What do you get when you type ´line ?´ ?
Regards,
GP
12-09-2005 10:32 AM
Router(config)#line ?
<0-326> First Line number
aux Auxiliary line
console Primary terminal line
tty Terminal controller
vty Virtual terminal
x/y Slot/Port for Modems
x/y/z Slot/Subslot/Port for Modems
12-09-2005 09:36 AM
Here's some more info. This is the output from the "show lines" command.
Tty Line Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
* 0 0 CTY - - - - - 0 0 0/0 -
1 1 AUX 9600/9600 - - - - - 0 0 0/0 -
1/0 66 TTY 9600/9600 - - - - - 0 0 0/0 -
1/1 67 TTY 9600/9600 - - - - - 0 0 0/0 -
1/2 68 TTY 9600/9600 - - - - - 0 0 0/0 -
1/3 69 TTY 9600/9600 - - - - - 0 0 0/0 -
1/4 70 TTY 9600/9600 - - - - - 0 0 0/0 -
1/5 71 TTY 9600/9600 - - - - - 0 0 0/0 -
1/6 72 TTY 9600/9600 - - - - - 0 0 0/0 -
1/7 73 TTY 9600/9600 - - - - - 0 0 0/0 -
1/8 74 TTY 9600/9600 - - - - - 0 0 0/0 -
1/9 75 TTY 9600/9600 - - - - - 0 0 0/0 -
1/10 76 TTY 9600/9600 - - - - - 0 0 0/0 -
1/11 77 TTY 9600/9600 - - - - - 0 0 0/0 -
1/12 78 TTY 9600/9600 - - - - - 0 0 0/0 -
1/13 79 TTY 9600/9600 - - - - - 0 0 0/0 -
1/14 80 TTY 9600/9600 - - - - - 0 0 0/0 -
1/15 81 TTY 9600/9600 - - - - - 0 0 0/0 -
12-09-2005 11:14 AM
Hello,
from your output it looks like you module is installed in slot 1, so your line numbers would be 66 thru 81. Can you try:
line 66 81
This should allow you to configure all your lines at the same time...
Regards,
GP
12-09-2005 12:12 PM
GP,
I entered the command "line 66 81" and configured the lines at the same time. I connected the first 4 ports to the console ports on various cisco equipment, but it's still not working. When I use the "connect" command to access the other device, I get this error -
TermServer#connect test
Trying test (10.1.1.1, 2000)...
% Connection refused by remote host
This happens on all hosts. There is no reason I can see in the config for the remote device to refuse the connection. Both enable secret and vty passwords are set. Here is my term server config -
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TermServer
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
!
aaa session-id common
!
resource policy
!
ip subnet-zero
--More-- !
!
ip cef
!
!
ip host test 2000 10.1.1.1
ip host test1 2001 10.1.1.1
ip host test2 2002 10.1.1.1
ip host test3 2003 10.1.1.1
ip host test4 2004 10.1.1.1
!
username cisco privilege 15 password 0 cisco
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
--More-- duplex auto
speed auto
!
ip classless
!
ip http server
!
!
control-plane
!
!
line con 0
line aux 0
line 1/0 1/15
session-timeout 30
exec-timeout 0 0
no exec
line vty 0 4
password cisco
!
scheduler allocate 20000 1000
!
end
12-09-2005 12:25 PM
Output from the "show line 1/0" command -
TermServer#show line 1/0
Tty Line Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
* 1/0 66 TTY 9600/9600 - - - - - 0 0 52/158 -
Line 1/0, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 9600/9600, no parity, 2 stopbits, 8 databits
Status: Ready, Active
Capabilities: EXEC Suppressed
Modem state: Ready
Modem hardware state: CTS* noDSR DTR RTS
Special Chars: Escape Hold Stop Start Disconnect Activation
^^x none - - none
Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch
never 00:30:00 none not set
Idle Session Disconnect Warning
never
Login-sequence User Response
00:00:30
Autoselect Initial Wait
not set
Modem type is unknown.
Session limit is not set.
Time since activation: 00:36:04
Editing is enabled.
History is enabled, history size is 20.
DNS resolution in show commands is enabled
Full user help is disabled
Allowed input transports are telnet.
Allowed output transports are telnet.
Preferred transport is telnet.
No output characters are padded
No special data dispatching characters
12-09-2005 12:48 PM
Hello,
I think you need to change the ports as following:
ip host test 2066 10.1.1.1
ip host test1 2067 10.1.1.1
ip host test2 2068 10.1.1.1
ip host test3 2069 10.1.1.1
ip host test4 2070 10.1.1.1
etc.
Can you try this and see if it makes a difference ?
Regards,
GP
12-12-2005 08:49 AM
That did it! I made this change and then cleared all the lines. After that, it worked. Thanks for your help.
12-09-2005 03:38 AM
Hi,
Pls. go thro. this link, i will detail u how to configure the term server with sample config.
http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a008014f8e7.shtml
Rds,
Balaji. V
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide