cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1114
Views
0
Helpful
2
Replies
Highlighted
Beginner

ActiveX RDP Fullscreen Resolution

This is not a question, but a very simple solution to a problem that had us scratching our heads for quite a while.  Hopefully this will save someone else some time figuring it out.

We use the Clientless SSL VPN with a terminal server for our general remote access for users, and have been using the ActiveX RDP plugin with full screen very successfully for quite a few years.  But on many new laptops (including the Surface Pros) with a high resolution we were having issues where it would no longer show full screen, it would be about 75% of the screen, which many users complained about.

We finally tracked the issue down to an IE/Javascript issue.  The ActiveX plugin uses Javascript to detect the current screen resolution to determine what is needed for the full screen option, but IE will incorrectly report back the resolution based on the level of zoom on the page.  Essentially, if you were at 200% zoom, you would get half resolution on the screen.  On these devices IE defaulted to 150% zoom.  The solution is as simple as changing the zoom to 100%.

Hope this helps someone.

-Brian

Everyone's tags (1)
2 REPLIES 2

Brian,Can you let us know

Brian,

Can you let us know what versions you use on the following:

- ASA Code

- Windows versions

- IE Versions

We're having problems getting the IE ActiveX connection to work at all with the client-less vpn. The java client works fine with all browsers that we've tested on.

Thanks.

Highlighted
Beginner

For what it is worth...  The

For what it is worth...  The resolution to enable ActiveX for the WebVPN in Internet Explorer is to enable "Compatibility Mode".  Add the domain for your VPN and then it will work!

A bit late but hopefully someone else comes across this and finds it useful.