cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
868
Views
10
Helpful
12
Replies

ADSL Performance Issue

r.hall
Level 1
Level 1

Hi,

I'm configuring an 2621XM with ADSL WIC on an 8Mb/512Kb line. With this setup, I can achieve a maximum throughput of 2.4Mbs (almost exact). If I put a cheap and cheerful ADSL router (free from the ISP) on the line, i get the full 8Mb.

The config is below. I fiddled around with MTU, but i cant see why this should be. Is there an inherent limit on the ADSL WIC? It reports the correct line speed (auto 8Mb/512Kb) with no errors on the line (sh dsl / sh atm).

Any thoughts or help appreciated.

Regards

Richard

Config

using 1921 out of 29688 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CCME1

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxxx

enable password xxxxx

!

memory-size iomem 20

no network-clock-participate slot 1

no network-clock-participate wic 0

ip subnet-zero

!

!

!

!

ip cef

ip name-server 212.x.x.36

ip name-server 195.x.x.36

ip ips po max-events 100

no aaa new-model

no ftp-server write-enable

!

!

interface ATM0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet0/0

ip address 10.0.0.254 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

h323-gateway voip bind srcaddr 10.0.0.254

!

interface FastEthernet0/1

no ip address

ip virtual-reassembly

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp chap hostname xxxxxx

ppp chap password 0 xxxxxxx

ppp pap sent-username xxxxxxx

ppp ipcp dns request

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

!

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 10.0.0.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

!

control-plane

!

!

!

voice-port 1/0/0

connection plar opx 1001

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

!

!

!

dial-peer voice 10 voip

destination-pattern 1001

session target ipv4:10.0.0.102

!

dial-peer voice 1 pots

destination-pattern 9T

port 1/0/0

12 Replies 12

Hello,

try and set the dsl operating-mode to ansi-dmt:

interface ATM0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

--> dsl operating-mode ansi-dmt

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

And see if that makes a difference...

Regards,

GP

Nope. No difference at all.

The fact that it's 300KB/s (2.4Mb) and exactly this figure makes me think it's something like a performance issue with ppp or perhaps buffer configuration.

Thanks for the suggestion though.

Regards

Richard

Hello Richard,

you could try and set the MTU size to something different from what you have now (1452), try e.g. 1474, or 1500.

Who is your provider in the UK ?

Regards,

GP

Hi,

I've changed the MTU on both the dialer and ATM interfaces to various settings, but nothing seems to make any difference.

I also noticed that the CPU utilisation is around 20% but cant see which process is using it.

Thanks for the suggestions.

Regards

Richard

The ISP in question is UKOnline, the retail arm of Easynet.

I know it it stating the obvious but your FastEthernet interface is set to Full-Duplex, is it hard-coded on the other end of this link? i.e. your switch or direct to a PC via a cross-over cable.

Andy

Hi Andy,

Nope. Not that. Thanks for the repsonse.

Richard

miqbal
Cisco Employee
Cisco Employee

Hi Richard,

did you find the problem with the adsl speeds?

Regards,

I had the same issue. The ATM interface clock rate defaults to 2.6Mbps. You have to set this higher as appropriate. The max clockrate is 7Mbps.

clagos
Level 1
Level 1

I have encountered the same exact problem. This is the command I used under the ATM interface. The default limits throughput to around 2.5mb.

clock rate aal5 8000000

dmanigo
Level 1
Level 1

I was searching for my own answer and read your post.

interface ATM0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

I see the Point to Point Protocol configured but wanted to know if the line-code is ethernet or ATM. I'm not sure if your ISP requires a different pvc but the pvc for ethernet is 8/35 and ATM is 0/35 for ADSL.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: