cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
323
Views
0
Helpful
5
Replies
Highlighted

AnyConnect 4.7 Embedded Browser for SAML Uses IE

When using AnyCOnnect 4.7 the embedded browser use IE when authenticating with SAML. This causes issues in that we get 500 errors with first login. In addition, when connected to DUO/MFA , IE won't render all of the HRML correctly and we can't enter the code when users select token as an option. Any ideas on how to use a different embedded browser? 

5 REPLIES 5
Highlighted
Collaborator

Hi,

 

    Have you tried changing the "default browser" of the operating system?

 

Regards,

Cristian Matei.

Highlighted

The default browser is set to Chrome.
Highlighted

Hi,

 

   Are you using Windows 7 an IE 11 minimum? It seems it has to be IE on Windows devices.

 

Regards,

Cristian Matei.

Highlighted

It is a Windows 10 machine.
Highlighted
Beginner

Same issues here. I haven't found a way to change the embedded browser of the AnyConnect client to something other than IE. You can lean on your account rep or Duo Success Team since Duo has been acquired by Cisco and can internally escalate a feature request.

 

The embedded IE browser is a poor choice to use by a company that specializes in security in my opinion. At least let us use a browser that supports FIDO2/webauthn for modern security and cert-based security keys.

 

-Buster