Showing results for 
Search instead for 
Did you mean: 

AnyConnect Client (3.1.02040) - Windows 8 won't shut down


I've noticed and issue with Windows 8 and AnyConnect Client version 3.1.02040.  I've tried various things to try to resolve this issue but have hit a brick wall.  Whenever, I run AnyConnect on my Windows 8 PC and then shut it down for the day, the PC won't turn off.  I've ensured my AnyConnect client is disconnected and then quit the application and even killed the VPN service.

Has anyone else seen this issue???   Any resolution???

72 Replies 72

I'm making some progress directly with Cisco on this.  (We are making progress!)

Dan Coats

Anyone else made any progress with this? I personally cannot duplicate it with any of my devices using intel, or broadcom drivers but have had a report of the same when using 3.1.03103 and a Realtek NIC.


The Cisco devs have identified the exact issue and I have confirmed the fix on the machines that I was personally having the problem on.  I suspect that a fixed version of the software will be made publically available within the next few weeks or so.

Hang tight!  As soon as I know that it's posted, I'll reply back again here.



Do you know the bug id?


Unfortunately, I don't.  I've been having direct e-mail conversations with the engineers working on the problem and not through direct support means.

I'll check back with them today and see if there is any new guidance on release dates.

Any word on when this fix will be included in a release? I just installed 3.1.03103 (which was released April 1st) on a clean Windows 8 install (no AV or 3rd party firewall) and it still has this same issue.

I just checked the site and no new version or information on any pending update.

I can't go into additional details on this, however based on what I was told, it should be available before the end of the month.  (I have personally confirmed the fix for Cisco, so I know that the next version _should_ fix the issues that we have all been having.)

I'll check and see if there is any additional information that I can share.



That's great news. Thanks for your persaverance.

Sent from Cisco Technical Support iPhone App


I too have a simiar problem.  I've tried using different versions of Cisco
AnyConnect Secure Mobility Client and it still doesn't work right.

If I'm using my wireless connection, everything seems to be fine.  I'm able to connect via AnyConnect, disconnect, reconnect and shutdown Windows 8 x64 machine just fine without any issues.

Problem- If i connect via my wired network (ethernet port) on my Windows 8 x64 machine, the intial vpn connection is fine and it stays connected until it times out (hours) or i manually disconnect.  When i try to reconnect, it appears to connect, but then disconnects and pops up a message:  "The VPN client driver encountered an error.  Please restart your computer or device, then try again."  I can't reconnect and when i try to shutdown/reboot my computer, it will take like 10 or so minutes and then restarts.  -Windows crashes and generates a minidump.

to sum it up, wireless network connectivity and then launching anyconnect works fine without any issues, whereas wired network connectivity and launching anyconnect works fine the first time but when you try to reconnect it doesnt and the system crashes when you reboot or shutdown....very strange

system info:  lenovo t430 laptop running windows 8 x64 with/Cisco AnyConnect 3.1.03103

Yep- Sounds like the same problem all of us have been having.

Unfortunately, there isn't a workaround.  However from what I was told, the software is fixed and it's going through Windows certifications.  It should be available within a few weeks.  (Perhaps closer to the end of the month.)

In the interim, I went back to using IPSEC w/ Shrewsoft and a .pcf.

The problem exists in 3.1.02026, 3.1.02040 also. You can back down to 3.1.01065 and it will work. I have the same problem as you and 3.1.01065 does not cause me any issues. It was also the recommendation from Cisco when I opened a TAC case.


I case anyone is having trouble keeping your client from updating to the newer version and breaking again i found these lines added to the

C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\AnyConnectLocalPolicy.xml

file will keep your client from updating when you login if they have provisioned a newer one on the vpn site.





Make sure these are placed before the end () or they won't be seen.

I've been in contact with Cisco and from what I have been told, there is a good chance the updated client will be released this week.  I was part of the final testing group and can confirm that it fixes this issue.


any news?

I can't work productively anymore with this bug...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers