Showing results for 
Search instead for 
Did you mean: 

Anyconnect Secure Mobility Client 3.0.0629 constantly Acquiring IP Address with WPA-2 Personal

Level 1
Level 1


I'm trying to convert my home network over to WPA2-Personal and the Anyconnect SMC 3.0.0629 is drivng me crazy.  My desktop works fine.  My iPhone 4 works fine.

The SMC actually works, but it's constantly "Acquiring IP Address."  However, the host actually HAS an IP Address.  An IPCONFIG /ALL confirms that the host has an address.  In fact, Internet access is fine.  I'm using it now to compose this post.  The problem is the constant "Acquiring IP Address" because every few minutes the SMC pops up "Connected to.." followed by my SSID.  Pretty distracting.

If I change nothing else and just connect to my neighbors access point that uses WEP, it works fine.  If I connect to some random open access point in my neighborhood that's wide open, again it works fine.  The problem seems to be limited to WPA-2.  I even set a static IP Address, Subnet Mask and Default Gateways and when using WPA-2 the SMC will still constantly display "Acquiring IP Address" when clearly it doesn't need to.

If you have any ideas, it would greatly appreciate some feedback.



4 Replies 4

Level 1
Level 1

Messages Log:

[Fri Dec 23 16:44:58 2011] Connected (

[Fri Dec 23 16:44:58 2011] Acquiring IP Address

[Fri Dec 23 16:45:38 2011] Searching for a Network

[Fri Dec 23 16:45:38 2011] Searching for a Network

[Fri Dec 23 16:45:38 2011] Acquiring IP Address

[Fri Dec 23 16:45:38 2011] Authenticating

[Fri Dec 23 16:45:38 2011] Acquiring IP Address

[Fri Dec 23 16:45:38 2011] Connected (

[Fri Dec 23 16:45:40 2011] Acquiring IP Address

This just repeats over and over. is exactly the address it should be using and IPCONFIG /ALL confirms it.  It just keeps repeating this loop over and over....

Further diagnosis:

I went into the Wireless Network Connection properties  and unbound the "Cisco AnyConnect Network Access Manager Filter Driver" from the stack.  I then went over and selected my SSID and entered the WPA-2 Personal key from the native Windows applet and everything started working just fine.  I can even VPN into work using the Cisco ASM Client utility, it just doesn't show the available wirless networks anymore.  I have to use the native Windows applet for that now.

So I guess this is a workaround but it sure looks to me like the Cisco client has a problem knowing it has a valid IP Address when using a WPA encryption protocol.

I ran into this issue today and noticed the post from 2011 and I was very suprised there has not been an answer or a fix to the problem.  I started trying different things and attempted to figure out why some laptops had this issue and others didn't.  I also noticed that it didn't matter what type of network I joined (open, secured) the laptops in question would jump between authenticating and obtaining an IP address and would never succeed.  I figured I should try to update the driver on the wireless network card just to see if that could possibly be the issue, and to my suprise upgrading the driver to the latest firmware fixed the issue on every single laptop having the problem.  Non of the laptops required a reboot and started working as soon as the driver update was complete.  So if anyone else out there is having issues between wireless and NAM, try to upgrade your wireless drivers and see if that doesn't fix it up for you.

I'll also add that eap-chaining works really well, even using different EAP-FAST methods between the machine auth and the user auth works nicely.

Level 1
Level 1

I was able to solve this problem using the solution mentioned here..

In brief it suggests to disable NAM..worked for me.

Fantastic job!! Thanks for sharing!! :)

Sent from Cisco Technical Support Android App