Showing results for 
Search instead for 
Did you mean: 

AnyConnect + Windows 8 ?

Patrick Tran


I wanted to test AnyConnect on Windows 8

I got an error when "checking profiles updates".

When I put a xml profile file on C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\Profile , I got an error "Failed to load preferences"

Has someone succeeded in connecting AnyConnect on Windows 8?

Is there an incompatibility? (and no workaround?)



39 Replies 39


Since this is the f o o t b a l l season, I call Illegal motion by the Help Desk.  There is no problem and 3.1 apparently does work with Win 8.  The error I received this morning was that the VPN client wont start from a remote desktop session.  When I got that, I responded  "Yea, that's right."   I apologize for putting the keyboard in gear before all the details had been loaded up.  So I'm back to the one user out of many that can't get AnyConnect to work on his Win 7 laptop but won't bring the machine in to have it re-imaged or leave it with me to do detailed debugging.    Ya'll have a great day and thanks.

Charles Morris

Patrick Sheehan post helped me restore operability. Thanks Patrick.

Charles Morris


What version of AnyConnect are you using?  I have 3.1.00495 and still cannot get it to work.


We recommend 3.1MR1 or 3.0MR10. If it is failing with a Host Scan error, this is because your head-end Host Scan is out of date. If it's failing with a different error, please email us a DART (Diagnostics bundle) at and we will be glad to investigate for you.

3.0MR10 and 3.1MR1 are both available for download from by clicking Software Download. To access the SW, you must have Cisco support (SMARTnet). Your IT department should have access to the software for you.

Hi Peter

Could you please use the 3.0.xxxxx and 3.1.xxxxx numbering system instead of MRxx? At least I as a customer only see the long version numbering on the download portal and have nowhere a reference to which version you are actually referencing.



Can I get a link to download  3.0MR8 or 3.1????

I am using 2.5 with Windows 8 64 and it works fine after the registry editing that I posted above.

I got the link, what is the file name?

For pre-install:

3.1MR1 is: anyconnect-win-3.1.01065-pre-deploy-k9.iso

3.0MR10 is: anyconnect-win-3.0.10057-pre-deploy-k9.iso

Can you please send me the link aswell.

Can you please send me the link too? I use Cisco AnyConnect Secure Mobility Client version 3.0.2052 and it worked fine on Windows 7 32 bit. I just updated to Windows 8 ENT 32 bit. Now it does not work. Hostscan error occurs always when to connect.

Thank you.

Your admin will need to correct this by updating the Host Scan version on the head-end.  At the same time, they should update the head-end version 3.1MR1 (3.1MR2 should be out soon too, as well as an updated 3.0MR).

Had the same issue with version 3.0.08057 and resolved it by adding the following lines to the file

C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\

AnyConnectLocalPolicy.XML - add it at the bottom, right above the last line "






Still checking why that solved it, but thought it is worth the share...

Not applicable

Try version 3.1.02026

For me it worked.

I was using old client. Then tried this solution proposed earlier.

1) Browse to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnva]

2) Modify the value of the field "DisplayName" to "Cisco AnyConnect VPN Virtual Miniport Adapter for Windows x64"

That didn't help, so I downloaded latest build and it worked. Mind you that I didn't unistall old client and didn't check if the registry key has been modified by new client.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers