cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
230117
Views
0
Helpful
28
Replies

Cisco AnyConnect 3.0.2 and Mac OS X 10.7

pointless_l
Level 1
Level 1

I'm having trouble getting this to work, after my upgrade to Mac OS X Lion the Anyconnect client can no longer login. Reinstalling didn't work for me. What are other experiencing?

28 Replies 28

slawford
Cisco Employee
Cisco Employee

Hi All,

I am from the TAC and have been looking into a few of these issues.

For those of you that are seeing certificate related errors in /var/log/system.log, could you please send me a private message with the address of your headend, or let me know if you have one or multiple values set under the "Subject Alternate Name" field on your certificate.

I am trying to rule out a pattern I have noticed in a number of cases that I am raising with our development team, and want to make sure that these issues are addressed under

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtr64798

Thanks,

Steve.

CHARLES FRANCIS
Level 1
Level 1

Has anyone had any further luck with this? 

We are using a Verisign signed cert and this issue is only with our Lion clients.  We haven't been able to get the prompt to install the client from the webpage using Safari, Firefox or Chrome even though Java was installed/

If you email your headend address to Steve (see the post above yours in this thread) he will confirm to you if your certificate is affected and if 3.0.3 will work for you. They are aware of an issue with some certificates and are working on it.

Hi All,

Thanks for your private messages. I had noticed the Subject Alternate name pattern in the vast majority of problem cases, which I forwarded to the developers.

Please note that version 3.0.3054 has just been posted to Cisco.com which contains the fix for CSCtr64798.

The updated client can be found here:

http://www.cisco.com/cisco/software/release.html?mdfid=283000185&softwareid=282364313&release=3.0.3054&relind=AVAILABLE&rellifecycle=&reltype=latest&i=rm

Regards,

Steve.

3054 fixed my issues.

me too

3054 fixed my issues connecting as well. But unfortunately once connected my Macbook Air (2011) now crashes sporadically. Anyone else?

Yes, we are having crashes after installing the 3054 fix.... Any help would be nice.

There have been several Anyconnect releases with bug fixes since 3.0.3054 and the current version is 3.0.5080. Have you tried any of these?

ronbuchalski
Level 1
Level 1

We discovered that our issue was not with the AnyConnect client, but in fact was with ASA software 8.4.(2), which contained a bug which broke AnyConnect connectivity from Mac.  Not sure if it was isolated to 10.7 or not.

The ddts for the ASA bug is CSCts80367.  It was resolved in ASA software interim build 8.4.(2.18), and is now available in release 8.4.(3).

We loaded 8.4.(3) onto the ASA, tried to VPN from a Mac using AnyConnect, and it worked!

-rb

So was the fix applied only to 8.4 code? 

We're running 8.2(5)44 on a ASA 5520 and are having no luck with loading the AnyConnect client (anyconnect-macosx-i386-3.1.00495-k9.pkg) on a MAC os X 10.8.  We tried saving the file and loading it manually and then tried the auto config when JAVA was loaded.  Neither approach worked.  We still get the same 'file damaged error' message.  ??

dan

You have to *disable* Gatekeeper on your Mac. Then you can install AnyConnect (I had the same Problem with ASDM) and enable Gatekeeper again. Now it will work as usual.


Sent from Cisco Technical Support iPad App

Hope this helps steps to install the VPN client.

  1. Open up your System Preferences (hit Command+Space, type ‘System Preferences’ and then Enter)


  2. Click ‘Security & Privacy’


  3. Click the lock icon in the lower left, and enter your password


  4. Under ‘Allow applications downloaded from:’, select ‘Anywhere’, and from the popup, click ‘Allow From Anywhere’.


  5. Now install the VPN client.


  6. After you are done, under ‘Allow applications downloaded from:’ select ‘Mac App Store and identified developers’


  7. Close your ‘Security & Privacy’ settings window.


Dan Schauss
Level 1
Level 1

Changing the Gatekeeper settings worked. 

Here are two informative links.

  http://answers.uchicago.edu/page.php?id=24322

Disable Gatekeeper.    https://answers.uchicago.edu/page.php?id=25481

dan