Showing results for 
Search instead for 
Did you mean: 

Cisco ASA 5505 and DHCP Client Problems


Hi, i have a problem. I've connected my ASA appliance to an ADSL modem, and i dont get an DHCP address on the outside interface (e0/0). I use the asa-722-19.bin firmware.

I turned on the debugging for the DHCP client and could see that the ASA device was sending out broadcasts but a reply never came. Instead I connected the device to my internal network where the ASA got an address instantly.

I read somewhere that if I was to use ?ip address dhcp client-id fastethernet 0″, then I got an address from the ISP.

I tried looking for a similar command on the ASA5505 but I couldn?t find anything. I did however find a page on the Cisco site confirming my suspicions. It said some ISP?s require the client-id field of the DHCPDISCOVER request to be filled.

I've also read that this issue has beed fixed since a few weeks, now they have released version 7.2(2).22 where you can define ?dhcp-client client-id interface outside? in global configuration mode. Im running 7.2(2).19 and i cannot find any command like that in my appaiance. How do i fix my problem ? Or how do i get about recieving the 7.2(2).22 firmware update.

Regards !


6 Replies 6

Frequent Contributor
Frequent Contributor

On the ASA 5500 series adaptive security appliance, the interface to which you connect with ASDM is Management 0/0. For the PIX 500 series security appliance, the interface to which you connect with ASDM is Ethernet 1. To restore the default configuration, enter the configure factory-default command at the security appliance CLI.

Make sure the PC is on the same network as the security appliance.

If your platform does not support the factory default configuration, or you want to add to an existing configuration to make it accessible for ASDM, access the security appliance CLI according to the Cisco Security Appliance Command Line Configuration Guide, and enter the setup command. The setup command prompts you for a minimal configuration to connect to the security appliance using ASDM


Hi! Did you ever get this solved. Im sitting on three brand new ASA 5505 with this problem (among other issues). They all works with my absolete old Alcatel modem that was the first one I ever used at my home. Any other new modem (tried D-link, Linksys, Zyxel) off the standard shelf will not work. Im beginning to have serious thoughts about chaning brand of all our networking gear after playing with ASA 5505 for a couple of weeks. Thanks, Bjorn


Hi again! I thought I should share the solution that worked for me. I use software version 7.2(2) on this device. ASDM 5.2(2). In ASDM open configuration / Interfaces. Click in outside (my case 0/0) and press Edit. Then open the tab Advanced and set the correct Active Mac address. Fore some reason its empty by default and the ISP/modem don't like that. You will find the correct MAC address under the help menu / "About ASA". Im sure there is some another way to do this but this is a simple "how-to" that works with Swedens biggest ISP and their standard DSL modem.

When I used a Linksys DSL modem in bridge mode without the MAC address set I got an inside IP adress (192.168.x.x) from the modem to the ASA. After setting the MAC address I just had to do a renew and got the outside address right away. /Bjorn

(future users searchwords: no ip from isp, ASA 5505 and cable modem).

Perhaps i have a newer verison then you? i have two Asa5505. i'm running both on statics, but i tested on dsl and cable (one on each end) with dhcp first. i did not find the same reported issue. maybe its the firmware limitation?

I am suddenly, after over a year with no problems, having this same issue.  I have managed to at least figure out some of the puzzle.  I have a cable modem connected to an ASA5505 connected to a Linksys WRT610N.  I have the linksys in place for wireless capability.  It seems that with everything in place, my ASA dhcp client will never get IP settings from the ISP.

I have recently found that disconnecting the Linksys wirleless router and resetting my cable modem is the only way my ASA will get the IP information and work correctly.  I am trying very hard, but obviously missing something.  How can I have the Linksys wireless router in place without the ASA malfunctioning?  ... and why has this suddenly started??  Any help is greatly accepted.

There is definitly a problem, but I am not sure it is solely on the end of the 5505 side.

I resolved my problem, a year or 2 ago, by placing a netgear router as my border device.  The netgear gets the public address and then the 5505 gets a private address from the netgear DHCP service.  So that tells me that in some way the 5505 can get a DHCP license, but has problems when obtaining that license from some ISP's.

Those replying may want to list their ISP so we can identify possible sources of the issue.  I plan on trying to do some packet sniffing and I am anticipating that the DHCP packets from the ISP will not be formated properly.  Maybe as a result of ipv6 rollouts.

ISP: comcast

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers