cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4415
Views
0
Helpful
0
Replies

Cisco L2TP & PPTP configuration Template

! (1)virtual private dial-up network (VPDN) configuration::

vpdn enable

!

vpdn-group L2TP

! Default L2TP VPDN group

accept-dialin

protocol l2tp

virtual-template 10

lcp renegotiation always

no l2tp tunnel authentication

!

vpdn-group SW-VPN

! Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

l2tp tunnel timeout no-session 15

! (2)username/password for Authentication

username <myusername> password 0 <mypassword>

! (3)IPSEC phase 1

crypto isakmp policy 20

encr 3des

authentication pre-share

group 2

!

! (4)IPSec Phase 1 key for all hosts (0.0.0.0), used in Window 7 IPSec configuration prompt

crypto isakmp key <mykey> address 0.0.0.0 0.0.0.0 no-xauth

!

!

! (5)IPSec Phase 2 configuration

crypto ipsec transform-set L2TP_SET esp-3des esp-sha-hmac

mode transport

!

!

crypto dynamic-map L2TP_SET_MAP 20

set transform-set L2TP_SET

!

crypto dynamic-map SW-Map 10

set transform-set SW-Set

!

!

crypto map L2TP-MAP 20 ipsec-isakmp dynamic L2TP_SET_MAP

!

!

!

! (6) Virtual -Template for PPTP

interface Virtual-Template1

ip unnumbered Dialer1

peer default ip address pool PPTP_POOL

no keepalive

ppp mtu adaptive

ppp encrypt mppe auto required

ppp authentication ms-chap ms-chap-v2

!

! (7) Virtual -Template for L2TP

interface Virtual-Template10

ip unnumbered Dialer1

peer default ip address pool L2TP_POOL

no keepalive

ppp mtu adaptive

ppp authentication ms-chap ms-chap-v2

!

!(8) Crypto Map aplied into Dialer 1

interface Dialer1

mtu 1492

ip address negotiated

ip access-group INBOUND in

ip nat outside

ip inspect myfw out

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp authentication pap callin

ppp chap hostname <hostmane>

ppp chap password 0 <provider pass>

ppp pap sent-username <hostmane> password 0 <provider pass>

no cdp enable

crypto map L2TP-MAP

!

! (9)IP pool for PPTP & L2TP devices

ip local pool L2TP_POOL 10.255.255.1 10.255.255.254

ip local pool PPTP_POOL 10.255.254.1 10.255.254.254

IOS:: flash:c880data-universalk9-mz.150-1.M6.bin

Cheers,

0 Replies 0