cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
237
Views
0
Helpful
0
Replies
Highlighted
Beginner

Cisco site to site vpn b/n ASA and Router with internet access

I have configured IPSEC VPN between my branch office and HQ and able to reach the branch through HQ LAN and vice versa. Now I have to transport the internet from HQ for users at the Branch office using this IPSEC VPN tunnel but I am not sure how to do this. I use ASA at HQ and router at remote Branches.

ASA configuration 

: Saved

:
: Serial Number: 9AR334W85CE
: Hardware: ASAv, 2048 MB RAM, CPU Pentium II 3192 MHz
:
ASA Version 9.8(1)
!
hostname CISCOASA
enable password $sha512$5000$HJbpecuRQIn8Z2Cyp/gzKA==$/gi7M62brZsrEalqPkLFzw== pbkdf2
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names

!
interface GigabitEthernet0/0
nameif INSIDE
security-level 100
ip address 2.2.2.2 255.255.255.0
!
interface GigabitEthernet0/1
nameif OUTSIDE
security-level 0
ip address 4.4.4.2 255.255.255.0
!
interface GigabitEthernet0/2
nameif OUTSIDE-INTERNET
security-level 40
ip address 192.168.30.4 255.255.255.0
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/6
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif Management
security-level 95
ip address 100.100.100.1 255.255.255.0
!
ftp mode passive
object-group network HQLAN
network-object 1.0.0.0 255.0.0.0
network-object 15.15.15.0 255.255.255.0
object-group network AKLAN
network-object 8.8.8.0 255.255.255.0
object-group network DBLAN
network-object 10.10.10.0 255.255.255.0
access-list ICMPACL extended permit icmp any any
access-list HQAK extended permit ip object-group HQLAN object-group AKLAN
access-list HQDB extended permit ip object-group HQLAN object-group DBLAN
access-list ICMPACLINT extended permit icmp any any
access-list INTERNETACL extended permit ip 192.168.1.0 255.255.255.0 any
access-list INTERNETACL extended permit ip host 10.10.10.25 any
access-list INTERNETACL extended permit ip host 8.8.8.25 any
access-list INTACL extended permit ip any any
pager lines 23
mtu INSIDE 1500
mtu OUTSIDE 1500
mtu OUTSIDE-INTERNET 1500
mtu Management 1500
no failover
no monitor-interface service-module
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 8192
nat (INSIDE,OUTSIDE) source static HQLAN HQLAN destination static AKLAN AKLAN
access-group INTACL in interface OUTSIDE
access-group INTERNETACL in interface OUTSIDE-INTERNET
route OUTSIDE-INTERNET 0.0.0.0 0.0.0.0 192.168.30.2 1
route INSIDE 1.1.1.0 255.255.255.0 2.2.2.1 1
route INSIDE 3.3.3.0 255.255.255.0 4.4.4.1 1
route OUTSIDE 5.5.5.0 255.255.255.0 4.4.4.3 1
route OUTSIDE 7.7.7.0 255.255.255.0 4.4.4.3 1
route OUTSIDE 8.8.8.0 255.255.255.0 4.4.4.3 1
route OUTSIDE 9.9.9.0 255.255.255.0 4.4.4.3 1
route OUTSIDE 10.10.10.0 255.255.255.0 4.4.4.3 1
route INSIDE 11.11.11.0 255.255.255.0 2.2.2.1 1
route INSIDE 12.12.12.0 255.255.255.0 2.2.2.1 1
route INSIDE 13.13.13.0 255.255.255.0 2.2.2.1 1
route INSIDE 14.14.14.0 255.255.255.0 2.2.2.1 1
route INSIDE 15.15.15.0 255.255.255.0 2.2.2.1 1
route INSIDE 192.168.1.0 255.255.255.0 2.2.2.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication login-history
http server enable
http 0.0.0.0 0.0.0.0 INSIDE
http 0.0.0.0 0.0.0.0 Management
no snmp-server location
no snmp-server contact
crypto ipsec ikev2 ipsec-proposal HQAK
protocol esp encryption 3des
protocol esp integrity sha-1
crypto ipsec security-association lifetime seconds 86400
crypto ipsec security-association pmtu-aging infinite
crypto map HQDB 1 match address HQDB
crypto map HQDB 1 set peer 9.9.9.2
crypto map HQDB 1 set ikev2 ipsec-proposal HQAK
crypto map HQDB 10 match address HQAK
crypto map HQDB 10 set peer 7.7.7.2
crypto map HQDB 10 set ikev2 ipsec-proposal HQAK
crypto map HQDB interface OUTSIDE
crypto ca trustpoint _SmartCallHome_ServerCA
no validation-usage
crl configure
crypto ca trustpool policy
auto-import
crypto ca certificate chain _SmartCallHome_ServerCA
certificate ca 18dad19e267de8bb4a2158cdcc6b3b4a
308204d3 308203bb a0030201 02021018 dad19e26 7de8bb4a 2158cdcc 6b3b4a30
0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d30
36313130 38303030 3030305a 170d3336 30373136 32333539 35395a30 81ca310b
30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
74776f72 6b313a30 38060355 040b1331 28632920 32303036 20566572 69536967
6e2c2049 6e632e20 2d20466f 72206175 74686f72 697a6564 20757365 206f6e6c
79314530 43060355 0403133c 56657269 5369676e 20436c61 73732033 20507562
6c696320 5072696d 61727920 43657274 69666963 6174696f 6e204175 74686f72
69747920 2d204735 30820122 300d0609 2a864886 f70d0101 01050003 82010f00
3082010a 02820101 00af2408 08297a35 9e600caa e74b3b4e dc7cbc3c 451cbb2b
e0fe2902 f95708a3 64851527 f5f1adc8 31895d22 e82aaaa6 42b38ff8 b955b7b1
b74bb3fe 8f7e0757 ecef43db 66621561 cf600da4 d8def8e0 c362083d 5413eb49
ca595485 26e52b8f 1b9febf5 a191c233 49d84363 6a524bd2 8fe87051 4dd18969
7bc770f6 b3dc1274 db7b5d4b 56d396bf 1577a1b0 f4a225f2 af1c9267 18e5f406
04ef90b9 e400e4dd 3ab519ff 02baf43c eee08beb 378becf4 d7acf2f6 f03dafdd
75913319 1d1c40cb 74241921 93d914fe ac2a52c7 8fd50449 e48d6347 883c6983
cbfe47bd 2b7e4fc5 95ae0e9d d4d143c0 6773e314 087ee53f 9f73b833 0acf5d3f
3487968a ee53e825 15020301 0001a381 b23081af 300f0603 551d1301 01ff0405
30030101 ff300e06 03551d0f 0101ff04 04030201 06306d06 082b0601 05050701
0c046130 5fa15da0 5b305930 57305516 09696d61 67652f67 69663021 301f3007
06052b0e 03021a04 148fe5d3 1a86ac8d 8e6bc3cf 806ad448 182c7b19 2e302516
23687474 703a2f2f 6c6f676f 2e766572 69736967 6e2e636f 6d2f7673 6c6f676f
2e676966 301d0603 551d0e04 1604147f d365a7c2 ddecbbf0 3009f343 39fa02af
33313330 0d06092a 864886f7 0d010105 05000382 01010093 244a305f 62cfd81a
982f3dea dc992dbd 77f6a579 2238ecc4 a7a07812 ad620e45 7064c5e7 97662d98
097e5faf d6cc2865 f201aa08 1a47def9 f97c925a 0869200d d93e6d6e 3c0d6ed8
e6069140 18b9f8c1 eddfdb41 aae09620 c9cd6415 3881c994 eea28429 0b136f8e
db0cdd25 02dba48b 1944d241 7a05694a 584f60ca 7e826a0b 02aa2517 39b5db7f
e784652a 958abd86 de5e8116 832d10cc defda882 2a6d281f 0d0bc4e5 e71a2619
e1f4116f 10b595fc e7420532 dbce9d51 5e28b69e 85d35bef a57d4540 728eb70e
6b0e06fb 33354871 b89d278b c4655f0d 86769c44 7af6955c f65d3208 33a454b6
183f685c f2424a85 3854835f d1e82cf2 ac11d6a8 ed636a
quit
crypto ikev2 policy 1
encryption 3des
integrity sha
group 2
prf sha
lifetime seconds 86400
crypto ikev2 enable OUTSIDE
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
username cisco password $sha512$5000$BAd0r202wSx/2OrDubfgow==$vkBAyHRZoMiwsaMYYHS7jw== pbkdf2
tunnel-group 7.7.7.2 type ipsec-l2l
tunnel-group 7.7.7.2 ipsec-attributes
ikev2 remote-authentication pre-shared-key *****
ikev2 local-authentication pre-shared-key *****
tunnel-group 9.9.9.2 type ipsec-l2l
tunnel-group 9.9.9.2 ipsec-attributes
ikev2 remote-authentication pre-shared-key *****
ikev2 local-authentication pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map global_policy
class inspection_default
inspect ip-options
inspect netbios
inspect rtsp
inspect sunrpc
inspect tftp
inspect xdmcp
inspect icmp
inspect icmp error
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect esmtp
inspect sqlnet
inspect sip
inspect skinny
policy-map type inspect dns migrated_dns_map_2
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
profile License
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination transport-method http
Cryptochecksum:3b7ba92a7572f790459fc4d2dc1ab199
: end

 

router configuration

 

 Current configuration : 3835 bytes
!
! Last configuration change at 13:38:30 UTC Thu Nov 12 2020
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ALEM_KETMA_BR
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
redundancy
!
!
!
!
crypto ikev2 proposal AKHQ
encryption 3des
integrity sha1
group 2
!
crypto ikev2 policy AKHQ
proposal AKHQ
!
crypto ikev2 keyring AKHQ
peer 4.4.4.2
address 4.4.4.2
pre-shared-key local ************
pre-shared-key remote ************
!
!
!
crypto ikev2 profile AKHQ
match identity remote address 4.4.4.2 255.255.255.255
authentication remote pre-share
authentication local pre-share
keyring local AKHQ
!
!
!
crypto ipsec transform-set AKHQ esp-3des esp-sha-hmac
mode tunnel
!
!
!
crypto map AKHQ 1 ipsec-isakmp
set peer 4.4.4.2
set security-association lifetime seconds 86400
set transform-set AKHQ
set ikev2-profile AKHQ
match address AKHQ
!
!
!
!
!
interface GigabitEthernet0/0
ip address 7.7.7.2 255.255.255.0
duplex auto
speed auto
media-type rj45
crypto map AKHQ
!
interface GigabitEthernet0/1
ip address 8.8.8.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 7.7.7.1
!
ip access-list extended AKHQ
permit ip 8.8.8.0 0.0.0.255 1.0.0.0 0.255.255.255
permit ip 8.8.8.0 0.0.0.255 15.15.15.0 0.0.0.255
permit ip host 8.8.8.25 any
!
ipv6 ioam timestamp
!
!
!
control-plane
!
banner exec ^CCCCC
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner incoming ^CCCCC
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
banner login ^CCCCC
**************************************************************************
* IOSv is strictly limited to use for evaluation, demonstration and IOS *
* education. IOSv is provided as-is and is not supported by Cisco's *
* Technical Advisory Center. Any use or disclosure, in whole or in part, *
* of the IOSv Software or Documentation to any third party for any *
* purposes is expressly prohibited except as otherwise authorized by *
* Cisco in writing. *
**************************************************************************^C
!
line con 0
line aux 0
line vty 0 4
login
transport input none
!
no scheduler allocate
!
end 

help.jpg

But I can reach the internet from the HQ LAN

ic.PNG

0 REPLIES 0
Content for Community-Ad