cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
686
Views
0
Helpful
3
Replies
Fetakungen
Beginner

Connect to Access VPN accross site to site ASAv - IOS Router

Hi, I'm currently setting up a network with a ASAv and an old cisco 2811. Anyway i have setup a site to site vpn between them that is working fine but...
I have also setup a Access vpn on the asa that's not working as intended.
What i want is this:
Client with Access Vpn connect to ASA inside interface accordingly -> 2811 "Inside" <SITE-SITE> ASA "Inside" -> DMZ

In words i want client on 2811 side to connect to a VPN on the inside interface on the asa giving access to DMZ net when connected. The thing is it works flawlessly if i connect directly at asa side to inside or to outside interface on asa but not accross the vpn..

I can connect but no traffic to is returned from the DMZ. It would seem it tries to route the vpn to the outside gateway when i check the route table it says access "vpn client ip" "mask" "outside gateway" "INSIDE"

I have a Nat statement static nat 10.0.0.0/8 -> 10.0.0.0/8 so nat aint the issude

I have tried all i can think of regarding traffic over the tunnel but i dont under stand why it wont work.

Inside ASA 10.100.20.0/24
DMZ ASA 10.100.21.0/24

Acess VPN ASA 10.100.22.0/24

Crytpomap 10.100.20.0/24 -> 10.200.20.0/24

Inside 2811 10.200.20.0 /24
Crytpomap 10.200.20.0/24 -> 10.100.20.0/24

The site to site as said works as intended 2811 client can access the asa inside and can connect to the access vpn but not getting any return traffic from the DMZ.

ASA CONF:

ASA Version 9.3(1)
!
hostname Jonkoping-ASA
domain-name waterlab.local
enable password 8Ry2YjIyt7RRXU24 encrypted
names
ip local pool DMZ-ACCESS 10.100.22.11-10.100.22.40 mask 255.255.255.0
!
interface GigabitEthernet0/0
 description WAN
 nameif OUTSIDE
 security-level 0
 ip address dhcp setroute
!
interface GigabitEthernet0/1
 nameif INSIDE
 security-level 100
 ip address 10.100.20.1 255.255.255.0
!
interface GigabitEthernet0/2
 nameif DMZ
 security-level 20
 ip address 10.100.21.1 255.255.255.0
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/6
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/7
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/8
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 10.10.0.1 255.255.255.0
!
banner motd This is Waterlab Jonkoping if not allowed.. Get the fock out!
ftp mode passive
dns domain-lookup OUTSIDE
dns domain-lookup INSIDE
dns domain-lookup DMZ
dns domain-lookup management
dns server-group DefaultDNS
 name-server 8.8.8.8
 domain-name waterlab.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network Privnet
 subnet 10.0.0.0 255.0.0.0
 description Private net
object network Goteborg-INSIDE
 subnet 10.200.20.0 255.255.255.0
object network INSIDE
 subnet 10.100.20.0 255.255.255.0
object network Goteborg
 host 10.0.13.12
object service IKE
 service udp destination eq isakmp
object service NAT-T
 service udp destination eq 4500
object network DMZ
 subnet 10.100.21.0 255.255.255.0
object network ACESS-VPN
 subnet 10.100.22.0 255.255.255.0
object network NETWORK_OBJ_10.100.22.0_24
 subnet 10.100.22.0 255.255.255.0
object-group service SITE-SITE_VPN_IPSEC
 service-object esp
 service-object ah
 service-object object IKE
object-group service IPSEC_ACCESS_VPN
 service-object esp
 service-object object IKE
 service-object object NAT-T
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_2
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_3
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_4
 protocol-object ip
 protocol-object icmp
access-list INSIDE standard permit 10.100.20.0 255.255.255.0
access-list Lan_access_out extended permit ip any any
access-list OUTSIDE_cryptomap extended permit ip object ACESS-VPN object Gotebor   g-INSIDE
access-list OUTSIDE_cryptomap extended permit ip object INSIDE object Goteborg-I   NSIDE
access-list OUTSIDE_access_in extended permit object-group SITE-SITE_VPN_IPSEC o   bject Goteborg interface OUTSIDE
access-list OUTSIDE_access_in extended permit ip object Goteborg-INSIDE object I   NSIDE
access-list OUTSIDE_access_in extended permit ip object ACESS-VPN object DMZ
access-list OUTSIDE_access_in extended permit icmp any any
access-list DefaultRAGroup_splitTunnelAcl standard permit any4
access-list DMZ standard permit 10.100.21.0 255.255.255.0
access-list INSIDE_access_in extended permit object-group DM_INLINE_PROTOCOL_4 o   bject INSIDE any
access-list INSIDE_access_in extended permit object-group DM_INLINE_PROTOCOL_3 o   bject ACESS-VPN object DMZ
access-list DMZ_access_in extended permit ip object DMZ object ACESS-VPN
access-list DMZ_access_in extended deny object-group DM_INLINE_PROTOCOL_1 object    DMZ object Privnet
access-list DMZ_access_in extended permit object-group DM_INLINE_PROTOCOL_2 obje   ct DMZ any
pager lines 23
logging enable
logging asdm informational
mtu OUTSIDE 1500
mtu INSIDE 1500
mtu DMZ 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp deny any OUTSIDE
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (DMZ,INSIDE) source static Privnet Privnet destination static Privnet Privne   t no-proxy-arp route-lookup
nat (DMZ,OUTSIDE) source static Privnet Privnet destination static Privnet Privn   et no-proxy-arp route-lookup
nat (INSIDE,INSIDE) source static Privnet Privnet destination static Privnet Pri   vnet no-proxy-arp route-lookup
nat (INSIDE,OUTSIDE) source static Privnet Privnet destination static Privnet Pr   ivnet no-proxy-arp route-lookup
!
nat (any,OUTSIDE) after-auto source dynamic any interface description Nat overlo   ad Inside <-> Outside
access-group OUTSIDE_access_in in interface OUTSIDE
access-group INSIDE_access_in in interface INSIDE
access-group DMZ_access_in in interface DMZ
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authorization command LOCAL
http server enable
http 10.0.0.0 255.0.0.0 management
http 10.200.20.0 255.255.255.0 INSIDE
no snmp-server location
no snmp-server contact
no sysopt connection permit-vpn
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group5
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-A   ES-256-SHA
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES2   56
crypto map WAN_map 1 match address OUTSIDE_cryptomap
crypto map WAN_map 1 set peer 10.0.13.12
crypto map WAN_map 1 set ikev1 transform-set ESP-AES-256-SHA
crypto map WAN_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map WAN_map interface OUTSIDE
crypto map INSIDE_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map INSIDE_map interface INSIDE
crypto ca trustpoint _SmartCallHome_ServerCA
 no validation-usage
 crl configure
crypto ca trustpoint ASA
 keypair ASA
 crl configure
crypto ca trustpool policy
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
crypto ca certificate chain ASA
 certificate 01
    30820490 30820378 a0030201 02020101 300d0609 2a864886 f70d0101 0b050030
    72310b30 09060355 04061302 53453111 300f0603 55040813 08546865 20477269
    64310c30 0a060355 04071303 42475031 0c300a06 0355040a 13034350 55311e30
    1c06092a 864886f7 0d010901 160f4077 61746572 6c61622e 6c6f6361 6c311430
    12060355 0403130b 57617465 726c6162 2d434130 1e170d31 36303731 34323033
    3931305a 170d3236 30373132 32303339 31305a30 6a310b30 09060355 04061302
    53453111 300f0603 55040813 08546865 20477269 64310c30 0a060355 04071303
    42475031 0c300a06 0355040a 13034350 55311e30 1c06092a 864886f7 0d010901
    160f4077 61746572 6c61622e 6c6f6361 6c310c30 0a060355 04031303 41534130
    82012230 0d06092a 864886f7 0d010101 05000382 010f0030 82010a02 82010100
    a8996578 817b31f9 3c97d73c 15c25717 c28a515d e620782a 15432d0f 5afd1b8c
    789bc365 737a78ce 173e3c9f b3e32546 9d262b92 e73373e1 6f01712f 5569d596
    48c1ca8e 06a86dc6 7a8719f8 42f81d64 767e12aa 3968fc3c b59251df 65843a2a
    d11545cd 7da58687 7e629470 4333b86f 1bcd15c8 3af99a97 476e5027 e82aace9
    5bcc1a28 375550b2 683b7e32 05058b59 87152c0d a612ef07 4606caa3 52723699
    c1c1d962 19f208cb 05ad71eb 5fde7509 79a26b62 c0257086 fb2ba2c5 3230ebf5
    8bdd0748 17f46bab 8b1fd2fd c0763ea5 061e31ca f6cc6dc6 d5790f15 aecf105b
    ef39c2a1 3613daec ecce6f45 ac72662c e8c710ec 0aad656c 760d7843 b500b1b9
    02030100 01a38201 37308201 33300906 03551d13 04023000 30110609 60864801
    86f84201 01040403 02064030 33060960 86480186 f842010d 04261624 4f70656e
    53534c20 47656e65 72617465 64205365 72766572 20436572 74696669 63617465
    301d0603 551d0e04 1604143a dad3de88 c1c356eb 1f2b9a24 7db0d756 a9c60e30
    819c0603 551d2304 81943081 918014ba 50a9a037 b76238b2 e2ae5499 6059344e
    e105bfa1 76a47430 72310b30 09060355 04061302 53453111 300f0603 55040813
    08546865 20477269 64310c30 0a060355 04071303 42475031 0c300a06 0355040a
    13034350 55311e30 1c06092a 864886f7 0d010901 160f4077 61746572 6c61622e
    6c6f6361 6c311430 12060355 0403130b 57617465 726c6162 2d434182 01003013
    0603551d 25040c30 0a06082b 06010505 07030130 0b060355 1d0f0404 030205a0
    300d0609 2a864886 f70d0101 0b050003 82010100 63487775 abdf6f8f 0b288902
    ebe317b8 922606ee e2a8a7db 97ae4a36 3cfce2dd d487ca38 2f356b61 a2128dcb
    c567f872 35f21010 1326ea7b f78ccb07 3195df5c 1c8930f3 9713c042 f9701413
    bf8e35b7 3a1e2604 7c704dad a034ccf4 708b03fe a204a42c ffeae460 8f2c744b
    e4bd0dac 5011aedd 66f5a8fe 933b3e7c aa0da534 81815b56 7780dc06 9423cc12
    617813fa ea8747db 992cbf96 5ef52f2b d3460e85 10c408ff ed4c615d 17d80258
    291f32c4 c45227b9 43a862dc 119b79a1 d28efa45 0c33e453 5b8ef3c1 c7b56636
    8187655e 00f6d563 4e6fd654 66c486cb e8cc9361 3cccd79d ebcb6b15 db25fe03
    b45dfa7d b4299391 e86b7861 652c97ce 7cfa1122
  quit
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable INSIDE client-services port 443
crypto ikev2 remote-access trustpoint ASA
crypto ikev1 enable OUTSIDE
crypto ikev1 enable INSIDE
crypto ikev1 policy 1
 authentication pre-share
 encryption aes-256
 hash sha
 group 5
 lifetime 86400
telnet timeout 5
no ssh stricthostkeycheck
ssh 10.0.0.0 255.0.0.0 INSIDE
ssh 10.0.0.0 255.0.0.0 management
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access INSIDE
dhcp-client client-id interface OUTSIDE
dhcpd address 10.100.20.11-10.100.20.200 INSIDE
dhcpd dns 8.8.8.8 interface INSIDE
dhcpd domain waterlab.local interface INSIDE
dhcpd enable INSIDE
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl server-version tlsv1
ssl client-version tlsv1-only
ssl encryption aes128-sha1 aes256-sha1
ssl trust-point ASA
ssl trust-point ASA INSIDE
ssl trust-point ASA OUTSIDE
webvpn
 enable INSIDE
 no anyconnect-essentials
 anyconnect image disk0:/anyconnect-win-3.1.05187-k9.pkg 1
 anyconnect profiles DMZ-ACCESS_client_profile disk0:/DMZ-ACCESS_client_profile.   xml
 anyconnect enable
 tunnel-group-list enable
 error-recovery disable
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 vpn-tunnel-protocol l2tp-ipsec
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol l2tp-ipsec
 default-domain value waterlab.local
group-policy GroupPolicy_DMZ-ACCESS internal
group-policy GroupPolicy_DMZ-ACCESS attributes
 wins-server none
 dns-server value 8.8.8.8
 vpn-tunnel-protocol ikev2 ssl-client ssl-clientless
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value DMZ
 default-domain value waterlab.local
 webvpn
  anyconnect profiles value DMZ-ACCESS_client_profile type user
group-policy GroupPolicy_10.0.13.12 internal
group-policy GroupPolicy_10.0.13.12 attributes
 wins-server none
 dns-server value 8.8.8.8
 vpn-tunnel-protocol ikev1 ssl-client
 default-domain value waterlab.local
dynamic-access-policy-record DfltAccessPolicy
password-policy minimum-length 12
username admin password 3/lviPwfTkvzqanC encrypted privilege 15
tunnel-group DefaultRAGroup general-attributes
 default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ppp-attributes
 no authentication chap
 no authentication ms-chap-v1
tunnel-group 10.0.13.12 type ipsec-l2l
tunnel-group 10.0.13.12 general-attributes
 default-group-policy GroupPolicy_10.0.13.12
tunnel-group 10.0.13.12 ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 remote-authentication pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
tunnel-group DMZ-ACCESS type remote-access
tunnel-group DMZ-ACCESS general-attributes
 address-pool DMZ-ACCESS
 default-group-policy GroupPolicy_DMZ-ACCESS
tunnel-group DMZ-ACCESS webvpn-attributes
 group-alias DMZ-ACCESS enable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect rtsp
  inspect sunrpc
  inspect xdmcp
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect esmtp
  inspect sqlnet
  inspect sip
  inspect skinny
!
service-policy global_policy global
privilege cmd level 3 mode exec command perfmon
privilege cmd level 5 mode exec command dir
privilege cmd level 3 mode exec command ping
privilege cmd level 3 mode exec command who
privilege cmd level 3 mode exec command logging
privilege cmd level 3 mode exec command failover
privilege cmd level 3 mode exec command vpn-sessiondb
privilege cmd level 3 mode exec command packet-tracer
privilege cmd level 5 mode exec command export
privilege show level 5 mode exec command import
privilege show level 5 mode exec command running-config
privilege show level 3 mode exec command reload
privilege show level 3 mode exec command mode
privilege show level 3 mode exec command firewall
privilege show level 3 mode exec command asp
privilege show level 3 mode exec command cpu
privilege show level 3 mode exec command interface
privilege show level 3 mode exec command clock
privilege show level 3 mode exec command dns-hosts
privilege show level 3 mode exec command access-list
privilege show level 3 mode exec command logging
privilege show level 3 mode exec command vlan
privilege show level 3 mode exec command ip
privilege show level 3 mode exec command failover
privilege show level 3 mode exec command asdm
privilege show level 3 mode exec command arp
privilege show level 3 mode exec command ipv6
privilege show level 3 mode exec command route
privilege show level 3 mode exec command aaa-server
privilege show level 3 mode exec command aaa
privilege show level 3 mode exec command crypto
privilege show level 3 mode exec command ssh
privilege show level 3 mode exec command vpn-sessiondb
privilege show level 3 mode exec command vpn
privilege show level 3 mode exec command dhcpd
privilege show level 3 mode exec command blocks
privilege show level 3 mode exec command wccp
privilege show level 3 mode exec command dynamic-filter
privilege show level 3 mode exec command webvpn
privilege show level 3 mode exec command service-policy
privilege show level 3 mode exec command uauth
privilege show level 3 mode exec command compression
privilege show level 3 mode exec command ospf
privilege show level 3 mode exec command eigrp
privilege show level 3 mode configure command interface
privilege show level 3 mode configure command clock
privilege show level 3 mode configure command access-list
privilege show level 3 mode configure command logging
privilege show level 3 mode configure command ip
privilege show level 3 mode configure command failover
privilege show level 5 mode configure command asdm
privilege show level 3 mode configure command arp
privilege show level 3 mode configure command route
privilege show level 3 mode configure command aaa-server
privilege show level 3 mode configure command aaa
privilege show level 3 mode configure command crypto
privilege show level 3 mode configure command ssh
privilege show level 3 mode configure command dhcpd
privilege show level 5 mode configure command privilege
privilege clear level 3 mode exec command crypto
privilege clear level 3 mode exec command dns-hosts
privilege clear level 3 mode exec command logging
privilege clear level 3 mode exec command arp
privilege clear level 3 mode exec command aaa-server
privilege clear level 3 mode exec command dynamic-filter
privilege cmd level 3 mode configure command failover
privilege clear level 3 mode configure command logging
privilege clear level 3 mode configure command crypto
privilege clear level 3 mode configure command arp
privilege clear level 3 mode configure command aaa-server
prompt hostname context
call-home reporting anonymous
Cryptochecksum:1faf82e9bbf6ef5c1b06fe300fae9754
: end

3 REPLIES 3
m.kafka
Enthusiast

If I understand you right, you try to connect the remote-access-VPN coming in from the outside interface through a site-to-site-VPN to the inside interface?


+-------------------+
+------+ \--site-to-site-VPN---/ | |
client-VPN-->| 2811 |-----| - - - - - - - - - |---------------------->|
+------+ /---------------------\ | ASA outside | ASA inside
+---------+---------+
|
|
-----+----- ASA DMZ

I believe this won't work with ASA. RRI (reverse-route-injection) would install a route towards the interface where the client connects.

Even if you tried to connect to the outside interface instead, I'm not sure, whether the traffic decrypted from the site-to-site-VPN can hit a dynamic crypto map on the same interface.

Maybe give us a drawing how you want to connect.

Rgds, MiKa

That's Correct, I see , Montitoring the traffic makes it look that way.. The traffic hit's the DMZ but doesnt find it's way back to the client..

As you have observed yourself: the VPN-clinet's IP will be routed to the inside interface because the VPN-connection terminates there.

I am quite sure that you won't find a solution for this setup, at least not with an ASA.

Rgds, MiKa

Create
Recognize Your Peers
Content for Community-Ad