cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
931
Views
0
Helpful
22
Replies
sel18
Beginner

DMVPN Problem

Hello,

 

I have a lab configured on dmvpn with eigrp, but on the hub i can't view any spoke and on the spoke there are the ip of the Hub but with a state : NHRP ( configuration below)

there are anyone here can help me please to make the state up.

 

HUB:

interface Tunnel1
ip address 172.16.0.8 255.255.255.0
no ip redirects
ip mtu 1476
ip nhrp authentication DMVPN
ip nhrp network-id 1
ip nhrp holdtime 100
ip nhrp nhs 172.16.0.8
ip nhrp redirect
ip tcp adjust-mss 1436
tunnel source 192.168.10.2
tunnel mode gre multipoint

 

Spoke:

interface Tunnel1
ip address 172.16.0.9 255.255.255.0
no ip redirects
ip mtu 1476
ip nhrp authentication DMVPN
ip nhrp map 172.16.0.8 192.168.10.2
ip nhrp map multicast 192.168.10.2
ip nhrp network-id 1
ip nhrp holdtime 100
ip nhrp nhs 172.16.0.8
ip nhrp shortcut
ip tcp adjust-mss 1436
tunnel source 192.168.11.2
tunnel mode gre multipoint

 

HUB

Router#sh dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
T1 - Route Installed, T2 - Nexthop-override
C - CTS Capable
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

 

SPOKE

Router#sh dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
T1 - Route Installed, T2 - Nexthop-override
C - CTS Capable
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel1, IPv4 NHRP Details
Type:Spoke, NHRP Peers:1,

# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 192.168.10.2 172.16.0.8 NHRP 00:38:07 S

--------------------

EIGRP

 

HUB:

router eigrp DMVPN
!
address-family ipv4 unicast autonomous-system 1
!
topology base
exit-af-topology
network 123.0.0.0
network 123.8.8.8 0.0.0.0
network 172.16.0.0
exit-address-family
!

Spoke


router eigrp DMVPN
!
address-family ipv4 unicast autonomous-system 1
!
topology base
exit-af-topology
network 123.9.9.9 0.0.0.0
network 172.16.0.0
exit-address-family
!

22 REPLIES 22

any other suggestion here please !

Georg Pauwen
VIP Expert

Hello,

 

on the hub, it looks like you are missing the lines in bold:

 

interface Tunnel1
ip address 172.16.0.8 255.255.255.0
no ip redirects
ip mtu 1476
ip nhrp authentication DMVPN
--> ip nhrp map multicast dynamic
ip nhrp network-id 1
ip nhrp holdtime 100
ip nhrp nhs 172.16.0.8
--> no ip split-horizon eigrp 1
ip nhrp redirect
ip tcp adjust-mss 1436
tunnel source 192.168.10.2
tunnel mode gre multipoint

@georg

 

Thank you,

 

for the split-horizon, i used eigrp named ! how can i write eigrp 1 ?

and split-horizon didn't work with eigrp named 

Hello,

 

router eigrp DMVPN
!
address-family ipv4 unicast autonomous-system 1
af-interface Tunnel1
no split-horizon

@georg

thank you

i added this for the HUB

Emma Corry
Beginner

I have same problem, looking to this conversation like to some tv serial hoping to find any solutions.
Thanks all for your knowledge

sel18
Beginner

hi again

 

any other solution here plz ! i try all the possible solution that i khonw but nothing is change !!

 

thank you for your helps

@Emma Corry 

 

i found the solution

 

first check the mpls config and be sure that #sh mpls ldp nei is right

then check the ospf config and the redistribute of bgp and ospf in all the router

then check in the PE  #sh ip bgp all sum or #sh ip bgp all is correct and the state is up.

 

this is what i did and now it's working.

View solution in original post

Content for Community-Ad