cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
366
Views
5
Helpful
10
Replies

DMVPN receiving traffic but not returning a response.

JKOOP
Beginner
Beginner

Having an issue where the spoke and reach the hub and vice versa. But NHRP can't register and create a session. Any ideas?

 

dmvpn-hub-csr1#show run int Tu1
Building configuration...

Current configuration : 386 bytes
!
interface Tunnel1
bandwidth 1000000
ip address 10.212.1.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication dontlet
ip nhrp network-id 1
ip nhrp holdtime 450
ip tcp adjust-mss 1360
delay 10
tunnel source GigabitEthernet1
tunnel mode gre multipoint
tunnel key 1
tunnel path-mtu-discovery
tunnel vrf ISP1
tunnel protection ipsec profile ipsec-profile
end

dmvpn-hub-csr1#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
T1 - Route Installed, T2 - Nexthop-override
C - CTS Capable, I2 - Temporary
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel1, IPv4 NHRP Details
Type:Unknown, NHRP Peers:1,

# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 UNKNOWN 10.212.1.12 IKE never IX

dmvpn-hub-csr1#

 

 

dmvpn-spoke-2#show ip nhrp nhs detail
Legend: E=Expecting replies, R=Responding, W=Waiting, D=Dynamic
Tunnel1:
10.212.1.2 E priority = 0 cluster = 0 req-sent 0 req-failed 67 repl-recv 0


Pending Registration Requests:
Registration Request: Reqid 3, Ret 64 NHS 10.212.1.2 expired (Tu1)
dmvpn-spoke-2#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
T1 - Route Installed, T2 - Nexthop-override
C - CTS Capable, I2 - Temporary
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel1, IPv4 NHRP Details
Type:Spoke, NHRP Peers:1,

# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 10.12.1.2 10.212.1.1 IKE never SC

dmvpn-spoke-2#show run int Tu1
Building configuration...

Current configuration : 512 bytes
!
interface Tunnel1
bandwidth 1000000
ip address 10.212.1.11 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication dontlet
no ip nhrp map multicast dynamic
ip nhrp map 10.212.1.1 10.12.1.2
ip nhrp map multicast 10.12.1.1
ip nhrp network-id 1
ip nhrp holdtime 450
ip nhrp nhs 10.212.1.2
ip tcp adjust-mss 1360
delay 10
tunnel source GigabitEthernet1
tunnel mode gre multipoint
tunnel key 1
tunnel path-mtu-discovery
tunnel vrf ISP1
tunnel protection ipsec profile ipsec-profile
end

dmvpn-spoke-2#ping vrf ISP1 10.12.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.12.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms
dmvpn-spoke-2#

1 Accepted Solution

Accepted Solutions

Tunnel1 10.212.1.1 YES NVRAM up up <- sure hub is .1 not .2 
so  in Spoke 

ip nhrp nhs 10.212.1.1

ip nhrp map 10.212.1.1 10.12.1.2
ip nhrp map multicast 10.12.1.2

 

View solution in original post

10 Replies 10

ip nhrp nhs 10.212.1.2 <- this must be 10.212.1.1

 

ip nhrp map 10.212.1.1 10.12.1.2 <- why the mapping IP is different ?
ip nhrp map multicast 10.12.1.1    <-

10.212.1.2 is correct but ya there was a miss match. I'm still seeing the same result after correcting the config. 

but hub IP is 10.212.1.1 NOT 10.212.1.2 !!

dmvpn-hub-csr1#show ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet1 10.12.1.2 YES NVRAM up up
GigabitEthernet2 unassigned YES NVRAM administratively down down
GigabitEthernet3 unassigned YES NVRAM administratively down down
GigabitEthernet4 unassigned YES NVRAM administratively down down
Tunnel1 10.212.1.1 YES NVRAM up up
dmvpn-hub-csr1#

 

dmvpn-spoke-2#show ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet1 21.22.24.10 YES NVRAM up up
GigabitEthernet2 unassigned YES NVRAM administratively down down
GigabitEthernet3 unassigned YES NVRAM administratively down down
GigabitEthernet4 unassigned YES NVRAM administratively down down
Tunnel1 10.212.1.11 YES NVRAM up up
dmvpn-spoke-2#

dmvpn-hub-csr1#debug nhrp
NHRP protocol debugging is on
dmvpn-hub-csr1#
*Jul 24 02:28:50.854: NHRP: NHRP could not map 10.212.1.11 to NBMA, cache entry not found
*Jul 24 02:28:50.855: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1 netid-out 1
*Jul 24 02:28:50.855: NHRP: Checking for delayed event NULL/10.212.1.11 on list (Tunnel1 vrf: global(0x0))
*Jul 24 02:28:50.856: NHRP: No delayed event node found.
*Jul 24 02:28:51.397: NHRP: NHRP could not map 10.212.1.12 to NBMA, cache entry not found
*Jul 24 02:28:51.397: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1 netid-out 1
*Jul 24 02:28:51.397: NHRP: Checking for delayed event NULL/10.212.1.12 on list (Tunnel1 vrf: global(0x0))
*Jul 24 02:28:51.398: NHRP: No delayed event node found.
dmvpn-hub-csr1#
*Jul 24 02:28:52.552: NHRP: Setting cache expiry for 21.22.24.10 to 1 milliseconds in cache
dmvpn-hub-csr1#
*Jul 24 02:28:55.854: NHRP: NHRP could not map 10.212.1.11 to NBMA, cache entry not found
*Jul 24 02:28:55.854: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1 netid-out 1
*Jul 24 02:28:55.855: NHRP: Checking for delayed event NULL/10.212.1.11 on list (Tunnel1 vrf: global(0x0))
*Jul 24 02:28:55.855: NHRP: No delayed event node found.
*Jul 24 02:28:56.398: NHRP: NHRP could not map 10.212.1.12 to NBMA, cache entry not found
*Jul 24 02:28:56.399: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1 netid-out 1
*Jul 24 02:28:56.399: NHRP: Checking for delayed event NULL/10.212.1.12 on list (Tunnel1 vrf: global(0x0))
*Jul 24 02:28:56.399: NHRP: No delayed event node found.
dmvpn-hub-csr1#
*Jul 24 02:29:00.854: NHRP: NHRP could not map 10.212.1.11 to NBMA, cache entry not found
*Jul 24 02:29:00.855: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1 netid-out 1
*Jul 24 02:29:00.855: NHRP: Checking for delayed event NULL/10.212.1.11 on list (Tunnel1 vrf: global(0x0))
*Jul 24 02:29:00.855: NHRP: No delayed event node found.
*Jul 24 02:29:01.398: NHRP: NHRP could not map 10.212.1.12 to NBMA, cache entry not found
*Jul 24 02:29:01.399: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel1 netid-out 1
*Jul 24 02:29:01.399: NHRP: Checking for delayed event NULL/10.212.1.12 on list (Tunnel1 vrf: global(0x0))
*Jul 24 02:29:01.399: NHRP: No delayed event node found.
dmvpn-hub-csr1#


dmvpn-spoke-2#config t
Enter configuration commands, one per line. End with CNTL/Z.
dmvpn-spoke-2(config)#logging console
dmvpn-spoke-2(config)#exit
dmvpn-spoke-2#
*Jul 24 02:29:39.674: %SYS-5-CONFIG_I: Configured from console by console
dmvpn-spoke-2#
dmvpn-spoke-2#
dmvpn-spoke-2#
dmvpn-spoke-2#clear dmvpn sess
dmvpn-spoke-2#clear dmvpn session
dmvpn-spoke-2#config
*Jul 24 02:30:10.588: NHRP: Setting retrans delay to 64 for nhs dst 10.212.1.2
*Jul 24 02:30:10.588: NHRP-ERROR: Incompatible Destination NBMA (UNKNOWN) for 'Tunnel1'
*Jul 24 02:30:39.673: NHRP: Setting cache expiry for 10.12.1.2 to 1 milliseconds in cache
*Jul 24 02:30:58.795: NHRP: Setting retrans delay to 64 for nhs dst 10.212.1.2
*Jul 24 02:30:58.796: NHRP-ERROR: Incompatible Destination NBMA (UNKNOWN) for 'Tunnel1'

Tunnel1 10.212.1.1 YES NVRAM up up <- sure hub is .1 not .2 
so  in Spoke 

ip nhrp nhs 10.212.1.1

ip nhrp map 10.212.1.1 10.12.1.2
ip nhrp map multicast 10.12.1.2

 

It can't be as its another router. 

 

dmvpn-hub-csr1#show ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet1 10.12.1.2 YES NVRAM up up
GigabitEthernet2 unassigned YES NVRAM administratively down down
GigabitEthernet3 unassigned YES NVRAM administratively down down
GigabitEthernet4 unassigned YES NVRAM administratively down down
Tunnel1 10.212.1.1 YES NVRAM up up
dmvpn-hub-csr1#show ip arp vrf ISP1
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.12.1.1 212 5000.0006.0003 ARPA GigabitEthernet1
Internet 10.12.1.2 - 5000.001a.0000 ARPA GigabitEthernet1
dmvpn-hub-csr1#
*Jul 24 02:37:30.797: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 10.212.1.11 (Tunnel1) is down: retry limit exceeded
dmvpn-hub-csr1#
*Jul 24 02:37:34.186: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 10.212.1.11 (Tunnel1) is up: new adjacency

 

 

dmvpn-spoke-2(config)#do show run int Tu1
Building configuration...

Current configuration : 512 bytes
!
interface Tunnel1
bandwidth 1000000
ip address 10.212.1.11 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication dontlet
no ip nhrp map multicast dynamic
ip nhrp map multicast 10.12.1.2
ip nhrp map 10.212.1.1 10.12.1.2
ip nhrp network-id 1
ip nhrp holdtime 450
ip nhrp nhs 10.212.1.2
ip tcp adjust-mss 1360
delay 10
tunnel source GigabitEthernet1
tunnel mode gre multipoint
tunnel key 1
tunnel path-mtu-discovery
tunnel vrf ISP1
tunnel protection ipsec profile ipsec-profile
end

Nevermind. This is a weird IP scheme I'm working with. I see what you mean. 

It happened a lot, 
dont worry 
good luck

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers