03-30-2013 02:42 PM - edited 02-21-2020 06:47 PM
Trying to ping the Spoke 2 LAN from Spoke 1 fails (and vice versa) because there is no route in the routing table. Putting static routes in the spokes works, however, so it's not a connectivity problem.
Here's the Hub config:
interface Tunnel2550
bandwidth 3000
ip vrf forwarding UMMA01
ip address 172.31.255.1 255.255.255.224
no ip redirects
ip mtu 1380
no ip next-hop-self eigrp 2550
ip nhrp authentication XXXX
ip nhrp map multicast dynamic
ip nhrp network-id 2550
ip nhrp holdtime 600
no ip split-horizon eigrp 2550
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 2550
tunnel protection ipsec profile ENCRYPTEDGRE
Spoke 1:
interface Tunnel2550
bandwidth 3000
ip address 172.31.255.2 255.255.255.224
no ip redirects
ip mtu 1380
ip nhrp authentication XXXX
ip nhrp map multicast 1.1.1.1
ip nhrp map 172.31.255.1 1.1.1.1
ip nhrp network-id 2550
ip nhrp holdtime 600
ip nhrp nhs 172.31.255.1
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 2550
tunnel protection ipsec profile ENCRYPTEDGRE
Spoke 2:
interface Tunnel2550
bandwidth 3000
ip address 172.31.255.3 255.255.255.224
no ip redirects
ip mtu 1380
ip nhrp authentication XXXX
ip nhrp map multicast 1.1.1.1
ip nhrp map 172.31.255.1 1.1.1.1
ip nhrp network-id 2550
ip nhrp holdtime 600
ip nhrp nhs 172.31.255.1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 2550
tunnel protection ipsec profile ENCRYPTEDGRE
Here's the IP NHRP table from spoke 1:
NEXUMMA01#sh ip nhrp
172.31.255.1/32 via 172.31.255.1
Tunnel2550 created 03:54:40, never expire
Type: static, Flags: used
NBMA address: 1.1.1.1
172.31.255.2/32 via 172.31.255.2
Tunnel2550 created 00:00:10, expire 00:09:49
Type: dynamic, Flags: router unique local
NBMA address: 2.2.2.2
(no-socket)
172.31.255.3/32 via 172.31.255.3
Tunnel2550 created 00:00:10, expire 00:09:48
Type: dynamic, Flags: router used
NBMA address: 3.3.3.3
Here's ping results from Spoke 1 to Spoke 2 tunnel:
NEXUMMA01#ping 172.31.255.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.31.255.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
NEXUMMA01#
Here's the routing table for the Spoke 1 LAN:
192.168.255.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.255.0/24 is directly connected, GigabitEthernet0/1.2550
L 192.168.255.1/32 is directly connected, GigabitEthernet0/1.2550
Routing table for Spoke 2 LAN:
192.168.254.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.254.0/24 is directly connected, Vlan2550
L 192.168.254.1/32 is directly connected, Vlan2550
Routing table on Hub:
D 192.168.254.0/24 [90/2135808] via 172.31.255.3, 00:15:35, Tunnel2550
D 192.168.255.0/24 [90/2135808] via 172.31.255.2, 00:15:35, Tunnel2550
It's just not propagating the routes to the spokes for some reason. Please assist. Wondering if it has anything to do with the hub tunnel using a VRF.
03-31-2013 10:15 AM
can you show me EIGRP config at the hub and the spokes ?
Mohammad.
04-01-2013 11:44 AM
HUB:
router eigrp RRRR
!
address-family ipv4 unicast vrf XXXXX autonomous-system 2550
!
topology base
exit-af-topology
network 10.64.255.0 0.0.0.255
network 172.31.255.0 0.0.0.31
exit-address-family
router eigrp 2550
network 172.31.255.0 0.0.0.31
network 192.168.255.0
router eigrp 2550
network 172.31.255.0 0.0.0.31
network 192.168.254.0
router eigrp RRRR
SPOKE 1:
router eigrp 2550
network 172.31.255.0 0.0.0.31
network 192.168.255.0
SPOKE 2:
router eigrp 2550
network 172.31.255.0 0.0.0.31
network 192.168.254.0
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide