cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
294
Views
0
Helpful
1
Replies
Highlighted
Beginner

GRE tunnel in VRF with underlay in GRT

Hello,

I would like to know if it's possible to configure a GRE tunnel in a vrf using the GRT as underlay?

For example, this configuration (source):

interface Tunnel0
 ip vrf forwarding green
 ip address 200.200.200.3 255.255.255.0
 tunnel source Ethernet0/0
 tunnel destination 10.10.10.1
 tunnel vrf blue
!--- Tunnel 0 is part of VRF GREEN; but it uses the tunnel
!--- destination and source addresses from the routing
!--- table of VRF BLUE, because of this tunnel vrf blue
!--- command.

But, instead of using vrf blue routing table for the source and destination addresses, I want to use the GRT routing table.

 

Thank you for your help.

Thomas

1 REPLY 1
Highlighted
Beginner

Hello,

I found a way to make it work (not sure if it's the more efficient way).

In the vrf green, I configure a static route to the tunnel destination pointing to the GRT (using the word "global"):

ip route vrf green 10.10.10.1 255.255.255.255 (interface x/x) (next hop ip) global

source

Configuration example:

interface Tunnel0
 ip vrf forwarding green
 ip address 200.200.200.3 255.255.255.0
 tunnel source Ethernet0/0
 tunnel destination 10.10.10.1
!
interface Ethernet0/0
 ip address 20.20.20.3 255.255.255.0
!
ip route vrf green 10.10.10.1 255.255.255.255 Ethernet0/0 <next-hop-ip> global