cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
664
Views
0
Helpful
4
Replies

Issues with Remote VPN on ASA 5505.

hanwucisco
Level 1
Level 1

I configured a client vpn via CLI. I can connect through a client. When I show the IP address, it does get an IP(10.0.0.100) from the vpn pool. But after that, the PC cannot browse the HTTP or even ping the inside interface(10.0.0.1).

am i missing something? thanks,

Han

=====Inside(10.0.0.0/24, vpn pool is included)====ASA====Outside(192.168.1.0/24, where testing PC is located.), I use PAT.

Show run,

======

hostname ciscoasa
domain-name mydomain.com
enable password  vvv encrypted
passwd vvv encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 10.0.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
!
!
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 8.8.4.4
domain-name mydomain.com
object network inside
object network myhomenet
host 10.0.0.10
access-list 101 extended permit ip any host 10.0.0.10
access-list 101 extended permit icmp any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool testpool 10.0.0.100-10.0.0.110 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-631.bin
no asdm history enable
arp timeout 14400
!
object network myhomenet
nat (inside,outside) dynamic interface
access-group 101 in interface outside
!
route-map VPN-INTERNET permit 10
match ip address 109
!
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.0.0.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set FirstSet esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map dyn1 1 set transform-set FirstSet
crypto dynamic-map dyn1 1 set reverse-route
crypto dynamic-map dyn2 2 set reverse-route
crypto map mymap 1 ipsec-isakmp dynamic dyn1
crypto map mymap interface outside
crypto isakmp enable outside
crypto isakmp policy 1
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 43200
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 8.8.4.4
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username cisco password vvv encrypted
tunnel-group mygroup type remote-access
tunnel-group mygroup ipsec-attributes
pre-shared-key vvv

tunnel-group testgroup type remote-access
tunnel-group testgroup general-attributes<=== Iam not sure this command as whether it's right?
address-pool testpool
tunnel-group testgroup ipsec-attributes
pre-shared-key vvv
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home
profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:e2a02cb5b845848b8747d334f6c3cd18
: end
ciscoasa(config)#

==============

ciscoasa(config)# sh vpn-

Active Session Summary

Sessions:
                           Active : Cumulative : Peak Concurrent : Inactive
  SSL VPN               :       0 :          0 :               0
    Clientless only     :       0 :          0 :               0
    With client         :       0 :          0 :               0 :        0
  Email Proxy           :       0 :          0 :               0
  IPsec LAN-to-LAN      :       0 :          0 :               0
  IPsec Remote Access   :       1 :          2 :               1
  Totals                :       1 :          2

License Information:
  IPsec   :     10    Configured :     10    Active :      1    Load :  10%
  SSL VPN :      2    Configured :      2    Active :      0    Load :   0%
                            Active : Cumulative : Peak Concurrent
  IPsec               :          1 :          2 :               1
  SSL VPN             :          0 :          0 :               0
    AnyConnect Mobile :          0 :          0 :               0
    Linksys Phone     :          0 :          0 :               0
  Totals              :          1 :          2

Tunnels:
               Active : Cumulative : Peak Concurrent
  IKE    :          1 :          2 :               1
  IPsec  :          1 :          2 :               1
  Totals :          2 :          4

Active NAC Sessions:
  No NAC sessions to display

Active VLAN Mapping Sessions:
  No VLAN Mapping sessions to display
ciscoasa(config)#

1 Accepted Solution

Accepted Solutions

Hi Han,


That nat command will translate traffic from the inside network to itself and simulaneously translate the destination to itself.

In your case the inside network and the addresses assigned to the VPN client are in the same subnet.

Here is an example:

nat (inside,outside) source static real-src mapped-src destination static mapped-dst real-dst

When this nat statement is evaluated traffic from the inside has its source address translated from real-src to mapped-src and the destination traffic is translated likewise. The idea here is to not nat the traffic at all so that when a host on the inside replies to a request from the client the traffic is unchanged.

Here is the link to the configuration guide for NAT on the ASA

http://www.cisco.com/en/US/docs/security/asa/asa83/configuration/guide/nat_overview.html

Let me know if you have any questions.

Thanks,

Loren

View solution in original post

4 Replies 4

Loren Kolnes
Cisco Employee
Cisco Employee

Hi Han,

You need to configure nat exemption for the VPN client to communicate with the inside network.

object network inside-net
subnet 10.0.0.0 255.255.255.0

nat (inside,outside) source static inside-net inside-net destination static inside-net inside-net

IIn order to ping the inside interface you will need to use the "management-access inside" command.

Let me know if this helps.

Thanks,

Loren

Loren,

can you please explain to me what is this?

nat (inside,outside) source static inside-net inside-net destination static inside-net inside-net, inside to inside?

thanks,

Han

Hi Han,


That nat command will translate traffic from the inside network to itself and simulaneously translate the destination to itself.

In your case the inside network and the addresses assigned to the VPN client are in the same subnet.

Here is an example:

nat (inside,outside) source static real-src mapped-src destination static mapped-dst real-dst

When this nat statement is evaluated traffic from the inside has its source address translated from real-src to mapped-src and the destination traffic is translated likewise. The idea here is to not nat the traffic at all so that when a host on the inside replies to a request from the client the traffic is unchanged.

Here is the link to the configuration guide for NAT on the ASA

http://www.cisco.com/en/US/docs/security/asa/asa83/configuration/guide/nat_overview.html

Let me know if you have any questions.

Thanks,

Loren

thanks.