cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
34438
Views
35
Helpful
5
Replies
e_g_de_vries1
Beginner

Unable to install anyconnect client - "winsetup-release-web-deploy.msi" cannot be found

I am having problems with installing the Cisco Anyconnect Client version 4.1.04011-web-deploy-k9 on Windows 10.

Before upgrading to Windows 10 I uninstalled (add / remove programs) the old client. 

After upgrade to Windows 10 I want to install the supported version of Anyconnect but this failed. I receive the error:

"The feature you are trying to use is on a network resource that is unavailable."

"Click OK to try again or enter an alternate path to a folder containing the installation package "Winsetup-Release-web-deploy.mis" in the box below."

I am running the installation as Administrator, the installation file is on my local C: drive.

I guess that the removal of the old version was incomplete and that the new installation is trying to remove files and/or registry settings but is missing an uninstallation file.

Is there a fix tool for this or is there an instruction to manual remove all old files and registry settings?

5 REPLIES 5
e_g_de_vries1
Beginner

Problem Solved

 

In search for the solution for my problem I tried to install the client from the command prompt with elevated rights from c:\temp where I located the .msi installation file:

 

msiexec /fv anyconnect-win-4.1.04011-pre-deploy-k9.msi /lvx "c:\Temp\ac-Uninstall.log.txt”

 

Again the installations failed. This time with te message: The file "ManifestTool.exe" is not marked for installation. 

Only option I had was to click on "Ok".

 

This time the log "c:\Temp\ac-Uninstall.log.txt” was created. In this log I found this line: 

MSI (s) (E8:40) [07:42:34:275]: Product: Cisco AnyConnect Secure Mobility Client -- Error 2753. The File 'ManifestTool.exe' is not marked for installation.

 

I searched on the internet for "error 2753" AND "is not marked for installation". I found this site that directed me to the solution: 

https://helpdesk.illinoisstate.edu/kb/1962/Error_Error_2753_The_File_is_not_marked_for_installation_when_installing_Cisco_Jabber/

 

In the registry I found the key that was causing the installation failure. I deleted the key in the following steps and after that I succesfully installed the new client.

 

To edit the registry, do the following:

1.Click Start and type regedit in the box.

2.A dialogue box will pop up with the following text: Do you want to allow the following program to make changes to this computer? Click Yes.

3.Browse to the following location: HKEY_CLASSES_ROOT\Installer\Products\

4.Within the Products folder, locate and delete the registry key which contains product information for Cisco AnyConnect Secure Mobility Client. 

◦Each registry key within Products is an alphanumeric string. Select the first key and look on the right side for ProductName REG_SZ Cisco AnyConnect Secure Mobility Client. Go through each key in the Products folder until you find the one for Cisco AnyConnect Secure Mobility Client.

◦In my (this) case: [HKEY_CLASSES_ROOT\Installer\Products\E8CB28D0EF413434EBCBFF65361793A3]

◦Your version of Cisco AnyConnect Secure Mobility Client might have a different name for this registry key. 

◦I recommend making a backup of this registry key before deleting it.

5.Close the registry editor.

 

After this start the installation of the new Cisco AnyConnect Secure Mobility Client.

 

Christopher and Pete from Cisco support: thanks for your help in solving this problem and pointing me in the right direction!

Thanks for sharing the solution you found. +5

Thanks for the solution

Thank you for posting this solution. 

This worked for me Thanks

Content for Community-Ad