Showing results for 
Search instead for 
Did you mean: 
Daniel Dvorak

Unable to install anyconnect version 2.5 on Windows XP

I could not install any version of anyconnect at all on my netbook with Windows XP Home edition, SP3 with all necessary updates. MSI installation fails at the same point. I attach 2 pictures and one log which describe my situation. I could not find if somebody reports it in any internet community forums.

I tried to install localy and remotly from vpn gateway, the results are the same.

Shilpa Gupta
Cisco Employee

Hi Daniel,

I just want to you make sure that that the following registry key is existing:


The following is the reference link:-

Also make sure that the user logged in to install the client have admin rights.

I hope it helps.



Hi, I checked it before I wrote here my problem, the registry path "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce" exists on my pc and of course I install vpn client with admin rights. So I have this registry and still have a problem.

Erik Ingeberg

This is an interesting problem. The problem is similar in all the log files and looks something like this:

DEBUG: Error 2826:  Control BottomLine on dialog PrepareDlg extends beyond the boundaries of the dialog to the right by 3 pixels
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2826. The arguments are: PrepareDlg, BottomLine, to the right

I tried googling "error 2826" and parts of the error message, and found a wide variety of problems with different solutions. But I am guessing this could have something to do with either the font used on the XP machine or perhaps it has something to do with the character encoding in the clients regional settings.

Daniel Dvorak

Hi all, at the end I found out what it causes this error. It is quite simple problem and it is very annoying from Cisco since there is not some special requirements for installation directory where anyconnect should be installed.

I have a netbook Eee PC 901 which it has 2 physical ssd hard disks, one is 4GB C:, the second one is 8GB D:. I really don´t know how asus could even imagine users can use windows xp and program files directory together on one small 4GB hard disk, but I had to change system enviroment and the default location Program Files directory, which is on the same disk like %systemroot% directory by default, to second disk D:, so on my netbook I have the "D:\Program Files" directory.

It was enough to change directory to default location by registry value HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir "D:\Program Files" ---> "C:\Program Files" and voila, that's it!!!

I am confused about cisco anyconnect, because there is not any requirements, that installation need to be strictly in C: and in second there is not any chance to change directory location durring installation, so a man has to change the registry first.

This error is repeatable, if I change the registry back to D:, installation fails again.

I consider it as a elementary bug and Cisco should react on it.

Update error msg:

Product: Cisco AnyConnect VPN Client -- Error 1722.
There is a problem with this Windows Installer package.
A program run as part of the setup did not finish as expected.
Contact your support personnel or package vendor.
Action Ax_Install_Pre, location: D:\Program Files\Cisco\Cisco AnyConnect VPN Client\InstallHelper.exe,
command: -ax -install "D:\Program Files\Cisco\Cisco AnyConnect VPN Client\vpnweb.ocx" "C:\WINDOWS\system32\vpnweb.ocx"


When i was running anyconnect-win-3.1.00495-pre-deploy-k9.msi to install the VPN client to my corporate network I was getting the error "the file installhelper.exe is not marked for installation" first i looked into the registry under HKEY_CLASSES_ROOT\Installer\Products\ (look for the folder with a KEY called ProductName = 'Cisco Anyconnect blablabla'  then delete the folder in the registry, could be better if you made a backup of the registry before this).

If this doesn`t works look in C:\Program Files\ for any folder Cisco or Cisco Systems and rename it. 

Looks like this happens when for any reason (like in may case i didn`t had the Service Pack 3 installed) the previus deploys crash.

Restart installation.

Best Regards.

Juan Manuel de Pablo Ortiz.


This is the only solution that worked for me.  Thanks!

Content for Community-Ad