cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
496
Views
0
Helpful
3
Replies
payala
Beginner

VPN on a Stick with Cisco Router

Hello team,

I was wondering if it's possible to create the next scenario where I want to connect a Cisco Router 1841 directly to a GPON (Gigabit-capable Passive Optical Networks), here is my network diagram:

I was trying to configure Cisco SSL VPN (WebVPN), is it possible to create this network scenario??? There should be NAT for my internal ip address (192.168.1.1), right?

Here is the sample configuration that I created:

aaa authentication login default line
aaa authentication login userauthen local
aaa authentication login sslvpn local
aaa authentication ppp default local
aaa authorization network groupauthor local

!

password encryption aes
crypto pki token default removal timeout 0
!
crypto pki trustpoint my-trustpoint
enrollment selfsigned
serial-number
subject-name CN=my-certificate
revocation-check crl
rsakeypair my-rsa-keys
!

webvpn gateway my-WebVPN-Gateway
ip address 192.168.1.1 port 443
ssl encryption rc4-md5
ssl trustpoint my-trustpoint
inservice
!
webvpn context my-WebVPN
title "My WebVPN - Powered By Cisco"
ssl authenticate verify all
!
url-list "rewrite"
!
acl "ssl-acl"
permit ip 192.168.1.0 255.255.255.0 192.168.1.0 255.255.255.0
!
login-message "Cisco Secure WebVPN"
!
policy group webvpnpolicy
functions svc-enabled
filter tunnel ssl-acl
svc address-pool "webvpn-pool" netmask 255.255.255.0
svc rekey method new-tunnel
svc split include 192.168.1.0 255.255.255.0
default-group-policy webvpnpolicy
aaa authentication list sslvpn
max-users 2
inservice

Here is the configuration from the interface (the only interface connected to the GPON):

interface Vlan1
description < LAN >
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip accounting output-packets
ip nbar protocol-discovery
ip flow ingress
ip virtual-reassembly in
!

3 REPLIES 3
Philip D'Ath
Advisor

Life would be easier if you did:

internal hosts <--> 1841 <--> GPON router

That's correct but the problem is that I need to get another AP instead of the GPON. Actually my VPN is working now but I'm getting a lot of problems with Full tunnel and also I'm having issues with disconnections. I'm not sure what's going on.

Check this site for more info http://www.best-power-banks.com/

Create
Recognize Your Peers
Content for Community-Ad