cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

VPN Split tunneling with Hairpinning / U-turn to specific IP / web address

I have quite an old set-up and am not really a sys-ops person (primarily a developer so out of my depth a bit) but had to make do.
Were using a ASA 5505 in passthrough mode at a datacentre for web servers.
But with the closure of an office one of the internal storage servers was moved in there and I had to re-configure the ASA to allow VPN access.

The users connect through Split tunnelling to access the shared drive - but I would now like to also enable hairpinning / U-turn to a specific website which requires a static IP as some users do not have this at home.
Is this possible?
How can it be done ?

Am guessing something to do with NATing the connection then routing it back out the external interface for the one specific web IP ?


Cisco Adaptive Security Appliance Software Version 8.0(4)
Device Manager Version 6.2(1)

Somewhat sanitised config:

It might well be a mess - please feel free to shout if you see anything else out of place.

-----------------------------------------------------------------------------------------------

Result of the command: "show running-config"

: Saved
:
ASA Version 8.0(4)
!
hostname ASATDA
domain-name default.domain.invalid
enable password <Password> encrypted
passwd <Password> encrypted
names
name xx.xxx.xx.180 Archie
name xx.xxx.xx.181 Rubben
name xx.xxx.xx.179 Vincent
name xx.xxx.xx.182 ORubben
name xx.xxx.xx.18 CompanyName-18 description CompanyName-18
name xx.xxx.xx.19 CompanyName-19 description CompanyName-19
name xx.xxx.xx.19 MyHome description My home IP plusnet
name xx.xxx.xx.214 MyNWales2 description Dec 2014
name xx.xxx.xx.183 Web2016
name 192.168.98.3 ArchieInside
name 192.168.98.2 RubbenInside
name 192.168.98.5 Web2016Inside
name 192.168.98.4 VincentInside
name 192.168.98.7 OldRubbenInside
name 192.168.98.13 CompanyNameSANINside
name 192.168.98.12 CompanyNameSageInside
name xx.xxx.xx.186 CompanyNameSageOutside
name 192.168.98.11 OtherCompanyMailInside
name xx.xxx.xx.185 OtherCompanyMailOutside
name 192.168.98.6 TDAMailInside
name xx.xxx.xx.184 TDAMailOutside
name xx.xxx.xx.248 GarryHome
name 192.168.98.1 SAN
name xx.xxx.xx.147 MySister description Sister's House - Scotland
name 104.27.192.92 WhatIsMyIP description test IP
!
interface Vlan1
nameif outside
security-level 0
ip address xx.xxx.xx.178 255.255.255.240
!
interface Vlan2
nameif inside
security-level 100
ip address 192.168.98.10 255.255.255.0
!
interface Ethernet0/0
speed 100
duplex full
!
interface Ethernet0/1
switchport access vlan 2
speed 100
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa804-k8.bin
ftp mode passive
clock timezone GMT/BST 0
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group network OfficeHome
network-object host CompanyName-18
network-object host CompanyName-19
network-object host MyHome
network-object host MyNWales2
network-object host GarryHome
network-object host MySister
object-group network DnsServer
network-object host Vincent
object-group network FtpServer
network-object host Vincent
network-object host Archie
network-object host ORubben
network-object host Web2016
network-object host TDAMailOutside
object-group network WebServer
description web server
network-object host Vincent
network-object host Archie
network-object host Web2016
network-object host ArchieInside
network-object host Web2016Inside
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
object-group network EmailServer
network-object host Vincent
network-object host OtherCompanyMailInside
network-object host VincentInside
network-object host TDAMailInside
network-object host TDAMailOutside
network-object host OtherCompanyMailOutside
object-group service rdc tcp
port-object eq 3389
object-group network rAdmin
network-object host Vincent
network-object host ORubben
object-group service Radmin tcp
port-object eq 4999
object-group network RDCserver
network-object host Archie
network-object host Rubben
network-object host Web2016
object-group service TLS-ftp tcp
description SSL/TLS-ftp
port-object eq 990
port-object eq 989
port-object eq ssh
port-object eq ftp
port-object eq ftp-data
port-object eq 33322
port-object eq 33323
port-object eq 33324
port-object eq 33325
port-object eq 33326
object-group service DM_INLINE_TCP_0 tcp
group-object TLS-ftp
port-object eq ftp
port-object eq ftp-data
port-object eq www
port-object eq https
object-group protocol DM_INLINE_PROTOCOL_1
protocol-object udp
protocol-object tcp
object-group protocol DM_INLINE_PROTOCOL_2
protocol-object udp
protocol-object tcp
object-group protocol DM_INLINE_PROTOCOL_3
protocol-object icmp
protocol-object icmp6
object-group service DM_INLINE_TCP_1 tcp
group-object TLS-ftp
port-object eq ftp
port-object eq ftp-data
object-group protocol DM_INLINE_PROTOCOL_4
protocol-object udp
protocol-object tcp
object-group service DM_INLINE_TCP_2 tcp
port-object eq pop2
port-object eq pop3
port-object eq smtp
object-group service DM_INLINE_TCP_3 tcp
port-object eq www
port-object eq https
group-object TLS-ftp
port-object eq ftp
port-object eq ftp-data
group-object Radmin
group-object rdc
object-group service iPerf tcp-udp
description Used for testing using iPerf
port-object eq 5201
object-group service DM_INLINE_TCP_4 tcp
group-object TLS-ftp
port-object eq ftp
port-object eq ftp-data
port-object eq www
port-object eq https
group-object Radmin
group-object rdc
group-object iPerf
object-group service DM_INLINE_TCP_5 tcp
group-object TLS-ftp
port-object eq ftp
port-object eq ftp-data
group-object Radmin
group-object rdc
object-group service DM_INLINE_TCP_6 tcp
group-object TLS-ftp
port-object eq domain
port-object eq ftp
port-object eq ftp-data
port-object eq www
port-object eq https
group-object Radmin
group-object rdc
object-group service SAN tcp
description 2681
port-object eq 3260
port-object eq 2681
object-group service DM_INLINE_TCP_7 tcp
group-object Radmin
group-object TLS-ftp
group-object rdc
group-object SAN
object-group service DM_INLINE_TCP_8 tcp
group-object Radmin
group-object TLS-ftp
group-object rdc
object-group protocol DM_INLINE_PROTOCOL_5
protocol-object udp
protocol-object tcp
object-group service ExchangeOWA tcp
description RPC
port-object eq pop2
port-object eq pop3
port-object eq smtp
port-object eq www
port-object eq https
port-object eq 465
port-object eq 993
port-object eq imap4
port-object eq 6001
port-object eq 6002
port-object eq 6004
port-object eq 135
port-object eq 445
port-object eq 593
object-group service DM_INLINE_TCP_10 tcp
group-object ExchangeOWA
group-object rdc
group-object TLS-ftp
object-group service DM_INLINE_TCP_9 tcp
group-object ExchangeOWA
group-object rdc
group-object Radmin
object-group service DM_INLINE_TCP_11 tcp
group-object Radmin
group-object rdc
object-group network InsideServers
network-object host OtherCompanyMailInside
network-object host CompanyNameSageInside
network-object host CompanyNameSANINside
network-object host RubbenInside
network-object host ArchieInside
network-object host VincentInside
network-object host Web2016Inside
network-object host TDAMailInside
network-object host OldRubbenInside
object-group network VPN_CompanyName
network-object host OtherCompanyMailInside
network-object host CompanyNameSageInside
network-object host CompanyNameSANINside
network-object host ArchieInside
object-group service DM_INLINE_TCP_12 tcp
group-object ExchangeOWA
group-object Radmin
group-object rdc
object-group network SANclients
network-object host ArchieInside
network-object host Web2016Inside
network-object host Archie
network-object host Web2016
access-list outside_access_in extended permit udp host MyHome host Web2016
access-list outside_access_in extended permit tcp any host OtherCompanyMailOutside object-group DM_INLINE_TCP_12
access-list outside_access_in extended permit tcp any host CompanyNameSageOutside object-group DM_INLINE_TCP_11
access-list outside_access_in extended permit icmp any host TDAMailOutside
access-list outside_access_in extended permit tcp any host TDAMailOutside object-group DM_INLINE_TCP_10
access-list outside_access_in extended permit tcp any host ORubben object-group DM_INLINE_TCP_8
access-list outside_access_in extended permit tcp any host Vincent object-group DM_INLINE_TCP_6
access-list outside_access_in extended permit tcp any host Rubben object-group DM_INLINE_TCP_5
access-list outside_access_in extended permit tcp any host Web2016 object-group DM_INLINE_TCP_4
access-list outside_access_in extended permit tcp any host Archie object-group DM_INLINE_TCP_3
access-list outside_access_in extended permit icmp any any log disable
access-list outside_access_in extended permit object-group TCPUDP object-group OfficeHome any log disable
access-list outside_access_in extended permit object-group TCPUDP any object-group WebServer eq www log disable
access-list outside_access_in extended permit tcp any object-group FtpServer eq ftp log disable
access-list outside_access_in extended permit tcp any object-group FtpServer eq ftp-data log disable
access-list outside_access_in extended permit object-group TCPUDP any object-group DnsServer eq domain log disable
access-list outside_access_in extended permit tcp any object-group EmailServer object-group DM_INLINE_TCP_9 log disable
access-list outside_access_in extended permit tcp any object-group WebServer eq https log disable
access-list outside_access_in extended permit tcp any object-group WebServer eq ssh log disable
access-list outside_access_in extended permit ip object-group OfficeHome any log disable
access-list outside_access_in extended permit tcp any object-group FtpServer object-group TLS-ftp log disable
access-list outside_access_in extended permit tcp object-group FtpServer any object-group TLS-ftp log disable
access-list outside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 host MyHome host ArchieInside log disable
access-list outside_access_in extended permit icmp any object-group EmailServer
access-list outside_access_in extended permit tcp object-group SANclients host SAN object-group SAN log disable
access-list inside_access_in extended permit object-group TCPUDP any any log disable
access-list inside_access_in extended permit icmp any any log disable
access-list inside_access_in extended permit tcp any any object-group DM_INLINE_TCP_7 log disable
access-list inside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 any any
access-list inside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 object-group SANclients host SAN log disable
access-list inside_access_in_1 extended permit ip object-group OfficeHome any log disable
access-list inside_access_in_1 extended permit ip object-group WebServer any log disable
access-list inside_access_in_1 extended permit ip host Rubben any log disable
access-list outside_access_in_1 extended permit tcp any object-group WebServer object-group DM_INLINE_TCP_0 log disable
access-list outside_access_in_1 extended permit tcp any object-group FtpServer object-group DM_INLINE_TCP_1 log disable
access-list outside_access_in_1 extended permit icmp any any
access-list outside_access_in_1 extended permit object-group DM_INLINE_PROTOCOL_1 host MyHome any log disable
access-list outside_access_in_1 extended permit object-group DM_INLINE_PROTOCOL_1 any object-group DnsServer eq domain
access-list outside_access_in_1 extended permit tcp any object-group EmailServer object-group DM_INLINE_TCP_2
access-list inside_access_in_2 extended permit object-group TCPUDP any any
access-list inside_access_in_2 extended permit ip any any log disable
access-list inside_access_in_2 extended permit object-group DM_INLINE_PROTOCOL_3 any any
access-list inside_nat0_outbound extended permit ip any 192.168.68.128 255.255.255.192
access-list inside_nat0_outbound extended permit ip any 192.168.98.32 255.255.255.224
access-list inside_nat0_outbound extended permit ip any 192.168.98.96 255.255.255.224
access-list inside_nat0_outbound extended permit ip any 192.168.98.128 255.255.255.240
access-list DefaultRAGroup_splitTunnelAcl standard permit host WhatIsMyIP
access-list DefaultRAGroup_splitTunnelAcl standard permit 192.168.98.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
logging mail errors
logging from-address <admin email address>
logging recipient-address <admin email address> level critical
mtu outside 1500
mtu inside 1500
ip local pool VPN_pool 192.168.98.40-192.168.98.49 mask 255.255.255.0
ipv6 access-list inside_access_ipv6_in permit ip any any log disable
ipv6 access-list inside_access_ipv6_in permit object-group DM_INLINE_PROTOCOL_1 any any
ipv6 access-list inside_access_ipv6_in permit icmp6 any any log disable
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 0 0.0.0.0 0.0.0.0
nat (inside) 0 0.0.0.0 0.0.0.0 outside
static (inside,outside) Archie ArchieInside netmask 255.255.255.255 dns
static (inside,outside) Web2016 Web2016Inside netmask 255.255.255.255 dns
static (inside,outside) Rubben RubbenInside netmask 255.255.255.255 dns
static (inside,outside) Vincent VincentInside netmask 255.255.255.255 dns
static (inside,outside) ORubben OldRubbenInside netmask 255.255.255.255 dns
static (inside,outside) TDAMailOutside TDAMailInside netmask 255.255.255.255 dns
static (inside,outside) OtherCompanyMailInside OtherCompanyMailOutside netmask 255.255.255.255 dns
static (inside,outside) CompanyNameSageOutside CompanyNameSageInside netmask 255.255.255.255 dns
static (inside,outside) OtherCompanyMailOutside OtherCompanyMailInside netmask 255.255.255.255 dns
static (inside,inside) SAN SAN netmask 255.255.255.255 dns
access-group outside_access_in in interface outside
access-group inside_access_in_1 in interface inside control-plane
access-group inside_access_in in interface inside
access-group inside_access_ipv6_in in interface inside
route outside 0.0.0.0 0.0.0.0 xx.xxx.xx.177 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http MySister 255.255.255.255 outside
http GarryHome 255.255.255.255 outside
http MyHome 255.255.255.255 outside
http 149.241.66.97 255.255.255.255 outside
http CompanyName-18 255.255.255.255 outside
http xx.xxx.xx.17 255.255.255.255 outside
http Web2016 255.255.255.255 outside
http xx.xxx.xx.126 255.255.255.255 outside
http xx.xxx.xx.107 255.255.255.255 outside
http 0.0.0.0 0.0.0.0 inside
http xx.xxx.xx.251 255.255.255.255 outside
http xx.xxx.xx.253 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt connection tcpmss 1320
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5 TRANS_ESP_3DES_SHA
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet MyHome 255.255.255.255 outside
telnet timeout 5
ssh MyHome 255.255.255.255 outside
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection scanning-threat shun except object-group OfficeHome
threat-detection scanning-threat shun duration 3600
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
group-policy DefaultRAGroup_2 internal
group-policy DefaultRAGroup_2 attributes
vpn-tunnel-protocol l2tp-ipsec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value DefaultRAGroup_splitTunnelAcl
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
vpn-tunnel-protocol l2tp-ipsec
group-policy DefaultRAGroup_1 internal
group-policy DefaultRAGroup_1 attributes
dns-server value 8.8.8.8
vpn-tunnel-protocol l2tp-ipsec
username user1 password <Password> nt-encrypted privilege 0
username user1 attributes
vpn-group-policy DefaultRAGroup_1
username user2 password <Password> nt-encrypted privilege 0
username user2 attributes
vpn-group-policy DefaultRAGroup_1
username user3 password <Password> nt-encrypted privilege 0
username user3 attributes
vpn-group-policy DefaultRAGroup_1
username user4 password <Password> nt-encrypted privilege 0
username user4 attributes
vpn-group-policy DefaultRAGroup_1
username user5 password <Password> nt-encrypted privilege 0
username user5 attributes
vpn-group-policy DefaultRAGroup_1
.
.
.
.
.

username testuser password <Password> nt-encrypted privilege 0
username testuser attributes
vpn-group-policy DefaultRAGroup_2

tunnel-group DefaultRAGroup general-attributes
address-pool VPN_pool
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key *
tunnel-group DefaultRAGroup ppp-attributes
authentication pap
authentication ms-chap-v2
tunnel-group DefaultWEBVPNGroup ppp-attributes
authentication pap
authentication ms-chap-v2
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
smtp-server xx.xxx.xx.18
prompt hostname context
Cryptochecksum:f1189495802b4b459ef4282b2aa9fe7d
: end

0 REPLIES 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: