cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3393
Views
0
Helpful
5
Replies

Teamviewer with HTTPs Proxy on Ironport S160 not working

BetonKemmlerIT
Beginner
Beginner

I activated the HTTPS Proxy on our Ironport S160 . To start with I created decrypt rule that puts all request on passthru.

Now everything is working except Teamviewer.

I created a UserAgent identity für DynGate and included this identity in the no.de rule.

A GREP gives me this output

CONNECT tunnel://master12.teamviewer.com:443/ - PASSTHRU_CUSTOMCAT_7-no.dp-useragent.dyngate.id-NONE-NONE-NONE-DefaultGroup

CONNECT tunnel://95.211.37.202:443/ - PASSTHRU_WEBCAT_7-no.dp-useragent.dyngate.id-NONE-NONE-NONE-DefaultGroup

Could anybody give me a hint as to what i need to to get Teamviewer working.

If disable the https proxy Teamviewer is working again.

5 Replies 5

donnylee
Cisco Employee
Cisco Employee

Hi,

If you are using authentication in your identity, disable authentication and try again.

thanks,

Donny

Hi Donny,

thanks for the repley.

In the identity No Authentication is selectet only the User Agent is set to DynGate.

From the grep output I take it that  for all Teamviewer trafic the correkt user agent "useragent.dyngate.id" and the correct decrytion policy "no.dp" is applied with the PASSTHRU aktion being set.

Any further insight is appriciated.

Hi Markus,

Can you share the whole access log (there should be more entries) from grep so we can look at the details from all teamviewer traffic?

Hi Donny,

thanks for your repley.

Since this went a little deeper into the ironport config then my expertise in this matter, I consultet our Cisco partner.

He found out that there is a setting that is only available through the cli that applies to this problem.

Advancedproxyconfig->MISCELLANEOUS->Would you like to block tunneling of non-SSL transactions on SSL Ports?

->Yes

I can´t say much about it but it might point someone else with the same problem in the right direction.

Anyway Teamviewer 9 is now working with https proxy enable. Teamviewer ist set on passthru.

Hello Markus,

Glad to know you could find local support to get this issue solved.

For sure this information can be used as assistance in case someone else gets into the same problem.

Thanks for sharing.

Regards,

Donny

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers